FAT32分区卦载求救!

为当前最终发行版之前的所有版本提供支持
回复
sharmy
帖子: 4
注册时间: 2005-12-12 20:59
送出感谢: 0
接收感谢: 0

FAT32分区卦载求救!

#1

帖子 sharmy » 2007-05-31 22:31

我的第三个分区hda6卦载有问题,求高手分析一下!
-----这是ls -al /media的情况-------
drwxr-xr-x 8 root root 4096 2007-05-31 21:37 .
drwxr-xr-x 21 root root 4096 2007-05-24 05:18 ..
lrwxrwxrwx 1 root root 6 2007-05-24 04:52 cdrom -> cdrom0
drwxr-xr-x 2 root root 4096 2007-05-24 04:52 cdrom0
drwx------ 8 sharmy root 4096 1970-01-01 08:00 ETERTAIN
-rw-r--r-- 1 root root 93 2007-05-31 21:37 .hal-mtab
---x--s--- 1 root root 0 2007-05-23 21:33 .hal-mtab-lock
dr-xr-xr-x 1 root plugdev 4096 2007-05-31 21:07 hda1
dr-xr-xr-x 1 root plugdev 4096 2007-05-31 21:07 hda5
drwxr-xr-x 2 sharmy root 4096 2007-05-24 04:52 hda6
drwxrwxrwx 18 root plugdev 4096 1970-01-01 08:00 hda7

--Windows下hda6是E盘,名字是ETERTAIN,


这是/etc/fstab内容
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda8
UUID=5212f54a-a7fc-41c3-bd88-824cfab9b436 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda1
UUID=12E9AD0E82199031 /media/hda1 ntfs defaults,nls=utf8,umask=000,gid=46 0 1
# /dev/hda5
UUID=4BA6B43E61B6C064 /media/hda5 ntfs defaults,nls=utf8,umask=000,gid=46 0 1
# /dev/hda6
UUID=AA3715A9B6BA9009 /media/hda6 vfat defaults,nls=utf8,umask=000,gid=46 0 1
# /dev/hda7
UUID=4595-13E1 /media/hda7 vfat defaults,utf8,umask=000,gid=46 0 1
# /dev/hda9
UUID=851ff9e2-e512-4fed-bf6a-73e9df55b9f4 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0

--------------------
进入/media/hda6里面看是空的,有建立文件的权限, ETERTAIN却不行
HH106
帖子: 81
注册时间: 2007-04-25 9:36
来自: 东莞
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 HH106 » 2007-06-01 18:56

sudo vi /etc/fstab

# /dev/hda6
UUID=AA3715A9B6BA9009 /media/hda6 vfat defaults,nls=utf8,umask=000,gid=46 0 1

# /dev/hda6
UUID=AA3715A9B6BA9009 /media/hda6 vfat defaults,utf8,umask=000,gid=46 0 1

试试
casm
帖子: 33
注册时间: 2006-07-11 11:47
来自: Dalian, China
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 casm » 2007-06-01 19:15

楼上的正解!

只要比较一下hda6和其余的windows分区有什么不同就行了,然后修改一下就行了
回复

回到 “老旧版本支持”