为什么安装程序老是报怨通不过认证?

为当前最终发行版之前的所有版本提供支持
回复
guile
帖子: 9
注册时间: 2005-09-28 1:38
来自: linux公社
送出感谢: 0
接收感谢: 0
联系:

为什么安装程序老是报怨通不过认证?

#1

帖子 guile » 2005-11-09 17:23

用apt-get安装东西,经常系统会提示安装下面通不过认证的包吗?
我用过gentoo,这在gentoo上是根本不可能的。gentoo根本不可能给你安装通不过认证的软件。
但是,为什么通不过认证,却又能够用呢?我的电脑上已经安装了很多这种软件包了。真担心是否已经中了毒。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2005-11-09 17:34

没有认证有什么关系,又不是win那套ms的认证。
gentoo不都是src的吗。当然没有这些提示了。
● 鸣学
guile
帖子: 9
注册时间: 2005-09-28 1:38
来自: linux公社
送出感谢: 0
接收感谢: 0
联系:

遇上个比我菜的,赫赫

#3

帖子 guile » 2005-11-09 17:47

gentoo是由ebuild来控制软件的安装的。
太首先要下载源码包。如果,下载的源码包(tar。gz或tar。bz2)通不过md5校验,那么它就拒绝解包这个软件,更别说安装了。
软件包的md5信息是存在相应目录下的digest文件中的。是在你执行emerge sync的时候,桐ebuild文件一并下载下来的。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2005-11-09 18:22

md5什么意思。只是保证文件是正式发行的。你现在得到警告的包,哪个不是带md5。
● 鸣学
头像
oneleaf
论坛管理员
帖子: 10209
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#5

帖子 oneleaf » 2005-11-09 18:37

没有认证的包其实都是ubuntu-cn自己的包,我们正在想办法解决这个问题。主要是由于包没有得到官方签名,所以出来提示。
回复

回到 “老旧版本支持”