[问题]jdk安装到了哪里(6.10)~~~?

为当前最终发行版之前的所有版本提供支持
回复
头像
why_790721
帖子: 295
注册时间: 2006-12-01 22:28
送出感谢: 0
接收感谢: 0

[问题]jdk安装到了哪里(6.10)~~~?

#1

帖子 why_790721 » 2007-06-03 13:20

如题:
头像
依寻依然
帖子: 1617
注册时间: 2006-10-31 14:49
送出感谢: 0
接收感谢: 0

#2

帖子 依寻依然 » 2007-06-03 13:30

/usr/lib/jvm
Borders are meant to be crossed
头像
why_790721
帖子: 295
注册时间: 2006-12-01 22:28
送出感谢: 0
接收感谢: 0

#3

帖子 why_790721 » 2007-06-03 13:38

楼上的能不能说的再详细一些呀,我在里面照了很长时间也没找到。你帮我看看这句话:
Testing /usr/bin/X11/java...
Exception in thread "main" java.lang.ClassFormatError: Extra bytes at the end of class file com/sun/kvem/environment/JavaVersionTester
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$000(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

No suitable Java interpreter was detected

0) Specify a path to a Java interpreter directory.
1) Cancel this installation.
Select a choice [0-1]: 0

This application requires Java 2 SDK, Standard Edition (1.4 or later). Enter a path to a Java 2 SDK (For example: /user/jdk1.4/bin). You can type "exit" to cancel installation.
Enter a path to the Java 2 SDK
:
头像
why_790721
帖子: 295
注册时间: 2006-12-01 22:28
送出感谢: 0
接收感谢: 0

#4

帖子 why_790721 » 2007-06-03 15:04

难道就没有人知道吗?
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#5

帖子 avauntage » 2007-06-03 15:17

快速指南
另外,在~/.bashrc中加入
export JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun
export PATH="${PATH}:${JAVA_HOME}/bin"
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
回复

回到 “老旧版本支持”