当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 一块硬盘,双OS,如此分区怎么不行?(已解决)
帖子发表于 : 2007-06-03 18:05 

注册: 2007-05-29 6:18
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
一块硬盘,C、D、E给XP用一半,剩下给UBUNTU7.04用。C:主分区。下面(包括linux)为扩展分区。先装XP后,再装UBUNTU,安装成功。UBUNTU分区:
/ 10G ReiserFS
/boot 56M ext3
/home 20G ReiserFS
swap 1024M
这样安装后,UBUNTU能正常启动,XP能进入启动状态,但启动到一半时蓝屏。用diskgen查看分区信息,报告扩展分区和/home分区有非法参数。此时硬盘在DOS下看得到C、D、E盘信息,但执行FDISK命令返回:error reading fixed disk.我只好把整个扩展分区删除重建,硬盘才恢复正常。我第一次装UBUNTU时如下分区,XP和LINUX都能正常启动:
swap
/ EXT3
/boot EXT3
/home ext3
请问大X们:1、造成硬盘分区信息错误的原因是swap不能在硬盘最后一个分区吗?为什么 ?还是别的什么?
2、此时可用diskgen修正分区错误参数吗?怎么改?


最后由 online 编辑于 2007-06-05 10:29,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-06-03 20:05 

注册: 2007-05-06 2:18
帖子: 527
送出感谢: 0 次
接收感谢: 0 次
我的SWAP就是在最后一个分区的
我单独给ubuntu分两个分区
一个是/一个是swap
我不和WIN搅在一起的


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-06-03 20:22 

注册: 2007-05-29 6:18
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
总不可能是同时用了EXT3和ReiserFS 造成的。开始以为是XP自己崩溃,就删除了整个扩展分区,重新装了UBUNTU一遍,问题依然。另:上楼的,我也没把UBUNTU与WIN搅在一起呀。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-06-04 12:15 

注册: 2007-05-29 6:18
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
没人回答,顶一下


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-06-05 12:10 

注册: 2007-05-29 6:18
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
经过反复摸索,终于找到原因。都是隐藏分区惹的祸。联想硬盘设了个该死的隐藏分区,在bios 和fdisk下都看不见,linux分区工具看到的空白分区包含了隐藏分区的,但没法用它,所以分区表会出错。我用delhpa把隐藏分区删除再装就正常了。奇怪的是第一次安装时怎么没出错?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译