当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如何恢复主盘的mbr?
帖子发表于 : 2005-11-10 12:12 

注册: 2005-11-08 22:16
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
两块硬盘,主盘win2k,从盘win98和ubuntu。

摘走从盘后,win2k启动不了了。怎么恢复啊?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-11-10 13:25 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
fdisk /mbr 试试??


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-11-10 13:44 

注册: 2005-05-08 13:25
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
试一下
dos下键入 fdisk /mbr
再看一下主盘的主分区有活动标志的么
可以用diskgenius 等工具

不过可能不行


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-11-10 13:57 

注册: 2005-09-13 21:18
帖子: 173
送出感谢: 0 次
接收感谢: 2
对啊~我也是认为如果我删除了Ubuntu. 那么我还能正常的进入我的XP吗?  


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-11-10 16:02 

注册: 2005-11-08 22:16
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
4321go 写道:
对啊~我也是认为如果我删除了Ubuntu. 那么我还能正常的进入我的XP吗?  


这个好解决。以下引用自http://www.netadmin.com.cn/experience/20040702/3496.asp

如果你想删除Linux,可以使用Windows XP安装光盘启动,然后选择在故障恢复控制台中修复,进入故障恢复控制台以后,输入Administrator账户密码,接着执行fixmbr和fixboot 两个命令,最后执行exit命令重新启动以后就可以删除安装Linux时写入的MBR了。另外,由于fdisk不认识EXT文件系统,所以建议使用Windows XP里面的磁盘管理工具删除和格式化安装有Linux的分区,操作步骤是:“开始”--“运行”里面输入“compmgmt.msc”打开计算机管理,点击“储存”下面的“磁盘管理”,找到安装有Linux的分区,鼠标右键点击,选择删除逻辑驱动器即可释放空间,然后重新分区、格式化被删除的分区为Windows能够识别的文件系统即可。

我刚试过了,用win2k的启动盘启动至故障恢复台,fixmbr然后fixboot,重起后可以进入win2k了。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-11-10 16:04 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
只有这个fdisk /mbr最方便了。是纯dos下面。


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-11-10 23:27 

注册: 2005-11-08 22:16
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
windows是行了,辛辛苦苦配置好的ubuntu可引导不了了。

狠狠心重新安装时,这回学乖了,grub不装在mbr上,结果grub引导

的时候只有win一个选项,偶真是欲哭无泪啊,再重新安装...安装过程中

出现乱码......今天真是倒霉透顶了!


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-11-10 23:36 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
zard 写道:
windows是行了,辛辛苦苦配置好的ubuntu可引导不了了。

狠狠心重新安装时,这回学乖了,grub不装在mbr上,结果grub引导

的时候只有win一个选项,偶真是欲哭无泪啊,再重新安装...安装过程中

出现乱码......今天真是倒霉透顶了!

你不是摘走了吗?怎么引导?
如果只是引导及分区位置调整的问题,不用急着重装,有好多工具可以解决,比如grub2dos,loadin等.现在的话试试把linux启动分区设为活动分区试试,不行还是用grub2dos,去引导linux再重安装grub就可以了.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-11-11 7:20 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
grub当然是在mbr。谁说的不安装到哪里。
可以到主页认真看一下如何恢复。很简单的。


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译