不能上网如何装软件?(已解決部分,正在解决)

为当前最终发行版之前的所有版本提供支持
zwither
帖子: 9
注册时间: 2005-11-07 14:49
送出感谢: 0
接收感谢: 0

不能上网如何装软件?(已解決部分,正在解决)

#1

帖子 zwither » 2005-11-11 13:09

最近安了ubuntu510,因为在学校是通过锐捷认证软件上网的,安装了认证的程序运行,发现需要libpcap库的支持,于是从另一台win机上下了libpcap的源码,准备编译,运行了configure,提示没有gcc,没有cc
于是,我又下载了gcc-4.0.2-tar.bz2解压道/usr/src/gcc-4.0.2
cd /usr/src/gcc-4.0.2
运行./configure
提示:configure:error:Building in the source directory is not supported in this release.
于是我又cd /usr/src
运行./gcc-4.0.2/configure
提示:checking for gcc...no
checking for cc.....no
configure:error:no acceptable cc found in $PATH
大概就是安装gcc的源码也要gcc进行编译,可是我是没有gcc才安装gcc的啊,

文档里的东西大都是从网上直接安装的,可是我要先安装源码才能上网,这个怎么解决,难道ubuntu里没有gcc,如果有,路径在哪里,没有的话,在不能上网的前提下,如何安装源码啊?

The title was edited by millenniumdark on 2005。11。11
上次由 zwither 在 2005-11-11 16:48,总共编辑 1 次。
ifu
帖子: 130
注册时间: 2005-10-25 15:08
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 ifu » 2005-11-11 13:21

你可以从别人的电脑上复制他apt-get下来的gcc的deb包来装啊。
ifu
帖子: 130
注册时间: 2005-10-25 15:08
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 ifu » 2005-11-11 13:22

或者直接从网上下这个deb包。
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#4

帖子 oneleaf » 2005-11-11 13:30

先用代理上。安装好编译环境。
zwither
帖子: 9
注册时间: 2005-11-07 14:49
送出感谢: 0
接收感谢: 0

#5

帖子 zwither » 2005-11-11 13:53

回ifu:我这个屋只有我用Linux,我直接用win机下Deb包试一试,顺便,我不太了解deb包,这个就不用编译了吗?直接就可以用的?

回oneleaf:不能用代理,必须先运行认证软件才能上,有那个验证服务器有检测功能,不允许用通过局域网的代理上。郁闷。
头像
max0000
帖子: 310
注册时间: 2005-04-08 14:54
送出感谢: 0
接收感谢: 0

#6

帖子 max0000 » 2005-11-11 14:14

你怎么装的5.10?
用cdrom的话还是先从本地把build-essential装上吧!
zwither
帖子: 9
注册时间: 2005-11-07 14:49
送出感谢: 0
接收感谢: 0

#7

帖子 zwither » 2005-11-11 14:17

知道了
sudo dpkg -i package_file.deb
谢谢大家了,^_^,安上gcc-4了
zwither
帖子: 9
注册时间: 2005-11-07 14:49
送出感谢: 0
接收感谢: 0

#8

帖子 zwither » 2005-11-11 15:07

我是默认安装的啊,就是安装时不输入:server,直接按回车。为什么,是不是系统安了gcc但不在$PATH里啊?
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#9

帖子 oneleaf » 2005-11-11 15:09

zwither 写了:回ifu:我这个屋只有我用Linux,我直接用win机下Deb包试一试,顺便,我不太了解deb包,这个就不用编译了吗?直接就可以用的?

回oneleaf:不能用代理,必须先运行认证软件才能上,有那个验证服务器有检测功能,不允许用通过局域网的代理上。郁闷。


有听说可以使用sock5的代理可以通过。
zwither
帖子: 9
注册时间: 2005-11-07 14:49
送出感谢: 0
接收感谢: 0

#10

帖子 zwither » 2005-11-11 16:04

请问需要的libpcap.so.0.6.2有deb包吗?我安了libpcap0.8不行
zwither
帖子: 9
注册时间: 2005-11-07 14:49
送出感谢: 0
接收感谢: 0

#11

帖子 zwither » 2005-11-11 16:06

还有如果要安装rpm源,需要安什么程序啊?在kubuntu下面。
ifu
帖子: 130
注册时间: 2005-10-25 15:08
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 ifu » 2005-11-11 16:23

alien -i xxxxx.rpm
不过可能要先安装alien,找deb包装。
zwither
帖子: 9
注册时间: 2005-11-07 14:49
送出感谢: 0
接收感谢: 0

#13

帖子 zwither » 2005-11-11 16:43

刚才看了技术文档,知道了alien -i ***.rpm
我安装了alien的deb包,运行
alien -i /usr/src/libccap-0.6.2-11.i386.rpm 没成功,系统下面提示:
sh:rpm:command not found
Error executing "LANG=C rpm -qp --queryformat............"
at /usr/share/perl5/Alien/Package.prm line 466
这是怎么回事啊。。不明白了
zwither
帖子: 9
注册时间: 2005-11-07 14:49
送出感谢: 0
接收感谢: 0

#14

帖子 zwither » 2005-11-11 16:45

弄了一下午了。google了无数次,现在还没搞定。。。。。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#15

帖子 eexpress » 2005-11-11 17:01

rpm的有很多种情况。alien不一定合适的。要自己看rpm的情况而定。一般是直接释放。有的还是个编译包呢。
● 鸣学
回复

回到 “老旧版本支持”