flash 安装出错(已经解决)

为当前最终发行版之前的所有版本提供支持
回复
库页王
帖子: 166
注册时间: 2007-06-01 16:32
送出感谢: 0
接收感谢: 0

flash 安装出错(已经解决)

#1

帖子 库页王 » 2007-06-07 20:13

我在装flash的时候 出现一下错误,清达人指教:
linyetian@ubuntu:~/software/install_flash_player_9_linux$ sudo ./flashplayer-installer

ERROR: Your architecture, \'x86_64\', is not supported by the
Adobe Flash Player installer.


具体的原文请看:
http://ubuntuforums.org/showthread.php?t=290785

。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。
Get the Mandrake nspluginwrapper packages


http://gwenole.beauchesne.info/proje...3-1.x86_64.rpm
http://gwenole.beauchesne.info/proje...3-1.x86_64.rpm

Get Flash 9 from Adobe


http://www.adobe.com/shockwave/downl...ShockwaveFlash

Unpack the installer, and locate the libflashplayer.so file

Install the 32 bit wrapper (linux32) and the package conversion tool (alien)

Quote:
sudo apt-get install ia32-libs lib32asound2 lib32ncurses5 ia32-libs-sdl ia32-libs-gtk gsfonts gsfonts-x11 linux32
sudo apt-get install alien
Proceding with the installation for gnome browsers

Quote:
sudo ln -s /usr/lib/nspluginwrapper/x86_64/npconfig /usr/bin/nspluginwrapper
sudo alien -d nspluginwrapper*.rpm
sudo dpkg -i nspluginwrapper*.deb
sudo mkdir /usr/lib/mozilla/plugins32
sudo cp {path to}/libflashplayer.so /usr/lib/mozilla/plugins32
sudo nspluginwrapper -i /usr/lib/mozilla/plugins32/libflashplayer.so
Making the plugin available for Firefox

Quote:
sudo ln -s /usr/lib/mozilla/plugins/npwrapper.so /usr/lib/mozilla-firefox/plugins/
sudo ln -s /usr/lib/mozilla/plugins/npwrapper.libflashplayer.so /usr/lib/mozilla-firefox/plugins/
上次由 库页王 在 2007-06-08 17:41,总共编辑 1 次。
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#2

帖子 xhy » 2007-06-07 20:40

amd64的机器
如果需要在64位的firefox中使用flash插件
不可以直接安装 需要通过nspluginswrapper间接安装

或者直接在AMD64的系统里装32位的firefox
回复

回到 “老旧版本支持”