[问题]制作本地源的时候怎样自动清除低版本的deb?

为当前最终发行版之前的所有版本提供支持
回复
头像
fanhe
帖子: 2357
注册时间: 2007-03-24 23:45
送出感谢: 0
接收感谢: 9 次

[问题]制作本地源的时候怎样自动清除低版本的deb?

#1

帖子 fanhe » 2007-06-10 13:21

如题,资源列表都乱了,只剩下一堆deb,低版本和高版本都有,请问怎样清除低版本的deb,然后制作本地源?
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 skyx » 2007-06-11 12:13

招唤雕
no security measure is worth anything if an attacker has physical access to the machine
rainytooo
帖子: 52
注册时间: 2006-12-30 7:44
送出感谢: 0
接收感谢: 0

#3

帖子 rainytooo » 2007-06-11 13:23

等待雕
tourist
帖子: 39
注册时间: 2007-06-08 11:46
送出感谢: 0
接收感谢: 0

#4

帖子 tourist » 2007-06-11 14:41

sudo apt-get autoclean(只删除低版本的deb包),sudo apt-get clean(全部删除)


这也是我刚看别人帖子看到的 ,搂主可以试下,这是手工删除吧 呵呵 不是你说的自动删除
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

Re: [问题]制作本地源的时候怎样自动清除低版本的deb?

#5

帖子 skyx » 2007-06-11 15:31

fanhe 写了:如题,资源列表都乱了,只剩下一堆deb,低版本和高版本都有,请问怎样清除低版本的deb,然后制作本地源?


不删是否也可行,招唤雕,


如果不删,建立依赖时会不会把低版本忽略?

手上没有ubuntu , 所以没法看debian参考手册


招唤雕
no security measure is worth anything if an attacker has physical access to the machine
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#6

帖子 skyx » 2007-06-11 15:57

如果不删,建立依赖时会不会把低版本忽略?

手上没有ubuntu , 所以没法看debian参考手册


招唤雕
no security measure is worth anything if an attacker has physical access to the machine
雕啸长空
帖子: 1897
注册时间: 2006-09-12 14:09
送出感谢: 0
接收感谢: 0

#7

帖子 雕啸长空 » 2007-06-11 15:58

看系统提示,稍整理一个可以得到丢弃列表,然后怎么个删法就看个人喜好了。

另,apt-get clean这类的清除命令只对/var/cache/apt/arvhicves目录下的包起作用

代码: 全选

fideas@zerone:/media/soft/packs$ sudo dpkg-scanpackages kde357/ /dev/null |gzip >kde357/Packages.gz
 ! Package kdelibs4c2a (filename kde357//kdelibs/kdelibs4c2a_3.5.7-0ubuntu1~feisty2_i386.deb) is repeat but newer version;
   used that one and ignored data from kde357//kdelibs/kdelibs4c2a_3.5.7-0ubuntu1~feisty1_i386.deb !
 ! Package kdelibs-data (filename kde357//kdelibs/kdelibs-data_3.5.7-0ubuntu1~feisty1_all.deb) is repeat;
   ignored that one and using data from kde357//kdelibs/kdelibs-data_3.5.7-0ubuntu1~feisty2_all.deb !
 ! Package kdelibs (filename kde357//kdelibs/kdelibs_3.5.7-0ubuntu1~feisty2_all.deb) is repeat but newer version;
   used that one and ignored data from kde357//kdelibs/kdelibs_3.5.7-0ubuntu1~feisty1_all.deb !
 ! Package kdelibs4-doc (filename kde357//kdelibs/kdelibs4-doc_3.5.7-0ubuntu1~feisty2_all.deb) is repeat but newer version;
   used that one and ignored data from kde357//kdelibs/kdelibs4-doc_3.5.7-0ubuntu1~feisty1_all.deb !
 ! Package kdelibs-dbg (filename kde357//kdelibs/kdelibs-dbg_3.5.7-0ubuntu1~feisty2_i386.deb) is repeat but newer version;
   used that one and ignored data from kde357//kdelibs/kdelibs-dbg_3.5.7-0ubuntu1~feisty1_i386.deb !
 ! Package kdelibs4-dev (filename kde357//kdelibs/kdelibs4-dev_3.5.7-0ubuntu1~feisty1_i386.deb) is repeat;
   ignored that one and using data from kde357//kdelibs/kdelibs4-dev_3.5.7-0ubuntu1~feisty2_i386.deb !
 ** Packages in archive but missing from override file: **
Fair winds and following seas !
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#8

帖子 skyx » 2007-06-11 16:00

也就是不用删了

但我只想把这里面的低版本做成本地源,该如何操作?比如原来6.10 和7.04的混在一起了,都在一个目录中

谢谢楼上现身,学习了
no security measure is worth anything if an attacker has physical access to the machine
回复

回到 “老旧版本支持”