[分享]Ubuntu软件升级思路

为当前最终发行版之前的所有版本提供支持
头像
KSKY
帖子: 358
注册时间: 2007-01-20 20:57
送出感谢: 0
接收感谢: 0

[分享]Ubuntu软件升级思路

#1

帖子 KSKY » 2007-06-11 11:05

一直想把ubuntu的一些软件升级到新版本,可是自己编译老是容易出错。网上又没有提供的deb安装包。
昨天看见有些朋友都把ubuntu升级到了7.10.本来决定当回小白鼠也升下的。修改了源update一下。又害怕把自己的系统再搞坏。图标提示发现新的更新。点开一看,这么多软件都换到了新版。正好升级下我一直寻找的最新软件。GIMP 2.3 Mplayer Audacious ,升级啊!

把源改成gutsy的

代码: 全选

    sudo sed -i ’s/feisty/gutsy/’ /etc/apt/sources.list
    sudo apt-get update
    sudo apt-get install gimp mplayer audacious
为了放心,换回 Feisty 源

代码: 全选

    sudo sed -i ’s/gutsy/feisty/’ /etc/apt/sources.list
为了放心,还是用回feisty吧。小白鼠还是叫他们去做吧!
可以用这个方法使用gutsy的软件和Feisty 的源哦!

原文来自[何必呢]
头像
KSKY
帖子: 358
注册时间: 2007-01-20 20:57
送出感谢: 0
接收感谢: 0

#2

帖子 KSKY » 2007-06-11 11:06

图片
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 skyx » 2007-06-11 11:12

学习



只是升多了,很多包说不定也会变成7.10的,有问题就不太好办。


我倒觉得如果硬件比较新,7.04的内核又不支持,个人又不愿自己译内核, 这时手动从7.10源中下载 7.10的内核deb安装还是简单可行
no security measure is worth anything if an attacker has physical access to the machine
头像
KSKY
帖子: 358
注册时间: 2007-01-20 20:57
送出感谢: 0
接收感谢: 0

#4

帖子 KSKY » 2007-06-11 11:16

只是部分升级软件 所以不存在你说得问题
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 skyx » 2007-06-11 11:19

KSKY 写了:只是部分升级软件 所以不存在你说得问题
学习
no security measure is worth anything if an attacker has physical access to the machine
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#6

帖子 dbzhang800 » 2007-06-11 11:35

KSKY 写了:只是部分升级软件 所以不存在你说得问题
风险还是比较大的,其实
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 skyx » 2007-06-11 11:36

dbzhang800 写了:
KSKY 写了:只是部分升级软件 所以不存在你说得问题
风险还是比较大的,其实
学习
no security measure is worth anything if an attacker has physical access to the machine
头像
KSKY
帖子: 358
注册时间: 2007-01-20 20:57
送出感谢: 0
接收感谢: 0

#8

帖子 KSKY » 2007-06-11 11:42

dbzhang800 写了:
KSKY 写了:只是部分升级软件 所以不存在你说得问题
风险还是比较大的,其实
这和你用编译好的deb没什么两样!
雕啸长空
帖子: 1897
注册时间: 2006-09-12 14:09
送出感谢: 0
接收感谢: 0

#9

帖子 雕啸长空 » 2007-06-11 12:15

KSKY 写了:
dbzhang800 写了:
KSKY 写了:只是部分升级软件 所以不存在你说得问题
风险还是比较大的,其实
这和你用编译好的deb没什么两样!
除非你这个包是孤岛.
Fair winds and following seas !
头像
KSKY
帖子: 358
注册时间: 2007-01-20 20:57
送出感谢: 0
接收感谢: 0

#10

帖子 KSKY » 2007-06-11 13:55

雕啸长空 写了:
KSKY 写了:
dbzhang800 写了:
KSKY 写了:只是部分升级软件 所以不存在你说得问题
风险还是比较大的,其实
这和你用编译好的deb没什么两样!
除非你这个包是孤岛.
你装deb也不是需要依赖包???
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#11

帖子 xhy » 2007-06-11 14:35

风险的确相当大
曾经因为这个破坏过依赖关系
把locale的一个组建破坏掉

假如包A依赖包B
而7.04的里面包A和包B都是老版本的

使用apt-get 会强制将包B也升级

而直接安装deb 不会强制升级包B 只要老的包B能支持新包A

apt-get 要求包是配套的最新版
dpkg 仅仅要求版本 >= XXX
目前负债150多万
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#12

帖子 skyx » 2007-06-11 15:50

xhy 写了:风险的确相当大
曾经因为这个破坏过依赖关系
把locale的一个组建破坏掉

假如包A依赖包B
而7.04的里面包A和包B都是老版本的

使用apt-get 会强制将包B也升级

而直接安装deb 不会强制升级包B 只要老的包B能支持新包A

apt-get 要求包是配套的最新版
dpkg 仅仅要求版本 >= XXX

我估计出问题的不一定是楼上所说的依赖问题,因为单纯的so文件依赖升级后应该也没什么问题。


比如ubuntu 7.04 通过改为7.10的源 apt-get 安装7.10 的软件a ,如果a依赖7.10的软件b 和c ,当然b c都会升级。 软件a 的使用不会有什么影响


但原来7.04 的软件中d也依赖软件b 和c ,出问题的可能是软件 d

对于d来说, b 和c 不一定是单纯的so文件,b c 可能存在与之对应的配制文件, 但7.04 和7.10 的b c 二者配制文件有可能不相容,这样软件d如果要用 b c 的配制,d也就不正常了



估计问题还不仅仅是配制文件,依赖问题也不仅是这些,我觉得影响其它软件的正常使用可能性最大


我不懂程式编写,以上是我瞎想的,如果想错了,请不要对我进行人身攻击


ubuntu/debian的优势应该就在于源中的软件把全部关系都理顺了。但源混用又会破坏这种优势
no security measure is worth anything if an attacker has physical access to the machine
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#13

帖子 xhy » 2007-06-11 18:03

很少有软件配置文件不向下兼容的

不兼容主要是功能性的 而不是配置性的

否则做LFS的时候就没必要一遍遍的调整工具链了 直接改配置文件就得了
目前负债150多万
99392006
帖子: 8
注册时间: 2007-06-10 8:24
送出感谢: 0
接收感谢: 0

#14

帖子 99392006 » 2007-06-11 18:56

KSKY 写了:图片
你的是什么主题?
头像
KSKY
帖子: 358
注册时间: 2007-01-20 20:57
送出感谢: 0
接收感谢: 0

#15

帖子 KSKY » 2007-06-11 21:16

ubuntustudio
回复

回到 “老旧版本支持”