安装 oracle是出现错误 关于njni10的错误

为当前最终发行版之前的所有版本提供支持
回复
xmvigour
帖子: 41
注册时间: 2005-11-10 15:42
送出感谢: 0
接收感谢: 0

安装 oracle是出现错误 关于njni10的错误

#1

帖子 xmvigour » 2005-11-13 14:31

UnsatisfiedLinkError exception loading native library: njni10
以下是错误信息

代码: 全选

Output generated from configuration assistant "Oracle Net Configuration Assistant":
Command = /opt/oracle/product/10.2.0/db_1/jdk/jre//bin/java   -Duser.dir=/opt/oracle/product/10.2.0/db_1/network/jlib -classpath /opt/oracle/product/10.2.0/db_1/jdk/jre//lib/i18n.jar:/opt/oracle/product/10.2.0/db_1/jdk/jre//lib/rt.jar:/opt/oracle/product/10.2.0/db_1/jlib/ewt3.jar:/opt/oracle/product/10.2.0/db_1/jlib/ewtcompat-3_3_15.jar:/opt/oracle/product/10.2.0/db_1/jlib/netcfg.jar:/opt/oracle/product/10.2.0/db_1/network/jlib/netcam.jar:/opt/oracle/product/10.2.0/db_1/network/jlib/netca.jar:/opt/oracle/product/10.2.0/db_1/jlib/help4.jar:/opt/oracle/product/10.2.0/db_1/jlib/jewt4.jar:/opt/oracle/product/10.2.0/db_1/jlib/oracle_ice.jar:/opt/oracle/product/10.2.0/db_1/jlib/share.jar:/opt/oracle/product/10.2.0/db_1/jlib/swingall-1_1_1.jar:/opt/oracle/product/10.2.0/db_1/jlib/srvmhas.jar:/opt/oracle/product/10.2.0/db_1/jlib/srvm.jar:/opt/oracle/product/10.2.0/db_1/network/tools:/opt/oracle/product/10.2.0/db_1/jlib/ldapjclnt9.jar:/opt/oracle/product/10.2.0/db_1/jlib/ldapjclnt10.jar:/opt/oracle/product/10.2.0/db_1/oui/jlib/OraInstaller.jar:/opt/oracle/product/10.2.0/db_1/lib/xmlparserv2.jar oracle.net.ca.NetCA /orahome /opt/oracle/product/10.2.0/db_1 /orahnam OraDb10g_home1 /instype typical /inscomp client,oraclenet,javavm,server,ano /insprtcl tcp /cfg local /authadp NO_VALUE /nodeinfo NO_VALUE /responseFile /opt/oracle/product/10.2.0/db_1/network/install/netca_typ.rsp
UnsatisfiedLinkError exception loading native library: njni10



对了怎么在运行安装程序的时候 出现中文界面???我的oracle是cn99上的10g2.我的jdk是安文档里头的手动装的1.5
xmvigour
帖子: 41
注册时间: 2005-11-10 15:42
送出感谢: 0
接收感谢: 0

#2

帖子 xmvigour » 2005-11-13 21:01

请问成功安装的大大 你们的gcc是多少
今天看到有人说 装9i的时候link到gcc2。x的时候 安装过程不会出现什么*.mk编译不过去!我想10i的时候是不是也有这个问题
xmvigour
帖子: 41
注册时间: 2005-11-10 15:42
送出感谢: 0
接收感谢: 0

#3

帖子 xmvigour » 2005-11-14 12:03

哪个大大能不能把要安装之前的需要的包和怎么去装那个包的命令
比如rpm,awk之类的

我在装到一半的时候 总是提示 XXXX.mk没编译之类 要你忽视或重试的警告窗口
找了半天 都不知道什么地方错了 一路忽视下去到 装net80 splplus的时候 就停止了 出去最上头的那些错误!
都不知道怎么装下去了
回复

回到 “老旧版本支持”