在Dell Optiplex 320安装Ubuntu 7.04

为当前最终发行版之前的所有版本提供支持
回复
sundoctor
帖子: 125
注册时间: 2007-01-16 15:41
送出感谢: 0
接收感谢: 0

在Dell Optiplex 320安装Ubuntu 7.04

#1

帖子 sundoctor » 2007-06-11 23:29

Dell Optiplex 320这机器比较怪异,很多Linux发行版比如FC、suse等不能正常安装,当然经过各种方式还是可以安装,ubuntu 7.04可以正常安装,但就算安装上grub也不能引导进入系统,就算recovery mode也进入不了,网上有用lilo替换grub解决方案,本人没有用过。因现在太多的Linux发行版都己经改用grub引导,ubuntu安装时也没有提供lilo选项,改用lilo虽然不算麻烦,对于新手还是不太方便。

最简单最快的解决方案可以采用grub4dos引导,装完ubuntu7.04后重启时入Windows或者用启动LiveCD进入linux。

方法1:Windows 2k/xp/2003 下,运行附件中 grubutil-1.1-bin-w32-9 目录下的 grubinst_gui.exe ,在“磁盘”处选中ubuntu 7.04安装所在硬盘,在“选项”区选中“启动时不搜索软盘”,点击“安装”即可。

方法2:LINUX 下,假设ubuntu 7.04安装所在硬盘为 /dev/sda(注意:某些情况下,多块硬盘的情况下,ubuntu 7.04安装所在硬盘就不一定是 sda 了),进入 bootlace.com 所在目录,运行命令 sudo ./bootlace.com /dev/sda 即可。

在硬盘上找一个或新建一个 fat16/fat32/ext2/ext3 分区,将附件中的 grldr 拷至其根目录, 并在同一目录下建立 menu.lst 文件,内容如下:

timeout 10
default 0

title Ubuntu, kernel 2.6.20-15-generic
find --set-root /boot/vmlinuz-2.6.20-15-generic
kernel /boot/vmlinuz-2.6.20-15-generic root=/dev/sda3 ro splash
initrd /boot/initrd.img-2.6.20-15-generic
boot

title Ubuntu, kernel 2.6.20-15-generic (recovery mode)
find --set-root /boot/vmlinuz-2.6.20-15-generic
kernel /boot/vmlinuz-2.6.20-15-generic root=/dev/sda3 ro single
initrd /boot/initrd.img-2.6.20-15-generic
boot

title Windwos XP
rootnoverify (hd0,0)
makeactive

其中,,我的ubuntu7.04安装在第一块硬盘第三分区上,/dev/sda3表示第一块硬盘第三分区,大家可以根据自己的安装改变,当然/dev/sda3也可以用UUID替换。/boot/vmlinuz-2.6.20-15-generic 版本根据自己系统内核改变,不过我安装的ubuntu-7.04-desktop-i386.iso在没有更新升级之前是2.6.20-15。我是在一块硬盘安装多系统,在安装ubuntu之前己经WinXp,安装在硬盘第一分区上,下面内容即可引导时入WinXP
title Windwos XP
rootnoverify (hd0,0)
makeactive

重启即可看grub4dos引导项,可以成功引导进入Ubuntu。
附件
grub4dos.zip
grub for dos
(164.9 KiB) 下载 2100 次
semix
帖子: 7
注册时间: 2006-04-27 16:28
送出感谢: 0
接收感谢: 0

#2

帖子 semix » 2007-07-11 12:20

不错不错
alfa
帖子: 15
注册时间: 2007-04-09 15:53
送出感谢: 0
接收感谢: 0

#3

帖子 alfa » 2007-08-16 11:12

我就是按LZ的设置做下去的,但是为啥我的机器为啥不能启动XP和Vista呀?
机器一送来的时候按要求给安装的XP,个人习惯Vista了,所以又自己安装了Vista
昨天装的Ubuntu,遇到LZ的问题,按这个方法解决,XP和Vista进不去了:(

代码: 全选

title Windwos XP 
rootnoverify (hd0,0) 
makeactive 
这段里面,我看Grub里面写的是 (hd0,1),不管我换成什么都不能进入XP||Vista系统
总是提示错误,错误提示MBR字节数错误,所以不能引导,然而重装Ubuntu后,用Grub还能进入Vista和XP,这个会是Grub4Dos的问题么?
回复

回到 “老旧版本支持”