出现了无法装软件的问题~{已经解决}

为当前最终发行版之前的所有版本提供支持
回复
4321go
帖子: 179
注册时间: 2005-09-13 21:18
送出感谢: 0
接收感谢: 2 次

出现了无法装软件的问题~{已经解决}

#1

帖子 4321go » 2005-11-14 14:42

我从archive.ubuntu.org.cn下载了这些deb:opera.deb 和azureus.deb
没有安装成功 ,说是依赖什么东西暂时无法安装,退出后,出现了任何软件都无法安装的问题! 如下:

代码: 全选

sudo apt-get install libqt3-mt
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
  azureus: 依赖: libcommons-cli-java 但是它将不会被安装
           依赖: liblog4j1.2-java 但是它将不会被安装
           依赖: libseda-java 但是它将不会被安装
           依赖: libswt-gtk-3.1-java 但是它将不会被安装
           依赖: sun-j2re1.5 但却无法安装它 或
                   java2-runtime
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

代码: 全选

sudo apt-get install realplayer
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
  azureus: 依赖: libcommons-cli-java 但是它将不会被安装
           依赖: liblog4j1.2-java 但是它将不会被安装
           依赖: libseda-java 但是它将不会被安装
           依赖: libswt-gtk-3.1-java 但是它将不会被安装
           依赖: sun-j2re1.5 但却无法安装它 或
                   java2-runtime
  opera: 依赖: libqt3-mt (>= 3.3.4) 但是它将不会被安装 或
                 libqt3c102-mt (>= 3.3.4) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


我使用了apt-get -f install 但好象没有作用!
而且在Gnome App Install 里也出现了如下这个问题,什么操作都无法做。
附件
Screenshot.png
上次由 4321go 在 2005-11-14 19:25,总共编辑 1 次。
4321go
帖子: 179
注册时间: 2005-09-13 21:18
送出感谢: 0
接收感谢: 2 次

#2

帖子 4321go » 2005-11-14 14:48

我试了一下安装输入法,如下,当提示fcitx 已经是最新的版本了 之后,仍然出现莫名其妙的提示!

代码: 全选

sudo apt-get install fcitx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
fcitx 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
  azureus: 依赖: libcommons-cli-java 但是它将不会被安装
           依赖: liblog4j1.2-java 但是它将不会被安装
           依赖: libseda-java 但是它将不会被安装
           依赖: libswt-gtk-3.1-java 但是它将不会被安装
           依赖: sun-j2re1.5 但却无法安装它 或
                   java2-runtime
  opera: 依赖: libqt3-mt (>= 3.3.4) 但是它将不会被安装 或
                 libqt3c102-mt (>= 3.3.4) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2005-11-14 14:57

尽量到新利得里面安装。opera的不用deb。到网站下。
● 鸣学
4321go
帖子: 179
注册时间: 2005-09-13 21:18
送出感谢: 0
接收感谢: 2 次

#4

帖子 4321go » 2005-11-14 15:20

eexpress 写了:尽量到新利得里面安装。opera的不用deb。到网站下。


哦,新利得帮我修复了问题!谢谢~
回复

回到 “老旧版本支持”