求助 Skype 运行不起来 [以解决,见2楼]

为当前最终发行版之前的所有版本提供支持
回复
czhou
帖子: 28
注册时间: 2007-05-06 9:37
来自: 天津
送出感谢: 0
接收感谢: 0

求助 Skype 运行不起来 [以解决,见2楼]

#1

帖子 czhou » 2007-06-14 16:15

我的系统是6.10,Skype安装之后运行不起来,一点反应都没有。我也找不到安装路径。请高手们帮帮忙。

是不是又像OpenOffice运行不起来一样,和scim有冲突?不过我安装了scim-bridge。。。

安装过程如下:
sudo gedit /etc/apt/sources.list

在文件最后添加Skype Repository

## Official Skype Repository
deb http://download.skype.com/linux/repos/debian/ stable non-free

sudo aptitude update
sudo aptitude install skype

安装记录:

zhou@zhou-desktop:~$ sudo gedit /etc/apt/sources.list
Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Unknown message received: Invalid message: cursor_location_changed (0, 506, 4294967274,...)
Unknown message received: Invalid message: cursor_location_changed (0, 506, 4294967232,...)
sys:1: GtkWarning: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
zhou@zhou-desktop:~$ sudo aptitude update
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
Ign cdrom://Ubuntu 6.10 _Edgy Eft_ - Release i386 (20061025) edgy/main Translation-en_AU
Ign cdrom://Ubuntu 6.10 _Edgy Eft_ - Release i386 (20061025) edgy/restricted Translation-en_AU
Ign http://download.skype.com stable Release.gpg
Ign http://download.skype.com stable/non-free Translation-en_AU
Ign http://download.skype.com stable Release
Ign http://download.skype.com stable/non-free Packages
Get:1 http://download.skype.com stable/non-free Packages [705B]
Get:2 http://au.archive.ubuntu.com edgy Release.gpg [191B]
Ign http://au.archive.ubuntu.com edgy/main Translation-en_AU
Ign http://au.archive.ubuntu.com edgy/restricted Translation-en_AU
Ign http://au.archive.ubuntu.com edgy/universe Translation-en_AU
Ign http://au.archive.ubuntu.com edgy/multiverse Translation-en_AU
Get:3 http://au.archive.ubuntu.com edgy-updates Release.gpg [191B]
Ign http://au.archive.ubuntu.com edgy-updates/main Translation-en_AU
Ign http://au.archive.ubuntu.com edgy-updates/restricted Translation-en_AU
Ign http://au.archive.ubuntu.com edgy-updates/universe Translation-en_AU
Ign http://au.archive.ubuntu.com edgy-updates/multiverse Translation-en_AU
Hit http://au.archive.ubuntu.com edgy Release
Hit http://au.archive.ubuntu.com edgy-updates Release
Hit http://au.archive.ubuntu.com edgy/main Packages
Hit http://au.archive.ubuntu.com edgy/restricted Packages
Hit http://au.archive.ubuntu.com edgy/universe Packages
Hit http://au.archive.ubuntu.com edgy/multiverse Packages
Hit http://au.archive.ubuntu.com edgy/main Sources
Hit http://au.archive.ubuntu.com edgy/restricted Sources
Hit http://au.archive.ubuntu.com edgy/universe Sources
Hit http://au.archive.ubuntu.com edgy/multiverse Sources
Hit http://au.archive.ubuntu.com edgy-updates/main Packages
Hit http://au.archive.ubuntu.com edgy-updates/restricted Packages
Hit http://au.archive.ubuntu.com edgy-updates/universe Packages
Hit http://au.archive.ubuntu.com edgy-updates/multiverse Packages
Hit http://au.archive.ubuntu.com edgy-updates/main Sources
Hit http://au.archive.ubuntu.com edgy-updates/restricted Sources
Hit http://au.archive.ubuntu.com edgy-updates/universe Sources
Hit http://au.archive.ubuntu.com edgy-updates/multiverse Sources
Get:4 http://security.ubuntu.com edgy-security Release.gpg [191B]
Ign http://security.ubuntu.com edgy-security/main Translation-en_AU
Ign http://security.ubuntu.com edgy-security/restricted Translation-en_AU
Ign http://security.ubuntu.com edgy-security/universe Translation-en_AU
Ign http://security.ubuntu.com edgy-security/multiverse Translation-en_AU
Hit http://security.ubuntu.com edgy-security Release
Hit http://security.ubuntu.com edgy-security/main Packages
Hit http://security.ubuntu.com edgy-security/restricted Packages
Hit http://security.ubuntu.com edgy-security/universe Packages
Hit http://security.ubuntu.com edgy-security/multiverse Packages
Hit http://security.ubuntu.com edgy-security/main Sources
Hit http://security.ubuntu.com edgy-security/restricted Sources
Hit http://security.ubuntu.com edgy-security/universe Sources
Hit http://security.ubuntu.com edgy-security/multiverse Sources
Fetched 708B in 27s (26B/s)
Reading package lists... Done
zhou@zhou-desktop:~$ sudo aptitude install skype
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following NEW packages will be installed:
skype
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.1MB of archives. After unpacking 12.2MB will be used.
WARNING: untrusted versions of the following packages will be installed!

Untrusted packages could compromise your system's security.
You should only proceed with the installation if you are certain that
this is what you want to do.

skype

Do you want to ignore this warning and proceed anyway?
To continue, enter "Yes"; to abort, enter "No": yes
Writing extended state information... Done
Get:1 http://download.skype.com stable/non-free skype 1.3.0.53-1 [10.1MB]
Fetched 10.1MB in 3m57s (42.3kB/s)
Selecting previously deselected package skype.
(Reading database ... 111832 files and directories currently installed.)
Unpacking skype (from .../skype_1.3.0.53-1_i386.deb) ...
Setting up skype (1.3.0.53-1) ...

然后我试图从 Application -> Internet -> Skype 运行程序,可是一点反应都没有

谢谢
上次由 czhou 在 2007-06-16 14:22,总共编辑 1 次。
watson_yan
帖子: 80
注册时间: 2005-12-18 13:28
系统: 12.04
来自: JN>SD>PRC
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 watson_yan » 2007-06-14 17:53

重新安装libqt3-mt,然后在次安装skype
或者
XMODIFIERS=@im=none QT_IM_MODULE=xim skype
其他方法:http://www.cloverjune.com/read.php/157.htm
头像
TheThirdGhost
帖子: 1592
注册时间: 2006-07-23 16:25
来自: 南京
送出感谢: 0
接收感谢: 0

#3

帖子 TheThirdGhost » 2007-06-14 18:41

这东西如果不打国际长途,就没啥用了吧。
czhou
帖子: 28
注册时间: 2007-05-06 9:37
来自: 天津
送出感谢: 0
接收感谢: 0

#4

帖子 czhou » 2007-06-14 19:05

watson_yan 写了:重新安装libqt3-mt,然后在次安装skype
或者
XMODIFIERS=@im=none QT_IM_MODULE=xim skype
其他方法:http://www.cloverjune.com/read.php/157.htm
使用xmodifiers管用了,谢谢。不过我想请教一下,xmodifiers是什么?这个指令是什么意思?

另外,在请教一下怎样重新安装 libqt3-mt?是 sudo apt-get install libqt3-mt 吗?

多谢!
头像
TheThirdGhost
帖子: 1592
注册时间: 2006-07-23 16:25
来自: 南京
送出感谢: 0
接收感谢: 0

#5

帖子 TheThirdGhost » 2007-06-14 22:36

应该就是与scim的冲突问题
重新安装,推荐用sudo aptitude reinstall ***
回复

回到 “老旧版本支持”