Matlab装上了。但运行出错

为当前最终发行版之前的所有版本提供支持
xbear
帖子: 105
注册时间: 2007-05-14 0:10
送出感谢: 0
接收感谢: 0
联系:

Matlab装上了。但运行出错

#1

帖子 xbear » 2007-06-14 23:49

今天费了半天的时间下了个matlab,一共3张盘。可就是装不上。我晕呀。我们学校是限流量的。我都超了一半多的流量,结果还装不上。晕。
错误如下:
-------------------------------------------------------------------

An error status was returned by the program 'xsetup',
the X Window System version of 'install'. The following
messages were written to standard error:

Segmentation fault

Attempt to fix the problem and try again. If X is not available
or 'xsetup' cannot be made to work then try the terminal
version of 'install' using the command:

install* -t or INSTALL* -t

-------------------------------------------------------------------
.: 15: Can't open /tmp/14962tmwinstall/update/install/cleanup.sh
我也看了。/tmp/14962tmwinstall/update/install/cleanup.sh这个文件是有的。也能打开,可就是装不上。不知道为什么。
上次由 xbear 在 2007-06-17 0:05,总共编辑 1 次。
xbear
帖子: 105
注册时间: 2007-05-14 0:10
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 xbear » 2007-06-16 16:26

现在是装上了。可是用不了。为什么呀??哪个高人帮个忙。我在论坛里搜了半天也没有找到解决的办法。到这就不行了。如下
附件
Screenshot.png
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#3

帖子 aBiNg » 2007-06-16 17:28

$matlab --help

试试类似这个参数的。$matlab -nodesktop,具体可能记错。
xbear
帖子: 105
注册时间: 2007-05-14 0:10
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 xbear » 2007-06-16 23:42

aBiNg 写了:$matlab --help

试试类似这个参数的。$matlab -nodesktop,具体可能记错。
这个我已经试过了。我在论坛里查了好多方法都试了。就是解决不了问题,然后才来发问的。
用matlab -nodesktop显示如下:
xbear@LHL-XBEAR:~$ matlab -nodesktop

< M A T L A B >
Copyright 1984-2005 The MathWorks, Inc.
Version 7.0.4.352 (R14) Service Pack 2
January 29, 2005

Warning: MATLAB Toolbox Path Cache is out of date and is not being used.
Type 'help toolbox_path_cache' for more info.
Undefined function or variable "ispc".
Warning: MATLAB did not appear to successfully set the search path. To avoid this
warning the next time you start MATLAB, use
http://www.mathworks.com/access/helpdes ... hdef.shtml
to help troubleshoot the "pathdef.m" file. To recover for this session
of MATLAB, type "restoredefaultpath;matlabrc".
??? Undefined command/function 'colordef'.

Error in ==> hgrc at 59
colordef(0,'white') % Set up for white defaults

Error in ==> matlabrc at 91
hgrc
xbear
帖子: 105
注册时间: 2007-05-14 0:10
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 xbear » 2007-07-16 18:46

因为Matlab总是不能用。现在正打算装个windows,我的电脑上没有windows,还得重新分区。linux也得重装。真的很不情愿呀。
头像
getbaseclass
帖子: 7
注册时间: 2007-08-07 18:58
来自: 湖北武汉
送出感谢: 0
接收感谢: 0

#6

帖子 getbaseclass » 2007-08-19 13:43

你这情况我没遇到国
我安装完 后运行倒 没出现什么警告信息
一切好好的
界面和你贴图一样 就是进不去
感觉是许可证liscense的问题 :cry:
leeyee
帖子: 723
注册时间: 2006-04-11 9:01
送出感谢: 0
接收感谢: 0

#7

帖子 leeyee » 2007-08-19 14:03

Linux的matlab安装要注意以下几点:

1,用盘安装完成后在安装目录里(举例如/opt/MATLAB)有一个install_matlab脚本,这个脚本是用来安装一些软链接的,这个命令需要执行一次;
2,把matlab图标放到菜单里,切记运行命令应该为matlab -desktop,否则只会闪一下splash;
3,最好不要用matlab自带的java,一般不太稳定,且还有中文显示问题。最好修改/opt/MATLAB/bin/matlab脚本,添加一行

代码: 全选

export MATLAB_JAVA=/usr/lib/jvm/java-1.5.0-sun/jre
其中后面的路径换成自己系统的jre路径。
I would love to change the world, but they won't give me the source code.
http://hi.baidu.com/wienerlee
wzhy
帖子: 165
注册时间: 2007-04-24 21:43
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 wzhy » 2007-08-19 22:37

这是哪个大学FTP里的 deb包,楼主以及其他朋友可以一试:

ftp://202.38.73.198/debian/dists/sid/fo ... 2_i386.deb

我用教育网下,能达到400K左右。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#9

帖子 skyx » 2007-08-19 22:41

wzhy 写了:这是哪个大学FTP里的 deb包,楼主以及其他朋友可以一试:

ftp://202.38.73.198/debian/dists/sid/fo ... 2_i386.deb

我用教育网下,能达到400K左右。

USTC
no security measure is worth anything if an attacker has physical access to the machine
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#10

帖子 xiechy » 2007-08-19 23:59

wzhy 写了:这是哪个大学FTP里的 deb包,楼主以及其他朋友可以一试:

ftp://202.38.73.198/debian/dists/sid/fo ... 2_i386.deb

我用教育网下,能达到400K左右。
不要用这个。这个版本较老,还是7.0的。有挺多毛病,在新的glibc上。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#11

帖子 skyx » 2007-08-20 1:03

ftp://202.38.73.198/linux/matlab7_unix/ ... 2_i386.deb

一个服务器上怎么两个地方都有放? 只是ln 了一下还是不一样?
no security measure is worth anything if an attacker has physical access to the machine
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#12

帖子 zhuqin_83 » 2007-08-20 1:18

你管他一样不一样,反正不推荐用就是,上当了吧 :D
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#13

帖子 skyx » 2007-08-20 1:41

zhuqin_83 写了:你管他一样不一样,反正不推荐用就是,上当了吧 :D
在新的glibc上
难道还有别的地方有更好的deb? 那个dvd怎么样?
no security measure is worth anything if an attacker has physical access to the machine
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#14

帖子 zhuqin_83 » 2007-08-20 1:46

当然用dvd,版本是最新的。也不会有莫名其妙的错误。deb说真的就是把这个安装好的东西打个压缩包而已。不过要是打包的人水平有限。。。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#15

帖子 zhuqin_83 » 2007-08-20 1:47

我怎么总觉得你把glibc理解成一个地方了呢?自己看新立得,glibc是什么。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
回复

回到 “老旧版本支持”