安装软件总是报这种错误。。。

为当前最终发行版之前的所有版本提供支持
回复
gonefish
帖子: 6
注册时间: 2006-10-24 18:57
送出感谢: 0
接收感谢: 0

安装软件总是报这种错误。。。

#1

帖子 gonefish » 2007-06-22 18:56

正在设置 gnome-btdownload (0.0.28-1~feisty1) ...
Traceback (most recent call last):
File "/usr/bin/pycentral", line 1394, in ?
main()
File "/usr/bin/pycentral", line 1388, in main
rv = action.run(global_options)
File "/usr/bin/pycentral", line 875, in run
runtimes = get_installed_runtimes()
File "/usr/bin/pycentral", line 198, in get_installed_runtimes
default_version = pyversions.default_version(version_only=True)
File "/usr/share/pycentral-data/pyversions.py", line 130, in default_version
raise ValueError, "the symlink /usr/bin/python does not point to the python default version. It must be reset to point to %s" % debian_default
ValueError: the symlink /usr/bin/python does not point to the python default version. It must be reset to point to python2.5
dpkg:处理 gnome-btdownload (--configure)时出错:
子进程·post-installation script·返回了错误号·1
正在设置 python-mysqldb (1.2.1-p2-4ubuntu4) ...
Traceback (most recent call last):
File "/usr/bin/pycentral", line 1394, in ?
main()
File "/usr/bin/pycentral", line 1388, in main
rv = action.run(global_options)
File "/usr/bin/pycentral", line 875, in run
runtimes = get_installed_runtimes()
File "/usr/bin/pycentral", line 198, in get_installed_runtimes
default_version = pyversions.default_version(version_only=True)
File "/usr/share/pycentral-data/pyversions.py", line 130, in default_version
raise ValueError, "the symlink /usr/bin/python does not point to the python default version. It must be reset to point to %s" % debian_default
ValueError: the symlink /usr/bin/python does not point to the python default version. It must be reset to point to python2.5
dpkg:处理 python-mysqldb (--configure)时出错:
子进程·post-installation script·返回了错误号·1
在处理时有错误发生:
gnome-btdownload
python-mysqldb

不知道出了什么问题。。
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#2

帖子 bones7456 » 2007-06-22 19:03

$ll /usr/bin/python
lrwxrwxrwx 1 root root 9 2007-05-09 09:48 /usr/bin/python -> python2.5

要这样才对,你的是不是这样的?
关注我的blog: ε==3
gonefish
帖子: 6
注册时间: 2006-10-24 18:57
送出感谢: 0
接收感谢: 0

#3

帖子 gonefish » 2007-06-22 19:14

我现在的python链接的是2.4,但我改成2.5也会报这个错误
gonefish
帖子: 6
注册时间: 2006-10-24 18:57
送出感谢: 0
接收感谢: 0

#4

帖子 gonefish » 2007-06-22 19:16

-rwxr-xr-x 1 root root 1157044 2007-05-03 00:58 /usr/bin/python2.5
-rwxr-xr-x 1 root root 1026092 2007-04-13 05:04 /usr/bin/python2.4
lrwxrwxrwx 1 root root 11 2007-06-22 19:18 /usr/bin/python -> ./python2.5
gonefish
帖子: 6
注册时间: 2006-10-24 18:57
送出感谢: 0
接收感谢: 0

#5

帖子 gonefish » 2007-06-22 19:20

晕,原来是./python2.5,改成/usr/bin/python -> python2.5就好了。。。。
谢谢
vikeyoo
帖子: 10
注册时间: 2007-07-05 10:09
来自: guangdong
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 vikeyoo » 2007-07-08 19:25

oo@oo-desktop:~$ $ll /usr/bin/python
Python 2.5.1 (r251:54863, May 2 2007, 16:27:44)
[GCC 4.1.2 (Ubuntu 4.1.2-0ubuntu4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

我的还是不行。。。
回复

回到 “老旧版本支持”