安装Ubuntu 5.10时无法从光盘读取文件的解决办法

为当前最终发行版之前的所有版本提供支持
回复
cleven
帖子: 18
注册时间: 2005-11-17 9:25
送出感谢: 0
接收感谢: 0
联系:

安装Ubuntu 5.10时无法从光盘读取文件的解决办法

#1

帖子 cleven » 2005-11-18 10:26

硬件配置:
CPU: Sempron64 2500+
内存: Kingston DDR400 512M
主板: 七彩虹 C.NF4X v1.4
硬盘: Maxtor S-ATA 120G,8M,盒装
光驱: 明基DW1640
显卡: 铭瑄 X550 钻石版
显示器: Benq FP71G+,17" LCD

我先安装了Fedora Core 4,没有任何问题,所有设备都能驱动,硬盘被识别为/dev/sda。但是在安装Ubuntu 5.10时,我测试了i386、AMD64的CD和DVD版本,都是在“正在扫描光盘”之后的“加载额外组件”提示无法读取文件。使用安装程序菜单中的“检查光盘完整性”(具体名称忘了)时,AMD 64的版本和i386的版本各提示一个文件的MD5出错,具体文件名没记下来。
使用ISOMENU则AMD64位版本也是提示无法读取文件,而i386版本则在未进入安装界面前提示CRC错误。
使用GRUB硬盘安装也是相同的错误。后来我使用VMware在Windows XP中成功安装了i386的版本,而且是使用的物理光驱安装,而不是将ISO文件虚拟成光驱安装。而且所有下载的ISO文件都验证过MD5,且刻录后使用Nero验证了数据一致性,所以可以肯定光盘实际上是没有问题的。问题好像出在IDE设备或者安装程序中的解压缩等程序和硬件平台的兼容性上。

解决方案:
1.使用VMWare安装,GRUB可以装载MBR也可以装在Ubuntu分区的第一个扇区,如果是后者则使用GRUB for DOS引导(安装方法网上很多,也很简单),而GRUB的配置文件(/boot/grub下的menu.lst等)可以在VMWare中先拷贝到Windows FAT32的分区,然后再拷贝到C:\boot\grub中。这些都做好后,重启电脑(不是虚拟机),此时进入Ubuntu会提示/dev/hda*未找到,原因是VMWare中安装时,我的硬盘被挂载在/dev/hda,而实际上是/dev/sda。此时修改menu.lst(重启电脑在VMWare中修改,GRUB for DOS就在Windows里修改,如果是VMWare中最好一次改好,因为改了下面这个之后,VMWare中就进不去Ubuntu了),将/dev/hda改为/dev/sda,即:
kernel /boot/vmlinuz root=/dev/hda* ...改为:
kernel /boot/vmlinuz root=/dev/sda* ...
之后重启电脑,可以引导内核,但是不能引导Ubuntu。这时电脑在控制台,先备份后编辑/etc/fstab,把其中的/dev/hda*也改为/dev/sda*,保存,重启电脑就可以正常启动Ubuntu。但是这样改了之后在VMware中就不能再启动了。
2.启动之后将不能进入XWindow,xorg提示设备未找到。原始是VMWare中的显卡不是使用的物理显卡,而是VMWare的虚拟显卡。在控制台安装ATi的官方驱动,安装方法见“指南: ATI drivers”,只要做到其中的“保存文件,重启X,重启电脑”之后就可以正常进X了。注意下载的驱动是RPM的,sudo alien fglrx_6_8_0-8.10.19-1.i386.rpm时如果提示没有alien这个命令,就sudo apt-get install alien安装一下。

至此,问题解决,不知道是不是就我一个人有这个问题,我是刻了5张光盘、反复测试了5个晚上才得到以上办法的,又让我想起n年前装RedHat时因为硬盘跳线装了一个星期才装好的情景......里面涉及到的一些具体操作请在文档和论坛中找,或者google一下。

另外请各位高手帮忙看看,我很久没用Linux了,恐怕我又是因为一个小错误走了很多弯路:
1.是否是Ubuntu的Bug?如果是的话,我把错误信息再去找详细点然后汇报。
2.S-ATA设备在安装时BIOS中有没有特殊设定?为什么Fedora却可以?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2005-11-18 13:07

md5需要先检查。如果是iso安装,需要另外下3个不同于cd安装的文件。
● 鸣学
xyan
帖子: 34
注册时间: 2005-11-18 21:56
送出感谢: 0
接收感谢: 0

#3

帖子 xyan » 2005-11-19 12:24

LZ真有毅力,我已经战斗了一个晚上,iso文件没问题,md5校验没错,刻盘也没问题,也经过校验,安装也没问题,就是在输入用户名和密码后,进入桌面时屏幕停住不动了,鼠标能还能动,就是没有桌面,得等几个小时才能出现桌面,也不知道什么毛病。

我还得继续装啊,客观地讲,Linux的安装是比Windows差,记得我从Win3.1开始,一路win95、win98、winme、win2000、winxp到win2003,盗版盘或者镜像文件,每一次安装都是一次完成,从来没出过什么问题。
Enigma_Jiang
帖子: 39
注册时间: 2005-11-12 20:50
送出感谢: 0
接收感谢: 0

Re: 安装Ubuntu 5.10时无法从光盘读取文件的解决办法

#4

帖子 Enigma_Jiang » 2005-11-19 13:06

cleven 写了:硬件配置:
CPU: Sempron64 2500+
内存: Kingston DDR400 512M
主板: 七彩虹 C.NF4X v1.4
硬盘: Maxtor S-ATA 120G,8M,盒装
光驱: 明基DW1640
显卡: 铭瑄 X550 钻石版
显示器: Benq FP71G+,17" LCD


大家请注意明基DW1640,对就是这款DVD刻录机,与Ubuntu Linux的兼容上有问题。

我的证明路程

下载DVD镜像>>在虚拟机上安装成功>>刻录DVD>>真实安装提示文件损坏>>用Ultra ISO抓取成功>>用抓取之后的镜像在虚拟机中安装成功>>怀疑刻录机兼容问题>>更换三星光驱解决问题


注意这不是刻录机的质量问题,因为我用三星光驱安装时使用的还是在明基刻录机上刻录的DVD,由此可以证明刻录机的写入是没有问题的。而用刻录机抓取得镜像(是从我刻的盘上又抓了一遍)在虚拟机种安装成功,所以读取也没问题。唯一的解释是DW1640与Ubuntu Linux的兼容上有问题。

我付出了一上午一中午和半个下午,以及4张8xDVD+R。得到了一个安装成功的Ubuntu,和4张一模一样的完好安装光盘。
gxhunter
帖子: 63
注册时间: 2005-10-09 12:58
送出感谢: 0
接收感谢: 0

#5

帖子 gxhunter » 2005-11-19 13:25

完了,怪不得刚买的1640在ubuntu上有I/O错误,还真的是不兼容啊。
不过1640不兼容的话,浦科特740、飞利浦1648和SONY的810都要不兼容了。
希望早点有解决办法。
cleven
帖子: 18
注册时间: 2005-11-17 9:25
送出感谢: 0
接收感谢: 0
联系:

浪费了大好的光盘

#6

帖子 cleven » 2005-11-24 15:22

Enigma_Jiang和我一样浪费了大好的光盘, :(
头像
GOVO
帖子: 427
注册时间: 2005-05-15 3:09
送出感谢: 0
接收感谢: 0

#7

帖子 GOVO » 2005-11-24 16:14

我在刻盘完后再对光盘进行读取机校检,校检成功后就一定可以正确读盘了。
琴声如我
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#8

帖子 Tenyears » 2005-11-24 17:56

看我的老帖子,类似问题我在sony、源兴DVD上遇到过,但是明基DW1640就是OK了。安装、刻盘都没问题。

看来应该是ubuntu整个在DVD光驱支持上存在一些问题(CD ROM我没遇到过问题,也没看到人报道),导致光驱存在一点个体问题,读盘就有错,但又并不是针对某个具体型号。
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
回复

回到 “老旧版本支持”