请问,怎么装Jbuilder2006?

为当前最终发行版之前的所有版本提供支持
luckcao
帖子: 30
注册时间: 2005-11-08 11:59
送出感谢: 0
接收感谢: 0

请问,怎么装Jbuilder2006?

#1

帖子 luckcao » 2005-11-19 11:13

我刚刻了一张JBuilder2006,打开后,没有setup.exe

大家一看就知道我以前是用WINDOWS的。
请问,怎么在ubuntu里装呢?




===================================
已经解决了。见附图
附件
Screenshot.png
启动界面
Screenshot-1.png
主界面
Screenshot-2.png
关于界面
Screenshot.png
这是这张光盘里根目录的文件
上次由 luckcao 在 2005-11-21 20:44,总共编辑 1 次。
头像
oneleaf
论坛管理员
帖子: 10231
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#2

帖子 oneleaf » 2005-11-19 11:26

执行光盘上的install_linux.sh
luckcao
帖子: 30
注册时间: 2005-11-08 11:59
送出感谢: 0
接收感谢: 0

#3

帖子 luckcao » 2005-11-19 11:47

我在浏览器中双击install_linux.sh,没有任何反应。
我就在命令行窗口输入/media/cdrom/install_linux.sh
结果显示
bash: /media/cdrom/install_linux.sh: /bin/sh: bad interpreter: 权限不够
我是用root身份打开的命令行窗口,为什么还会提示没有权限呢?
头像
millenniumdark
论坛版主
帖子: 4160
注册时间: 2005-07-02 14:41
系统: Ubuntu 14.04 (Kylin)
送出感谢: 43 次
接收感谢: 9 次
联系:

#4

帖子 millenniumdark » 2005-11-19 12:03

打開終端

代码: 全选

cd <你的JBuilder2006光盤的目錄>
sudo ./install_linux.sh
luckcao
帖子: 30
注册时间: 2005-11-08 11:59
送出感谢: 0
接收感谢: 0

#5

帖子 luckcao » 2005-11-19 12:45

运行sudo ./install_linux.sh后提示:
sudo: unable to execute ./install_linux.sh: Permission denied

到底是什么问题呢?奇怪了。

有人遇到过么?
luckcao
帖子: 30
注册时间: 2005-11-08 11:59
送出感谢: 0
接收感谢: 0

#6

帖子 luckcao » 2005-11-19 16:12

拜托大家了。很急的。

谢谢!
头像
Xtire
帖子: 188
注册时间: 2005-09-11 14:08
来自: N朝古都
送出感谢: 0
接收感谢: 0

#7

帖子 Xtire » 2005-11-19 16:51

里面应该会有什么帮助文件之类的,看看,说不定就有答案。
头像
laborer
帖子: 1016
注册时间: 2005-10-25 11:15
送出感谢: 0
接收感谢: 1 次
联系:

#8

帖子 laborer » 2005-11-19 17:19

luckcao 写了:我在浏览器中双击install_linux.sh,没有任何反应。
我就在命令行窗口输入/media/cdrom/install_linux.sh
结果显示
bash: /media/cdrom/install_linux.sh: /bin/sh: bad interpreter: 权限不够
我是用root身份打开的命令行窗口,为什么还会提示没有权限呢?
不是的,你可能没有给install_linux.sh付予执行权限, 你执行

代码: 全选

ls -l /media/cdrom/install_linux.sh
看看,如果第一列不是-r-xr-xr-x,那可能就是/etc/fstab里面设置的问题了。
头像
paul
帖子: 510
注册时间: 2005-09-01 20:48
送出感谢: 0
接收感谢: 0

#9

帖子 paul » 2005-11-20 9:52

搞定了么?
luckcao
帖子: 30
注册时间: 2005-11-08 11:59
送出感谢: 0
接收感谢: 0

#10

帖子 luckcao » 2005-11-20 18:01

laborer 写了:
luckcao 写了:我在浏览器中双击install_linux.sh,没有任何反应。
我就在命令行窗口输入/media/cdrom/install_linux.sh
结果显示
bash: /media/cdrom/install_linux.sh: /bin/sh: bad interpreter: 权限不够
我是用root身份打开的命令行窗口,为什么还会提示没有权限呢?
不是的,你可能没有给install_linux.sh付予执行权限, 你执行

代码: 全选

ls -l /media/cdrom/install_linux.sh
看看,如果第一列不是-r-xr-xr-x,那可能就是/etc/fstab里面设置的问题了。
我看了,第一列就是-r-xr-xr-x. 整个结果如下:
-r-xr-xr-x 1 root root 533 2005-08-31 21:00 /media/cdrom/install_linux.sh

真是郁闷啊!
请大家帮帮忙。
谢谢
头像
oneleaf
论坛管理员
帖子: 10231
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#11

帖子 oneleaf » 2005-11-20 18:41

你吧安装程序复制到硬盘试试?

不过干嘛不使用eclipse,borland都计划放弃jBuilder了。准备重新基于eclipse开发一套IDE。
头像
laborer
帖子: 1016
注册时间: 2005-10-25 11:15
送出感谢: 0
接收感谢: 1 次
联系:

#12

帖子 laborer » 2005-11-20 19:45

支持oneleaf,eclipse非常棒,它的前生是ibm极具创新性的visualage for java,至于它的后世有人说就是下一个emacs。
luckcao
帖子: 30
注册时间: 2005-11-08 11:59
送出感谢: 0
接收感谢: 0

#13

帖子 luckcao » 2005-11-20 22:29

拜托各位了。我只用过Jbuilder。其他的不会用阿。
luckcao
帖子: 30
注册时间: 2005-11-08 11:59
送出感谢: 0
接收感谢: 0

#14

帖子 luckcao » 2005-11-21 12:55

大家帮帮忙啊.我不想就因为这个原因离开ubuntu大家庭啊.

谢谢了!
yangtseneu
帖子: 2
注册时间: 2005-11-20 18:39
送出感谢: 0
接收感谢: 0

#15

帖子 yangtseneu » 2005-11-21 13:33

chmod 777 *.sh
试一下,哈哈
我以前在FC4下成功安装过
回复

回到 “老旧版本支持”