chm格式文件,用chmsee的问题![已解决]

为当前最终发行版之前的所有版本提供支持
回复
sqpsunman
帖子: 77
注册时间: 2005-11-01 12:43
送出感谢: 0
接收感谢: 0
联系:

chm格式文件,用chmsee的问题![已解决]

#1

帖子 sqpsunman » 2005-11-19 11:29

安装chmsee是总是出现如下问题,但可以使用!重新启动后就没有了,需要什么依赖关系,我已经安装了libgtkhtml3.6-18阿,需要怎么弄阿!


sunman@sunman:~/Desktop$ sudo dpkg -i chmsee_0.8.0-1.1_i386.deb
Password:
选中了曾被取消选择的软件包 chmsee。
(正在读取数据库 ... 系统当前总共安装有 98368 个文件和目录。)
正在解压缩 chmsee (从 chmsee_0.8.0-1.1_i386.deb) ...
dpkg:依赖关系问题使得 chmsee 的配置工作不能继续:
chmsee 依赖于 libgtkhtml3.2-11 (>= 3.2.0);然而:
软件包 libgtkhtml3.2-11还没有被安装。
dpkg:处理 chmsee (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
chmsee
上次由 sqpsunman 在 2005-11-20 11:33,总共编辑 2 次。
初来乍到,请多关照,正在学习中........
sqpsunman
帖子: 77
注册时间: 2005-11-01 12:43
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 sqpsunman » 2005-11-19 11:30

sunman@sunman:~/Desktop$ sudo dpkg -i chmsee_0.8.0-1.1_i386.deb
Password:
选中了曾被取消选择的软件包 chmsee。
(正在读取数据库 ... 系统当前总共安装有 98368 个文件和目录。)
正在解压缩 chmsee (从 chmsee_0.8.0-1.1_i386.deb) ...
dpkg:依赖关系问题使得 chmsee 的配置工作不能继续:
chmsee 依赖于 libgtkhtml3.2-11 (>= 3.2.0);然而:
软件包 libgtkhtml3.2-11还没有被安装。
dpkg:处理 chmsee (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
chmsee
初来乍到,请多关照,正在学习中........
sqpsunman
帖子: 77
注册时间: 2005-11-01 12:43
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 sqpsunman » 2005-11-19 11:32

是不是和那个
sqpsunman 写了:在终端中输入 sudo apt-get update 命中网站链结后,出现如下情况请问如何解决?

E: 无法获得锁 /var/lib/dpkg/lock - open (11 资源暂时不可用)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

不能打开被锁住的管理员目录,有另外一个进程在使用它!请问如何看该使用的进程?有什么办法可以解决?
有什么关系吗?
初来乍到,请多关照,正在学习中........
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#4

帖子 glade » 2005-11-19 12:53

试试在终端下
sudo apt-get install libgtkhtml3.2-11

然后再装chmsee_0.8.0-1.1_i386.deb
头像
laborer
帖子: 1016
注册时间: 2005-10-25 11:15
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 laborer » 2005-11-19 14:50

chmsee直接用dpkg是装不了的,因为有版本冲突的问题,想把libgtkhtml版本降下来也不现实,那样会造成更多测版本冲突。我现在用的是另外一种方法,虽然不好看,但也有效。

首先:

代码: 全选

sudo apt-get install chmlib
sudo ln -sf /usr/lib/libgtkhtml-3.8.so.15 /usr/lib/libgtkhtml-3.1.so.11
注意,我用的是breezy,默认libgtkhtml版本是3.8-15,如果你用的不是这个版本,/usr/lib/libgtkhtml-3.8.so.15这个文件可能不存在,你要改成适合的。

然后去http://linuxfire.dhis.org/~zhong/files/ ... 1_i386.deb下载一个0.9.5的chmsee,运行:

代码: 全选

dpkg -x chmsee_0.9.5-1_i386.deb ~
~/usr/bin/chmsee
看看chmsee能不能起来了。这样是把chmsee解到你自己的Home目录下,如果想在全系统范围内用,可以用

代码: 全选

sudo dpkg -x chmsee_0.9.5-1_i386.deb /
不过我不推荐这样使用,不是系统源里面的还是放在自己的目录里面比较好,这样卸载起来方便一点。
sqpsunman
帖子: 77
注册时间: 2005-11-01 12:43
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 sqpsunman » 2005-11-20 11:23

laborer 写了:chmsee直接用dpkg是装不了的,因为有版本冲突的问题,想把libgtkhtml版本降下来也不现实,那样会造成更多测版本冲突。我现在用的是另外一种方法,虽然不好看,但也有效。

首先:

代码: 全选

sudo apt-get install chmlib
sudo ln -sf /usr/lib/libgtkhtml-3.8.so.15 /usr/lib/libgtkhtml-3.1.so.11
注意,我用的是breezy,默认libgtkhtml版本是3.8-15,如果你用的不是这个版本,/usr/lib/libgtkhtml-3.8.so.15这个文件可能不存在,你要改成适合的。

然后去http://linuxfire.dhis.org/~zhong/files/ ... 1_i386.deb下载一个0.9.5的chmsee,运行:

代码: 全选

dpkg -x chmsee_0.9.5-1_i386.deb ~
~/usr/bin/chmsee
看看chmsee能不能起来了。这样是把chmsee解到你自己的Home目录下,如果想在全系统范围内用,可以用

代码: 全选

sudo dpkg -x chmsee_0.9.5-1_i386.deb /
不过我不推荐这样使用,不是系统源里面的还是放在自己的目录里面比较好,这样卸载起来方便一点。
特别鸣谢!
初来乍到,请多关照,正在学习中........
头像
yang119345
帖子: 570
注册时间: 2005-06-19 14:22
来自: 上海
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 yang119345 » 2005-12-01 23:35

:shock: 这文章好~呵呵,给我拓宽思路了。 :? 我转了一下到自己的blog下。
感谢laborer

http://mushroom.phpower.net/index.php?action=show&id=25
回复

回到 “老旧版本支持”