apt-get 问题

为当前最终发行版之前的所有版本提供支持
回复
maths0503
帖子: 140
注册时间: 2007-04-14 20:27
来自: Dalian University of Technology
送出感谢: 0
接收感谢: 0
联系:

apt-get 问题

#1

帖子 maths0503 » 2007-07-01 9:49

gy@gy-desktop:~$ sudo apt-get remove beryl-plugins-data
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
beryl-plugins: 依赖: beryl-plugins-data 但是它将不会被安装
beryl-plugins-unsupported-data: 依赖: beryl-plugins-unsupported 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
gy@gy-desktop:~$
maths0503
帖子: 140
注册时间: 2007-04-14 20:27
来自: Dalian University of Technology
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 maths0503 » 2007-07-01 9:52

代码: 全选

gy@gy-desktop:~$ sudo apt-get -f install 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
读取状态信息... 完成             
正在更正依赖关系... 完成
将会安装下列额外的软件包:
  beryl-plugins-unsupported
下列【新】软件包将被安装:
  beryl-plugins-unsupported
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 77.4kB 的软件包。
解压缩后会消耗掉 254kB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://ubuntu.uestc.edu.cn feisty/universe beryl-plugins-unsupported 0.2.1-0ubuntu1 [77.4kB]
下载 77.4kB,耗时 0s (166kB/s)              
(正在读取数据库 ... 系统当前总共安装有 121806 个文件和目录。)
正在解压缩 beryl-plugins-unsupported (从 .../beryl-plugins-unsupported_0.2.1-0ubuntu1_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/beryl-plugins-unsupported_0.2.1-0ubuntu1_i386.deb (--unpack)时出错:
 正试图覆盖“/usr/lib/beryl/libgroup.so”,它属于软件包 beryl-plugins
在处理时有错误发生:
 /var/cache/apt/archives/beryl-plugins-unsupported_0.2.1-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
maths0503
帖子: 140
注册时间: 2007-04-14 20:27
来自: Dalian University of Technology
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 maths0503 » 2007-07-01 19:46

ding qi 来!!!! 老鸟给看看阿
回复

回到 “老旧版本支持”