当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : anjuta中文乱码怎么办?
帖子发表于 : 2007-07-02 17:40 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
系统是7.04,今天刚装的anjuta 2.2,打开gbk编码的含有中文注释的.c文件时,中文乱码,此文件在gedit中可以正常显示。在 设置 - preferences - 文档 - 编码 里面加进gbk、gb2312、gb18030编码、去掉默认的西文 都试过了(有重新打开anjuta),还是乱码。怎么解决?


_________________
关注我的blog: ε==3


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-02 22:36 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
还这样啊。试试加入工程。单独打开的可能不使用指定的编辑器设置?
utf8在win一样用。enconv *.c *.h算了。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-03 9:04 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
试过加入工程还是不行。发现anjuta在处理编码的时候有bug。不管 设置 - preferences - 文档 - 编码 里面怎么设置,utf8的文件总能正常显示,GB2312的文件总是乱码。

enconv *.c *.h 了之后倒是肯定可以,但是人家不是用win,有的用redhat。。。。还是7.×的。。。


_________________
关注我的blog: ε==3


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-03 13:41 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
export LC_ALL=zh_CN.GBK; anjuta
这样跑算了。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-07-03 15:06 
头像

注册: 2006-09-24 22:43
帖子: 710
送出感谢: 0 次
接收感谢: 0 次
转本地编码再打开.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译