[问题]自从升级了一个叫2.16.20.5的一个文件以后,apt-get就频繁出问题

为当前最终发行版之前的所有版本提供支持
回复
头像
casio1374633
帖子: 76
注册时间: 2007-03-05 15:38
送出感谢: 0
接收感谢: 0

[问题]自从升级了一个叫2.16.20.5的一个文件以后,apt-get就频繁出问题

#1

帖子 casio1374633 » 2007-07-06 13:37

这是在终端出现的问题的显示原因.

代码: 全选

无法下载 http://ubuntu.cn99.com/ubuntu/pool/universe/u/unicon/unicon-imc2_3.0.4-11_i386.deb  从服务器读取数据出错 - read (104 Connection reset by peer)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
情况如下:
有一天提示升级,看到一个大概大小4M,解压以后16M的文件叫2.16.20.5的什么包.然后开始出现是在cn99下载不一会就出现了断开.没有办法,我只好使用终端下载,apt-get upgrade来实现.不过还是同样的,就是显示出了下载什么读出错.

没办法,用键盘上键重复操作,终于像蜗牛一样爬完了.这个倒是没有怎么在意了,心想大概也就是下载的人太多了把.

但是在自从这次升级以后,使用apt-get 都接二连三的出现这个情况,每次我都需要通过重复命令来完成下载.像网络不好似的,但是我进行过sudo apt-get update.显示基本和以前的一样啊,命中都很高.

我以前用cn99的源是最快的..现在虽然不是很慢(速度现在也只有原来的2分之1或者3分之1了,原来是125K/s,现在大概就是30~50K/s),并且出现的是很不稳定,经常断掉,请问是cn99的原因还是我电脑的原因?是不是因为这次升级以后出现了什么问题?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
这是最新出现的情况,安装zhcon,即使像蜗牛那样爬完,也出现了MD5不同,无法安装的现象:

代码: 全选

casio@casio-ThinkPad:~$ sudo apt-get install zhcon
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
读取状态信息... 完成             
将会安装下列额外的软件包:
  libpth20 unicon-imc2
下列【新】软件包将被安装:
  libpth20 unicon-imc2 zhcon
共升级了 0 个软件包,新安装了 3 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 4154kB/8649kB 的软件包。
解压缩后会消耗掉 18.3MB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://ubuntu.cn99.com feisty/universe unicon-imc2 3.0.4-11 [4154kB]
下载 2B,耗时 0s (3B/s)               
无法下载 http://ubuntu.cn99.com/ubuntu/pool/universe/u/unicon/unicon-imc2_3.0.4-11_i386.deb  MD5 校验和不符
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?
上次由 casio1374633 在 2007-07-06 13:41,总共编辑 1 次。
头像
Decease
帖子: 834
注册时间: 2006-12-14 20:33
送出感谢: 0
接收感谢: 0

#2

帖子 Decease » 2007-07-06 13:41

或者加上 --fix-missing 的选项再试试?
头像
casio1374633
帖子: 76
注册时间: 2007-03-05 15:38
送出感谢: 0
接收感谢: 0

#3

帖子 casio1374633 » 2007-07-06 13:44

现在主要是我一直想问问,第一个问题就是我这个下载出现断点不是只下载这个包出现的,我之前下载或者升级的几个包都出现了这个情况.我想问问大家是否也出现了这个情况,是服务器的问题还是我的电脑升级升坏了什么.

还有就是速度没以前快了..不过还可以接受
头像
casio1374633
帖子: 76
注册时间: 2007-03-05 15:38
送出感谢: 0
接收感谢: 0

#4

帖子 casio1374633 » 2007-07-06 22:06

不是吧?没人回复?
头像
zmcbb30
帖子: 2717
注册时间: 2006-09-30 0:32
来自: 巴拉特星系第四行星──海尼森
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 zmcbb30 » 2007-07-06 22:17

把带 ubuntu-cn 那行注释掉
头可断,血可流,靓女不可不追求
相艾唔好口,够姜就只抽

BARTON 2500+/1536MDDR400
EP8RDA3G/MX4000 128M64bit 8X
DiamondPlus9-6Y080L0-ATA133
Samsung743DF
HiweedDesktop-1.0
头像
casio1374633
帖子: 76
注册时间: 2007-03-05 15:38
送出感谢: 0
接收感谢: 0

#6

帖子 casio1374633 » 2007-07-07 7:33

在source.list里面把cn99-cn的那个删除了.然后sudo apt-get update以后,还是这个问题..汗~~

运气不好??

是不是要开始更改源了?速度一开始挺快.在新立德下eva没一下子就又出现了

代码: 全选

W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/universe/e/eva/eva_0.4.1+cvs20070403-0ubuntu1_i386.deb
  从服务器读取数据出错 - read (104 Connection reset by peer)
~~~~~~~~~~~~~~~~~~~~~~~~

补充:重启一次以后再下载就没有断掉了。。不过暂时不能掉以轻心。。。我再观察今天,谢谢楼上的。估计是cn99-cn的服务器不稳定的原因。
回复

回到 “老旧版本支持”