[问题]请教安装软件包时的依赖提示

为当前最终发行版之前的所有版本提供支持
回复
drug
帖子: 10
注册时间: 2007-06-28 16:41
送出感谢: 0
接收感谢: 0

[问题]请教安装软件包时的依赖提示

#1

帖子 drug » 2007-07-11 17:47

我安装compiz-core的时候给我这样的信息:
compiz-core:
依赖: libc6 (>=2.5-0ubuntu1) 但是将会安装 2.3.6-0ubuntu20.4
依赖: libgl1-mesa-glx but it is not installable
依赖: libpng12-0 (>=1.2.13-4) 但是将会安装 1.2.8rel-5ubuntu0.2
依赖: libxcomposite1 但是此软件包将不会被安装
依赖: libxfixes3 (>=1:4.0.1) 但是将会安装 1:3.0.1.2-0ubuntu3
依赖: libxml2 (>=2.6.27) 但是将会安装 2.6.24.dfsg-1ubuntu1
依赖: libxrandr2 (>=2:1.2.0) 但是将会安装 1:1.1.0.2-0ubuntu4
依赖: libxslt1.1 (>=1.1.20) 但是将会安装 1.1.15-1ubuntu1

请问哪位能给我解释一下,到底是什么意思?是需要安装哪个版本还是不能安装哪个版本?还是已经拥有哪个版本?
请以其中一条举例说明
drug
帖子: 10
注册时间: 2007-06-28 16:41
送出感谢: 0
接收感谢: 0

#2

帖子 drug » 2007-07-11 18:40

就这个东西都没有人能够回答一下吗?
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 BigSnake.NET » 2007-07-11 18:44

用 aptitude 代替 apt-get 试试
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
drug
帖子: 10
注册时间: 2007-06-28 16:41
送出感谢: 0
接收感谢: 0

#4

帖子 drug » 2007-07-11 18:49

仍然无法解决依赖问题
系统给我的答案是:
Resolving dependencies...
未能解决依赖关系!放弃...
放弃。
头像
nihui
帖子: 1746
注册时间: 2006-10-21 12:03
来自: Shanghai
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 nihui » 2007-07-11 18:55

我觉得是楼主的源的关系吧。。
或许有些包是很新的,但系统却没那么新。。
比如 feisty 的包用在了 edgy 上。。 :shock:
.

私人空间
附有 Magic Linux 2.1 最新开发日志~


미안하다, 사랑한다


欢迎来 #xfce-cn 中文频道~~
drug
帖子: 10
注册时间: 2007-06-28 16:41
送出感谢: 0
接收感谢: 0

#6

帖子 drug » 2007-07-11 18:59

但是我用的是compizfusion 那个置顶贴里面的源啊
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2007-07-11 19:12

nihui 写了:我觉得是楼主的源的关系吧。。
或许有些包是很新的,但系统却没那么新。。
比如 feisty 的包用在了 edgy 上。。 :shock:
这多半有关。没理清版本的区别。
● 鸣学
drug
帖子: 10
注册时间: 2007-06-28 16:41
送出感谢: 0
接收感谢: 0

#8

帖子 drug » 2007-07-12 10:33

我的是6.06 LTS的 怎么才能看出报包是对应哪个版本的?
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#9

帖子 BigSnake.NET » 2007-07-12 10:37

drug 写了:我的是6.06 LTS的 怎么才能看出报包是对应哪个版本的?


.....你自己添加的源贴出来看看
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
drug
帖子: 10
注册时间: 2007-06-28 16:41
送出感谢: 0
接收感谢: 0

#10

帖子 drug » 2007-07-12 10:47

BigSnake.NET 写了:
drug 写了:我的是6.06 LTS的 怎么才能看出报包是对应哪个版本的?


.....你自己添加的源贴出来看看



哦~~我懂了~源在网址后面第一个字符串就是版本的代号吧?那我的确是搞错了,那么6.06的版本代号是多少啊?
那是不是说一定要先把版本升级到feisty 才能安装compizfusion??
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#11

帖子 BigSnake.NET » 2007-07-12 10:50

6.06 dapper
6.10 edgy
7.04 feisty
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
drug
帖子: 10
注册时间: 2007-06-28 16:41
送出感谢: 0
接收感谢: 0

#12

帖子 drug » 2007-07-12 10:52

那怎么才能升级呢?
头像
ericzb
帖子: 441
注册时间: 2006-11-16 21:34
来自: Bridge View
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 ericzb » 2007-07-14 0:48

改dapper->edgy->feisty
update->dist-upgrade
回复

回到 “老旧版本支持”