当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [转帖]Installing Ubuntu 7.04 (Feisty Fawn) on a ThinkPad T60
帖子发表于 : 2007-07-13 22:25 

注册: 2006-03-26 13:44
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
Installing Ubuntu 7.04 (Feisty Fawn) on a ThinkPad T60
From ThinkWiki
Jump to: navigation, search

Ubuntu 7.04 Feisty Fawn is the current release and works fine on:

* T60 UT-049GE and 2007-72U.
* T60p (follow this: Installing Ubuntu 7.04 Feisty Fawn on a ThinkPad T60p

The installation worked without any problems. The new network manager is great as it now supports a useful roaming mode. The system includes the new Linux kernel 2.6.20 which provides almost perfect acpi functionality.

Most of the tips in the Ubuntu 6.10 Edgy Eft Guide, like installing the ATI driver, apply to Feisty as well.

Feisty polishes up Thinkpad support for media buttons (acpi), and gives a much more usable machine immediately following installation than Edgy. This is a distribution to watch for Thinkpad users.


Contents
[hide]

* 1 ATI Driver, Intel Pro Wireless, and Powernowd Suspend to RAM Fixes
o 1.1 Fixing Suspend to RAM
o 1.2 Tips for those dist-upgrading from Edgy
* 2 Fix broken metacity window manager:
* 3 Related Ubuntu bugs

[edit] ATI Driver, Intel Pro Wireless, and Powernowd Suspend to RAM Fixes

"Out of the box:"

* Suspend to RAM fails during suspend, leaving the moon blinking indefinitely.
* At one point, the Ubuntu apt-installed fglrx packages had the driver version 8.33.6, which is one of the versions that supposedly "breaks" suspend to RAM. Resuming from an otherwise successful suspend will cause the machine to resume with a blank screen without the fix below. That said, the current version in Feisty is now 8.34.8, whose release notes say "A system hang no longer occurs when attempting to resume from hibernation mode," so if you simply allow Ubuntu to update itself from the internet you can skip that step. Note however if you install the 64-bit version of Ubuntu, you may have problems with suspend to RAM not coming back on wakeup, at least with the ATI graphics option on a recent (mid-2007) T60P.
* The Intel Pro Wireless 3945 wireless card will often stop working even after a successful suspend, requiring a restart.

* FR, 2007may9: Actually, I have a different experience with suspend and hibernate, with a T60 15.4" (core 2 duo 2GHz, intel graphic chip 945GM): Both suspend and hibernate work for me. Initially, I had an issue with a slightly corrupted video after resume from suspend (a couple of lines near the bottom right of the screen), that I fixed by using the intel X driver instead of the i810 (that comes stock with ubuntu feisty fawn). Just load xserver-xorg-driver-intel, that will uninstall xserver-xorg-driver-i810. No other modifications necessary, stock acpi-support and xorg.conf. I can also hibernate, but I loose sound when resuming. Restarting alsa does not restore it. UPDATE: I had trouble with the video getting corrupted during the vt switch (vt 7->1) that occurs during the suspend to RAM (or hibernate). These were solved by : (1) using uswsusp (s2ram and s2disk) as s2ram -f -a 3 (forces s3_bios and s3_mode), appending acpi_sleep=s3_bios,s3_mode vga=0 to the kernel boot parameters (/boot/grub/menu.lst) and removing splash from the same kernel options. I have done that 8 days ago, and gone through 3 countries, around 50 s2ram and 4-5 s2disk without a hinch (note: I'm still using the intel video drivers)

[edit] Fixing Suspend to RAM

I'm assuming you have the optional Intel Pro Wireless; ignore the line that mentions ipw3945 if you don't have that wireless card.

1. Disable powernowd during suspend

These two edits will disable the powernowd when you suspend, and re-enable it when you resume. For whatever reason, powernowd causes intermittent suspend problems.
* Open a terminal and type: sudo gedit /etc/acpi/suspend.d/10-thinkpad-standby-led.sh
* Add to the bottom of the file: /etc/init.d/powernowd stop
* Save the file and go back to the terminal.
* Type: sudo gedit /etc/acpi/resume.d/90-thinkpad-unstandby-led.sh
* Add to the bottom of the file: /etc/init.d/powernowd start

2. Edit /etc/default/acpi-support file to unload wireless module during suspend and disable video card warm boot

These edits will fix the disappearing wireless card and the blank screen on resume problems.
* Open a terminal and type: sudo gedit /etc/default/acpi-support
* Find the line MODULES="" and change it to MODULES="ipw3945" so that your wireless card module won't disappear after you resume.
* Next, find the line POST_VIDEO=true and change it to POST_VIDEO=false to eliminate the blank-screen-resume problem.
* Save the file.

* If you are running the 64-bit version of Ubuntu on a T60P with the ATI graphics option, and are still having suspend problems, consider installing the 32-bit version.

[edit] Tips for those dist-upgrading from Edgy

Repair fglrx to a working state:

If you have an ATI graphics card, now by default Mesa may be active despite your xorg.conf configuration in edgy. Check whether there is hardware acceleration:

$ fglrxinfo

The above should print "OpenGL vendor string: ATI Technologies Inc", among other output. If "Mesa" is present, then you need to reinstall the fglrx driver:

$ sudo apt-get remove xorg-driver-fglrx fglrx-control

$ sudo apt-get install xorg-driver-fglrx fglrx-control

$ sudo depmod -a

Then logout, kill the X server with control+alt+delete, and login again. Now the command 'fglrxinfo' will print the proper vendor string.


If the error persists and there is no 3D acceleration: comment out the line involving 'fglrx' in /etc/modprobe.d/lrm-video , then

$ sudo modprobe -v fglrx

and restart the X server (control+alt+del). Check that the driver is loaded:

$ lsmod

fglrx 540004 11
agpgart 35400 2 fglrx,intel_agp


The driver fglrx should be listed.


If you find this error in the Xorg logs (under System / Administration / System Logs):

(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering

Turn off AIGLX by adding the following in your /etc/X11/xorg.conf:

Section "ServerFlags"
Option "AIGLX" "off"
EndSection


To avoid the garbled display problem, remember that /etc/X11/xorg.conf should have the Composite option disabled (you only need it enabled for Compiz, which is not ready for feisty with ATI cards):

Section "Extensions"
Option "Composite" "0"
EndSection

[edit] Fix broken metacity window manager:

If you had installed a non-official compiz beta at some point, then you will have two disruptive settings files under your home directory.

.gnomerc
.dmrc

Have a look particularly at .gnomerc , which may contain a line specifying a window manager listed under .gnome-compiz-manager/openbox . The second file, .dmrc, may be pointing to a compiz desktop session that no longer exists in your system. Just get rid of both files (see bug https://bugs.launchpad.net/ubuntu/+sour ... bug/104903 )


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-13 22:52 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
估计翻译之后就更好了.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-14 0:00 
头像

注册: 2007-07-01 8:59
帖子: 30
地址: HZ
送出感谢: 0 次
接收感谢: 0 次
哎,我是使用toshiba的笔记本,安装起来也没那么费劲阿


_________________
technology is a war


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-08-15 23:59 

注册: 2006-01-27 22:13
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
主要是显示器亮度的问题,谁有解决方案阿


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译