当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : free命令下的swap总量为何是0?
帖子发表于 : 2007-07-15 20:36 

注册: 2007-05-19 16:36
帖子: 541
送出感谢: 0 次
接收感谢: 0 次
用free命令swap总量显示为0,请问是怎么回事?


附件:
screenshot.png
screenshot.png [ 12.55 KiB | 被浏览 1722 次 ]

screenshot.png
screenshot.png [ 58.84 KiB | 被浏览 1739 次 ]



最后由 sivaj 编辑于 2007-07-16 9:35,总共编辑了 3 次
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-15 20:38 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
正常.......因为你内存多


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-15 20:52 

注册: 2007-06-15 18:52
帖子: 31
地址: Chengdu
送出感谢: 0 次
接收感谢: 0 次
我也是0.呵呵


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-15 21:03 
头像

注册: 2005-12-28 1:16
帖子: 3916
地址: 火星
系统: Ubuntu 12.10 X64
送出感谢: 1
接收感谢: 0 次
我就没swap


_________________
目前负债150多万


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-07-15 21:07 
头像

注册: 2007-03-13 17:26
帖子: 2254
送出感谢: 0 次
接收感谢: 1
swap 行 total 值为0,表示 交换分区根本没挂载。。。。。。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-07-15 21:14 

注册: 2007-05-19 16:36
帖子: 541
送出感谢: 0 次
接收感谢: 0 次
我说的是总量啊 我的总量(total)显示为0的问题
总量应该显示划分给swap分区的才对啊 我内存为512M,划分给swap的也是512M,free命令下应该分为
total used free 三项,我的这三项都是0,那不是说明我没有swap或者没有挂载上吗?

我再贴一下我的free命令状况:
===========================================
j@ubuntu:~$ free
total used free shared buffers cached
Mem: 514444 506256 8188 0 8796 167392
-/+ buffers/cache: 330068 184376
Swap: 0 0 0
===========================================
total项下不应该是分配给swap分区的容量吗?怎么会是0呢


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-07-15 21:16 

注册: 2007-05-19 16:36
帖子: 541
送出感谢: 0 次
接收感谢: 0 次
我也觉得是5楼老兄说的情况,因为刚才我无缘无故死了一次机
请问改如何解决呢 ?
我的/etc/fstab里是有swap这一行的啊

========================================================
....
....

# /dev/sda8
UUID=5d42be40-371a-448a-93e1-325ffc15a022 /var reiserfs defaults 0
2
# /dev/sda10
UUID=82f60143-9c60-4e74-a229-f2eeb9cc4ba7 none swap sw 0
0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
(END)
.....
.....
=========================================================


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-07-15 21:21 

注册: 2005-08-06 10:10
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
我觉得楼主的字体不错,是什么字体啊?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-07-15 21:35 

注册: 2007-05-19 16:36
帖子: 541
送出感谢: 0 次
接收感谢: 0 次
回nofoghu老兄
字体是bitstream vera sans mono roman

知道swap没有挂载是什么问题吗 教我


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-07-15 21:36 
头像

注册: 2006-07-25 9:33
帖子: 223
送出感谢: 0 次
接收感谢: 0 次
估计是uuid变了


_________________
Take what man makes and use it, But do not worship it, For it shall pass. -- Anonymous

Twitter @jiangpeng


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-07-15 21:45 

注册: 2007-05-19 16:36
帖子: 541
送出感谢: 0 次
接收感谢: 0 次
请问jiang,uuid怎么会变的呢?如何修复呢


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-07-15 22:15 
头像

注册: 2006-07-25 9:33
帖子: 223
送出感谢: 0 次
接收感谢: 0 次
ls -l /dev/disk/byuuid/


_________________
Take what man makes and use it, But do not worship it, For it shall pass. -- Anonymous

Twitter @jiangpeng


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-07-15 22:59 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
记得是这样来激活swap分区:

mkswap /dev/sda10
swapon -a

swap分区的UUID是会变的,每次mkswap后都会变,据说UUID是根据文件系统而不是分区号来生成的.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-07-15 23:29 

注册: 2007-05-19 16:36
帖子: 541
送出感谢: 0 次
接收感谢: 0 次
多谢catinsnow和jiang!按照你说的已经解决swap分区不挂载的问题。
不过通常是什么原因导致swap的uuid于/dev/disk/by-uuid下的uuid对不上的呢?


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-07-16 9:00 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
如果是突然改变,多半是其他系统引起的。 :lol:


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译