究竟如何设置firestarter,才能让firestarter成功启动呢?

为当前最终发行版之前的所有版本提供支持
头像
lxyscience
帖子: 251
注册时间: 2007-07-11 17:19
送出感谢: 0
接收感谢: 0

究竟如何设置firestarter,才能让firestarter成功启动呢?

#1

帖子 lxyscience » 2007-07-17 17:52

网络连接状态良好。
搜索到的说让添加LANG后,仍然无效。
究竟如何设置firestarter,才能让firestarter成功启动呢?
头像
lxyscience
帖子: 251
注册时间: 2007-07-11 17:19
送出感谢: 0
接收感谢: 0

#2

帖子 lxyscience » 2007-07-18 6:52

anybody?
头像
relaxssl
帖子: 1448
注册时间: 2007-01-30 7:13
送出感谢: 4 次
接收感谢: 0

#3

帖子 relaxssl » 2007-07-18 9:46

你用的ubuntu一定是中文的,firefaster很笨,它不懂中文,你转为英文它就正常了,或者你要编辑一下相关的文件,你先google一下!
PS: 我个人觉得用英文的系统很好!很多好处咯。
307WRC
帖子: 480
注册时间: 2006-12-13 22:50
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 307WRC » 2007-07-18 10:09

sudo gedit /etc/firestarter/firestarter.sh
在# External network interface data
这行注释的上面,添加一行:
LANG=en_US
头像
lxyscience
帖子: 251
注册时间: 2007-07-11 17:19
送出感谢: 0
接收感谢: 0

#5

帖子 lxyscience » 2007-07-18 11:25

307WRC 写了:sudo gedit /etc/firestarter/firestarter.sh
在# External network interface data
这行注释的上面,添加一行:
LANG=en_US

这个输入后如何保存呢?
是在shell中显示的。
头像
lxyscience
帖子: 251
注册时间: 2007-07-11 17:19
送出感谢: 0
接收感谢: 0

#6

帖子 lxyscience » 2007-07-18 11:50

relaxssl 写了:你用的ubuntu一定是中文的,firefaster很笨,它不懂中文,你转为英文它就正常了,或者你要编辑一下相关的文件,你先google一下!
PS: 我个人觉得用英文的系统很好!很多好处咯。

结果还是一样,Failed to start firewall
307WRC
帖子: 480
注册时间: 2006-12-13 22:50
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 307WRC » 2007-07-18 12:23

lxyscience 写了:
307WRC 写了:sudo gedit /etc/firestarter/firestarter.sh
在# External network interface data
这行注释的上面,添加一行:
LANG=en_US

这个输入后如何保存呢?
是在shell中显示的。

呃,我的这个是用图形界面的gedit 编辑的,怎么保存你不会不知道吧。

改好之后重设一下网络配置。。。

这东西感觉很讨厌,重启之后有可能又有问题,而且有时候在提示启动失败之后,反而又运行起来了
dfyz
帖子: 56
注册时间: 2007-06-23 20:38
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 dfyz » 2007-07-18 12:27

取消网络共享试一下,反正我就是这样才运行的
头像
lxyscience
帖子: 251
注册时间: 2007-07-11 17:19
送出感谢: 0
接收感谢: 0

#9

帖子 lxyscience » 2007-07-18 14:33

307WRC 写了:
lxyscience 写了:
307WRC 写了:sudo gedit /etc/firestarter/firestarter.sh
在# External network interface data
这行注释的上面,添加一行:
LANG=en_US

这个输入后如何保存呢?
是在shell中显示的。

呃,我的这个是用图形界面的gedit 编辑的,怎么保存你不会不知道吧。

改好之后重设一下网络配置。。。

这东西感觉很讨厌,重启之后有可能又有问题,而且有时候在提示启动失败之后,反而又运行起来了


结果仍然无效
头像
lxyscience
帖子: 251
注册时间: 2007-07-11 17:19
送出感谢: 0
接收感谢: 0

#10

帖子 lxyscience » 2007-07-18 14:33

dfyz 写了:取消网络共享试一下,反正我就是这样才运行的


仍然无效
头像
relaxssl
帖子: 1448
注册时间: 2007-01-30 7:13
送出感谢: 4 次
接收感谢: 0

#11

帖子 relaxssl » 2007-07-18 17:13

你把系统的default语言换成english就OK了。
头像
lxyscience
帖子: 251
注册时间: 2007-07-11 17:19
送出感谢: 0
接收感谢: 0

#12

帖子 lxyscience » 2007-07-18 20:44

relaxssl 写了:你把系统的default语言换成english就OK了。


换了,可是仍然无效。
头像
relaxssl
帖子: 1448
注册时间: 2007-01-30 7:13
送出感谢: 4 次
接收感谢: 0

#13

帖子 relaxssl » 2007-07-18 22:46

lxyscience 写了:
relaxssl 写了:你把系统的default语言换成english就OK了。


换了,可是仍然无效。


应该不会,你把语言设置截取一个图贴上来看看。
头像
lxyscience
帖子: 251
注册时间: 2007-07-11 17:19
送出感谢: 0
接收感谢: 0

#14

帖子 lxyscience » 2007-07-18 23:16

relaxssl 写了:
lxyscience 写了:
relaxssl 写了:你把系统的default语言换成english就OK了。


换了,可是仍然无效。


应该不会,你把语言设置截取一个图贴上来看看。


唉,换来换去的,真的是无效啊。有效就不发贴啦。
你发几张设置放火墙的上来看看,我估计还是设置的问题。
头像
lxyscience
帖子: 251
注册时间: 2007-07-11 17:19
送出感谢: 0
接收感谢: 0

#15

帖子 lxyscience » 2007-09-20 22:50

sudo sed -i~ "s/\/sbin\/ifconfig/env LC_ALL=en_US \/sbin\/ifconfig/g" /etc/firestarter/firestarter.sh
回复

回到 “老旧版本支持”