关于zlib-dev软件的问题???(急)

为当前最终发行版之前的所有版本提供支持
回复
xman1978
帖子: 30
注册时间: 2007-05-28 16:10
送出感谢: 0
接收感谢: 0

关于zlib-dev软件的问题???(急)

#1

帖子 xman1978 » 2007-07-17 18:09

一个软件开发包的makefile片断如下:
#############################################################
#
# Test for prerequisites
#
#############################################################
is_zlib_available := $(shell ./test_if_zlib_is_available.sh)
ifneq '$(is_zlib_available)' 'yes'
$(warning The development version of 'zlib' is not available on your system. )
$(warning However, it is a requirement of the root file system package. Please)
$(warning install the development version of the 'zlib' library. )
$(warning )
$(warning Depending on the specifics of your Linux distribution, you can )
$(warning consider the following ways of installing 'zlib-dev' onto your )
$(warning system: )
$(warning - use a package manager, such as apt-get (apt-get install zlib-dev))
$(warning or yum (yum install zlib-dev). )
$(warning - google for the package in rpm form ('zlib-dev rpm download'). )
$(warning )
$(error Error: 'zlib-dev' not available)
endif

安装时,他总是说找不到zlib-dev,并且输出如上信息;
实际上我的ubuntu704已经安装了zlib1g-dev,可是我在搜索zlib-dev时怎么都没有
我估计zlib1g-dev和zlib-dev应该是同一个东西,可是上面的makefile就是不认
请问有什么办法解决吗???
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

#2

帖子 Nile » 2007-07-17 18:27

我估计zlib1g-dev和zlib-dev应该是同一个东西
不是一个东西,debian网上有下的。
Thinkpad T400
xman1978
帖子: 30
注册时间: 2007-05-28 16:10
送出感谢: 0
接收感谢: 0

#3

帖子 xman1978 » 2007-07-18 9:22

不行啊,我在debian.org上都没找到,麻烦给个连接,谢谢!
回复

回到 “老旧版本支持”