当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 21 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [原创]samba图形化配置工具swat
帖子发表于 : 2007-07-19 9:22 

注册: 2007-07-12 13:23
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
刚刚接触Linux没多久,觉得现在的linux还真好用多了。昨天想弄一下samba,翻看了一下论坛的帖子,发现都是讲怎么改配置文件的,原先我在HP-UX上装samba都是用swat配置的。觉得用图形化的配置工具比较方便,特别是对新手来说。废话不多说,把我昨天搞定samba的经验各位和我一样的新手交流一下。

1.安装samba
sudo apt-get install samba
sudo apt-get install smbfs
2.安装swat
sudo apt-get install swat
3.这一步比较重要,安装xinetd
sudo apt-get install xinetd
4.安装后执行
sudo vi /etc/inetd.conf
这一行前面如果有#off# 的话就删除掉#off#
#off# swat stream tcp nowait.400 root /usr/sbin/tcpd /usr/sbin/swat
然后执行
sudo vi /etc/xinetd.d/swat
打开文件后把一下内容贴进去
# description: SAMBA SWAT
service swat
{
disable = no
socket_type = stream
protocol = tcp
#should use a more limited user here
user = root
wait = no
server = /usr/sbin/swat
}

保存后执行
sudo dpkg-reconfigure xinetd

5.然后就可以使用swat了,访问http://localhost:901 就可以配置了,一般的先配置global 里面的security等选现,然后配置shares,再在password里面配置用户,最后可以在status里面控制samba的状态。这些就不多说了,能用linux的一般都有比较好的基础,摸索一下应该都能够搞定的。欢迎大家交流经验。

上两张PP :D

图片

图片


附件:
02.png
02.png [ 72.52 KiB | 被浏览 6648 次 ]

01.png
01.png [ 95.2 KiB | 被浏览 6612 次 ]



最后由 shijunbo 编辑于 2007-07-19 9:37,总共编辑了 1 次
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-19 9:26 
头像

注册: 2006-11-17 20:07
帖子: 359
地址: 杭州/宁波
送出感谢: 0 次
接收感谢: 0 次
不错!
如果楼主贴张图就更好了。


_________________
IMTX:http://imtx.cn/

LDCN(已经关闭):http://linuxdesktop.cn/

Ubuntu Tweak:http://ubuntu-tweak.com/


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-19 9:26 
头像

注册: 2007-01-24 22:07
帖子: 1417
地址: http://adqin.cn
送出感谢: 0 次
接收感谢: 0 次
不错,是比配置文件要简单些了。


_________________
时光流转 淘帮帮 淘宝推荐 潼南网 你问我答


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-19 9:40 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
http://forum.ubuntu.org.cn/viewtopic.ph ... ight=samba

gui意义不大,那samba本身兼容不好。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-07-19 14:22 

注册: 2007-07-16 8:58
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
安照LZ的方法做了一次,到最后打开---http://localhost:901 时说无法访问!
这是什么原因咩!
第四步我改用
sudo gedit /etc/inetd.conf 对inetd.conf进行编缉 并添加了swat stream tcp nowait.400 root /usr/sbin/tcpd /usr/sbin/swat 并保存!

第五步
接着同样运用
sudo gedit /etc/xinetd.d/swat
对文件进行编缉,开添加:
# description: SAMBA SWAT
service swat
{
disable = no
socket_type = stream
protocol = tcp
#should use a more limited user here
user = root
wait = no
server = /usr/sbin/swat
}
后保存

第六步
然后输入:
sudo dpkg-reconfigure xinetd
提示:
Stopping internet superserver: xinetd.
Stopping internet superserver: xinetd.
Leaving `diversion of /etc/init.d/inetd to /etc/init.d/inetd.real by xinetd'
Starting internet superserver: xinetd.

再在浏览输入:http://localhost:901
提示 无法访问!这是什么原因呢!请LZ帮忙解决一下!

第四与第五原语句应是:sudo vi xxxxxxxxx 的,但我的系统不能用 VI 这个命令!所以改用gedit


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-07-19 15:16 
头像

注册: 2007-03-27 10:42
帖子: 22
地址: 星城
送出感谢: 0 次
接收感谢: 0 次
看多了配置文件就差不多了.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-07-19 20:46 

注册: 2007-07-16 8:58
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
请问我的这个问题要怎样解决呢?!?!?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-07-20 10:00 

注册: 2007-07-12 13:23
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
bigglod 写道:
安照LZ的方法做了一次,到最后打开---http://localhost:901 时说无法访问!
这是什么原因咩!
第四步我改用
sudo gedit /etc/inetd.conf 对inetd.conf进行编缉 并添加了swat stream tcp nowait.400 root /usr/sbin/tcpd /usr/sbin/swat 并保存!

第五步
接着同样运用
sudo gedit /etc/xinetd.d/swat
对文件进行编缉,开添加:
# description: SAMBA SWAT
service swat
{
disable = no
socket_type = stream
protocol = tcp
#should use a more limited user here
user = root
wait = no
server = /usr/sbin/swat
}
后保存

第六步
然后输入:
sudo dpkg-reconfigure xinetd
提示:
Stopping internet superserver: xinetd.
Stopping internet superserver: xinetd.
Leaving `diversion of /etc/init.d/inetd to /etc/init.d/inetd.real by xinetd'
Starting internet superserver: xinetd.

再在浏览输入:http://localhost:901
提示 无法访问!这是什么原因呢!请LZ帮忙解决一下!

第四与第五原语句应是:sudo vi xxxxxxxxx 的,但我的系统不能用 VI 这个命令!所以改用gedit



安装了SWAT之后 inetd.conf中应该会有swat stream tcp nowait.400 root /usr/sbin/tcpd /usr/sbin/swat的,你的没有是不是因为SWAT没有安装好?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-07-20 14:27 

注册: 2007-07-16 8:58
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
问题解决了~今天重新安装了ubuntu 后再重新安装 samba smbfs 等后,现在可以运了~~~
等一下忙完后再总结一下上一次失败的原因!


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-07-20 15:44 

注册: 2007-07-16 8:58
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
错误可能是因为 vi 命令与 gedit 两个命令的不同!
vi
文件将在终端中打开,在这种方式打开时,输入有可能会出错!
我的错误可能就在这里~~~对需要输入的文档输入错了!

gedit
文件将会以记事本的方式打开,在这种方式打开,输入错误的机会比较少!


总结完毕~~~哈哈!!!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-07-21 12:51 

注册: 2007-07-21 2:53
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
好帮的 帖子!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-08-11 5:18 

注册: 2007-05-15 6:22
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
按照楼主的方法做的,打开swat网页后卫什么我只有很少的选项呢. 请见附件.


附件:
screenshot1.png
screenshot1.png [ 15.75 KiB | 被浏览 4654 次 ]

页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-09-19 13:24 
头像

注册: 2007-08-20 12:16
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
pferd 写道:
按照楼主的方法做的,打开swat网页后卫什么我只有很少的选项呢. 请见附件.

偶的和你的一样,正纳闷呢,只有4项,可能是swat没设置好 :D


_________________
Fantasy is just the beginning!...


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-04-21 16:33 

注册: 2008-04-16 8:05
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
LS,要用root用户访问


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-07-28 22:25 

注册: 2008-07-28 22:24
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
楼主,好帖阿! :lol: :lol: :lol: :lol: :lol:


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 21 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译