当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 太多的问题需要解决 !!!
帖子发表于 : 2005-11-28 10:28 

注册: 2005-09-16 13:10
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
我是从redhat开始学习linux的,总共也有两年多的时间了吧,虽然时间很长了,但是由于只是使用linux来工作,所以很多东西都是一知半解的,但是在redhat上面,从系统安装到系统软件的设置,基本上可以满足自己工作学习的需要了。

最近在笔记本上想装个linux,由于装了windows,硬盘空间也不是很多,在笔记本上想装个体积小一点的linux,我知道,很多人会说基本的linux系统体积不大,不管是redhat还是suse,或者是ubuntu, 我当然也知道在安装linux系统的时候选择软件包,但问题是,究竟该选择哪些东西才能既保证系统体积不会过大,又不会缺少某些必要的库文件,但是我在刚开始安装linux系统的时候,虽然选择了很多的软件包了,但是在使用过程中,经常提示缺少什么lib等等的,就那么一个lib库文件,我实在是不知道该到哪里去找,也不知道这个lib库文件是在哪个软件包里面。所以后来干脆就全部安装了,刚好也当作服务器使用。 在笔记本上,我不可能将redhat或者suse系统全部安装的,我将根分区划为5G,我希望系统体积控制在3.5G以下。
一直都听说Ubuntu非常不错,也非常希望尝试一下,所以就装了个Ubuntu5.1,总体来说,Ubuntu有两点非常让人满意,一是对硬件的支持非常好,竟然能即插即用,和windows一样了,而我原来用redhat9的时候,移动硬盘死都挂载不上,好不容易挂载上一次了,竟然把移动硬盘上的文件全部变成碎片了,害得我再也不敢使用移动硬盘了。 另外一点就是软件的安装管理非常方便。

但是也有不能让人满意的,首先就是基本的安装系统竟然没有安装gcc等编译器以及configure和make等linux下面必不可少的东西, 我知道很多人又会说了可以用apt-get来安装,可问题是,我即使用apt-get安装了gcc g++等,那那些相关的库怎么办,我不知道该怎样把相关的库补上,没有办法,只好搜索所有象libgcc等之类的库,并将他们全部装上,好了,总算是不缺库文件了,可是我的系统同时也不知道多了多少我用不到的东西了。 既然基本的系统能够包含 evolution firefox等软件,却为什么不把编译器和相关的库装上呢? 难道对于linux系统来说,evolution和firefox等比基本的编译器更重要吗? 对不起,我不想用 evolution和firefox, 我想用thunderbird和mazilla。 evolution和firefox可以不需要,但是gcc configure make等最基本的东西我想还没有哪个linux使用者不需要的吧。 这一点是我最不满意的地方了,如果对于一个没有网络的linux使用者,那又该怎么办?是不是就不能使用ubuntu了阿?

还有几个问题是:
1 我在redhat下面,使用ssh登陆别的linux机器时,xterm等x窗口可以显示到本机上来,或者现在本机上打开xhost,再在linux服务器上设置DISPALY的输出,也能把x窗口显示到本机上来,但是在Ubuntu上,不管我怎么弄都不行!!! 这一点对我来说非常重要,我需要登陆到服务器上工作,不如x窗口不能显示到本机,我可能只好更换系统了。 suse上面我试了试也不行,我不知道需要在哪里设置,真是郁闷,连windows下面的cygwin我都能够使用服务器的xwindows,而在linux系统上竟然不行 !!!
2 中文问题,我已经按照论坛上面的文档设置好了所有有关中文的个中设置,但是唯独fcitx的config文件在vi中显示乱码!!! 我只好使用gedit来打开它,什么原因阿??? 还好,用gedit将就一下也还能用,可是xmms和vlc呢?
哪怕他们如果能正常显示英语也好阿,用apt-get安装的xmms和vlc简直是一团乱码,从菜单到界面,所有的都是乱码!!! 我什么东西都看不清 !!! 算了,vlc我不要了,xmms从源码编译安装吧,我在redhat下面装过多次了,都没有问题,可是在ubuntu下面就是装不上,configure的时候提示gtk版本必须大于1.2,我已经装了gtk了,其他需要gtk的软件都没有问题,并且都已经提示gtk是2.0的版本了,而且我也已经装了一堆与gtk相关的库文件包了,竟然还是提示缺少gtk,当然可能是找不到 gtk-config, 我到哪里去找那东西阿? 郁闷 !!!

3 apache, 配置好了,系统启动时不会自己启动,但是从开始菜单里面的服务选项看,它已经在运行了,但是就是不行。手工启动吧,可是它不能识别cgi网页,将cgi的源码显示给我看,真是郁闷。 我对网页实在是不熟悉,但是在redhat下面经过简单的设置也能用,可是在这就是不行。

4 grub启动菜单共有6 7个选项了,我升级了内核版本,是新的内核将旧内核版本覆盖了,还是新的内核重新安装了? 从grub启动菜单看,旧的内核应该还存在于系统中,如果这样的话,那我多升级几次,系统岂不是越来越臃肿了?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-11-28 13:13 

注册: 2005-09-16 13:10
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
为什么没有人回答啊? 难道非得让我换个系统不成? 捣腾了很多天了,舍不得啊


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-11-28 13:24 
头像

注册: 2005-05-15 3:09
帖子: 427
送出感谢: 0 次
接收感谢: 0 次
内核问题,可以自己删除不用的吧。乱码问题可以用指南上面的本地语言环境设置解决。
如果出现LIB依赖问题的时候,可以用
apt-get -f install
来解决。
使用ssh登陆别的linux机器时,xterm等x窗口可以显示到本机上来?这个要教教我啊,如果我登陆到SUN的UNIX上面,也可以这样吗?
apache问题就。。。。我用tomcat就行了,这个不懂。
应该有人搞过这个的。


_________________
琴声如我


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-11-28 13:41 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
1 系统 系统管理 登录屏幕设置 安全 关闭 禁止TCP连接到X服务器.
2 fcitx的config的GB2312码,GEDIT会自动识别,VI不会
XMMS乱码,你搜搜论坛和主站点有很简单的解决办法.
3 查看主页上的如何安装apache服务指引
4 在新立得将不要的内核删除就会自动没有了.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-11-28 17:54 
头像

注册: 2005-11-01 18:23
帖子: 215
送出感谢: 0 次
接收感谢: 0 次
没有网络或许真的不该选择Ubuntu
我不喜欢自己到处去找软件然后make install,apt-get我觉得挺好,或许偶是一个懒人。这种超快的下载速度和便捷的安装,用得很省心。
FC和UB还有其它一些发行版都是各有所长,何必抱怨呢?
缺库好像有个auto-apt可以用,总比自己去找要省心吧.. :wink:


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-11-28 18:15 

注册: 2005-09-16 13:10
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
太感谢了,搞定!!!
:P :P :P :P :P


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-11-28 18:19 

注册: 2005-09-16 13:10
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
不过还是想问一下,如果自己编译安装xmms的话,那个gtk怎么弄阿? 有谁自己编译安装的吗?
我倒不是非得自己编译安装xmms,只是那个gtk太奇怪了,在很多软件中都需要gtk的。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-11-28 23:05 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
xmms用的是gtk1.2.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-12-04 23:33 

注册: 2005-12-01 16:38
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
我跟你同感,被几个库文件给折磨疯了,要编译区区一个声卡驱动,也不知道下了多少带C的包,./configure倒是通过了,可最终还是最终还是make失败,连提示都没有了,唉,苦啊,继续研究中。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Exabot [Bot], Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译