[求助]libc.so.6的问题,请大虾给个完整的解决方法

为当前最终发行版之前的所有版本提供支持
回复
头像
PentiumMMX
帖子: 51
注册时间: 2007-07-17 12:54
送出感谢: 0
接收感谢: 0

[求助]libc.so.6的问题,请大虾给个完整的解决方法

#1

帖子 PentiumMMX » 2007-07-26 11:20

Extracting temporary installation utilities to /home/scratch...
Executing the installation GUI...
Preparing to install...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
nawk: error while loading shared libraries: libm.so.6: cannot open shared object file: No such file or directory
dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
/bin/ls: error while loading shared libraries: librt.so.1: cannot open shared object file: No such file or directory
basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
hostname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

Launching installer...

grep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
/home/scratch/TEMP_ABAQUS_utils_root/jre/bin/java: error while loading shared libraries: libpthread.so.0: cannot open shared object file: No such file or directory
Removing temporary installation utilities...


...finished.


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

搜了一遍论坛和W找出来的帖子都没有给出易实现的解决方案。

ubuntu7.04里面是libc-2.5.so文件,安装了java6-jre 和jdk.

执行以下命令显示:

# grep "LD_ASSUME_KERNEL" /home/PentiumMMX/Desktop/abaqus/linux32/product/UNIX/Disk1/InstData/NoVM/install.bin



linux_LD_ASSUME_KERNEL_hack=0;
linux_LD_ASSUME_KERNEL_hack=1
# LD_ASSUME_KERNEL for Native POSIX Threading Library on some Linux distros
export LD_ASSUME_KERNEL=2.2.5
# unset the LD_ASSUME_KERNEL in cause we don't need it
unset LD_ASSUME_KERNEL
# check our rules for setting LD_ASSUME_KERNEL
linux_LD_ASSUME_KERNEL_hack=1
if [ $linux_LD_ASSUME_KERNEL_hack -eq 1 ]; then
LD_ASSUME_KERNEL=2.2.5
export LD_ASSUME_KERNEL

-------------------------------------------------------------
看来该工程软件的glibc要求的版本底呀,该怎么办

有人说将export LD_ASSUME_KERNEL注释掉,这能不影响安装吗?具体怎么操作,我试了一下,没有成功。
头像
PentiumMMX
帖子: 51
注册时间: 2007-07-17 12:54
送出感谢: 0
接收感谢: 0

#2

帖子 PentiumMMX » 2007-07-26 11:29

在线等各位编译高手来解决。
回复

回到 “老旧版本支持”