当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 27 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : mplayer的中文字幕成横线了..........
帖子发表于 : 2007-07-28 1:25 
头像

注册: 2007-01-06 3:26
帖子: 153
地址: FOX-HOUND
送出感谢: 0 次
接收感谢: 0 次
最近换成了kubuntu7.04,可mplayer的字幕按原来的设置显示的是横线........不知是怎么回事........

gui.config:
enable_audio_equ = "no"
vo_driver = "x11"
vo_panscan = "0.000000"
vo_doublebuffering = "yes"
vo_direct_render = "no"
vo_dxr3_device = "/dev/em8300-0"
v_framedrop = "0"
v_flip = "-1"
v_ni = "no"
v_idx = "-1"
vf_pp = "no"
vf_autoq = "0"
vf_lavc = "no"
ao_driver = "alsa"
ao_volnorm = "no"
softvol = "no"
ao_surround = "no"
ao_extra_stereo = "no"
ao_extra_stereo_coefficient = "1.000000"
dvd_device = "/dev/dvd"
cdrom_device = "/dev/cdrom"
osd_level = "1"
sub_auto_load = "yes"
sub_unicode = "yes"
sub_pos = "100"
sub_overlap = "no"
sub_cp = "unicode"
font_factor = "0.750000"
font_name = "/usr/share/fonts/truetype/msfonts/simhei.ttf"
font_encoding = "cp936"
font_text_scale = "3.850000"
font_osd_scale = "4.900000"
font_blur = "2.000000"
font_outline = "2.000000"
font_autoscale = "3"
cache = "no"
cache_size = "2048"
playbar = "yes"
load_fullscreen = "no"
show_videowin = "yes"
stopxscreensaver = "no"
autosync = "no"
autosync_size = "0"
gui_skin = "default"
gui_save_pos = "yes"
gui_main_pos_x = "583"
gui_main_pos_y = "647"
gui_video_out_pos_x = "3"
gui_video_out_pos_y = "24"
equ_band_00 = "0.000000"
equ_band_01 = "0.000000"
equ_band_02 = "0.000000"
equ_band_03 = "0.000000"
equ_band_04 = "0.000000"
equ_band_05 = "0.000000"
equ_band_06 = "0.000000"
equ_band_07 = "0.000000"
equ_band_08 = "0.000000"
equ_band_09 = "0.000000"
equ_band_10 = "0.000000"
equ_band_11 = "0.000000"
equ_band_12 = "0.000000"
equ_band_13 = "0.000000"
equ_band_14 = "0.000000"
equ_band_15 = "0.000000"
equ_band_16 = "0.000000"
equ_band_17 = "0.000000"
equ_band_18 = "0.000000"
equ_band_19 = "0.000000"
equ_band_20 = "0.000000"
equ_band_21 = "0.000000"
equ_band_22 = "0.000000"
equ_band_23 = "0.000000"
equ_band_24 = "0.000000"
equ_band_25 = "0.000000"
equ_band_26 = "0.000000"
equ_band_27 = "0.000000"
equ_band_28 = "0.000000"
equ_band_29 = "0.000000"
equ_band_30 = "0.000000"
equ_band_31 = "0.000000"
equ_band_32 = "0.000000"
equ_band_33 = "0.000000"
equ_band_34 = "0.000000"
equ_band_35 = "0.000000"
equ_band_36 = "0.000000"
equ_band_37 = "0.000000"
equ_band_38 = "0.000000"
equ_band_39 = "0.000000"
equ_band_40 = "0.000000"
equ_band_41 = "0.000000"
equ_band_42 = "0.000000"
equ_band_43 = "0.000000"
equ_band_44 = "0.000000"
equ_band_45 = "0.000000"
equ_band_46 = "0.000000"
equ_band_47 = "0.000000"
equ_band_48 = "0.000000"
equ_band_49 = "0.000000"
equ_band_50 = "0.000000"
equ_band_51 = "0.000000"
equ_band_52 = "0.000000"
equ_band_53 = "0.000000"
equ_band_54 = "0.000000"
equ_band_55 = "0.000000"
equ_band_56 = "0.000000"
equ_band_57 = "0.000000"
equ_band_58 = "0.000000"
equ_band_59 = "0.000000"


_________________
Elen síla lúmenn' omentielvo.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-28 9:11 

注册: 2006-10-24 11:46
帖子: 422
系统: debian
送出感谢: 0 次
接收感谢: 2
MPLAYER我一般只修改两地方就可以看中文字幕了

图形界面上
字体的那个标签选择中文字体
/usr/share/fonts/.../uming.ttf
旁边有个字幕的标签那里选择CP936


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-28 9:14 

注册: 2006-10-24 11:46
帖子: 422
系统: debian
送出感谢: 0 次
接收感谢: 2
sub_cp = "cp936"
font_factor = "0.750000"
font_name = "/usr/share/fonts/truetype/msfonts/simhei.ttf"
font_encoding = " unicode"
试试


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-28 9:30 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
安装smplayer, 字幕哪里选一个中文字体,字符集选cp936之类的。


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-07-28 10:36 
头像

注册: 2005-08-18 18:43
帖子: 3277
送出感谢: 0 次
接收感谢: 3
这么多字幕问题................> 每个人情况都不同一定要自己多实验 :P


_________________
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-07-28 10:52 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
内存不足 写道:
这么多字幕问题................> 每个人情况都不同一定要自己多实验 :P
:shock:


还是继续怂恿大家添加ubuntu-cn 源安装smplayer为好


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-07-28 10:58 
头像

注册: 2005-08-18 18:43
帖子: 3277
送出感谢: 0 次
接收感谢: 3
smplayer 也不是万能的 它也只是mplsyer的前端而已

解决了根本问题才好


_________________
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-07-28 11:01 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
内存不足 写道:
smplayer 也不是万能的 它也只是mplsyer的前端而已

解决了根本问题才好


这类问题以后我不参与了,反正我的mplayer对srt字幕没问题。


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-07-28 11:11 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
mplayer配置好了一般字幕问题不大,不过我确实遇到过某些特别的字幕加载不上,但是同样的字幕xine核心的是可以加载上的。

整体来说mplayer配置字幕比xine容易,xine还必须生成自己的专用字体。


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-07-28 13:03 
头像

注册: 2007-01-21 20:10
帖子: 749
送出感谢: 0 次
接收感谢: 0 次
内存不足 写道:
这么多字幕问题................> 每个人情况都不同一定要自己多实验 :P


是啊 :lol:


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-07-29 0:42 
头像

注册: 2007-01-06 3:26
帖子: 153
地址: FOX-HOUND
送出感谢: 0 次
接收感谢: 0 次
前段时间(重装以前),在ubuntu 7.04下,很轻送就搞定那个字幕了,就是选一下解码,再链接个字体,可现在不知为什么只有横线了.........


_________________
Elen síla lúmenn' omentielvo.


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-07-29 0:46 

注册: 2005-10-28 17:40
帖子: 172
送出感谢: 0 次
接收感谢: 0 次
你在mplayer的config文件里加上
font=path to your font
subfont=path to your font
就可以了。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-07-29 12:38 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
gmplayer有时候在字幕方面表现不好,现在看带字幕的片子都是在终端里 mplayer 加参数命令行搞


_________________
爱喝真猪奶茶的夜鸣猪


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-07-29 13:20 
头像

注册: 2007-01-21 20:10
帖子: 749
送出感谢: 0 次
接收感谢: 0 次
重新编译一回。加上--enable-freetype

刚才又看了些资料,觉得mplayer这么多的字幕问题,不是编译的问题,而可能是mplayer的一个bug。linuxsir上有个人和我有类似的经历,最后是删除了/etc/mplayer后就搞定了(但是我当初是没这个文件夹的)。

理论上命令行里指定的参数优先级最高,即使其它地方存在配置文件,也会按照命令行里的工作。可linuxsir那位就是一个反例。

我现在觉得并不是简单的编译时加了句--enable-freetype解决了问题,可能是其它。编码嘛,为什么同样的字幕之前不行,现在又行了呢

继续找找


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-08-01 11:48 
头像

注册: 2007-01-06 3:26
帖子: 153
地址: FOX-HOUND
送出感谢: 0 次
接收感谢: 0 次
我是源上直接安装的......

加了
font=path to your font
subfont=path to your font
後,启动不了了.........


_________________
Elen síla lúmenn' omentielvo.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 27 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译