[问题]我怎么连pkgconfig安装都有问题?

为当前最终发行版之前的所有版本提供支持
回复
redbee123
帖子: 4
注册时间: 2007-07-25 22:57
送出感谢: 0
接收感谢: 0

[问题]我怎么连pkgconfig安装都有问题?

#1

帖子 redbee123 » 2007-07-29 20:05

我是新手,刚刚安装ubuntu 6.06(单光盘690M版)的,已经更新了所有程序,现在想装gtk2.6,到网上搜索资料,全部很简单,都是最先要安装pkg-config
./configure --prefix=/usr
make ;
make instal
但是第一步就有问题了,根据提示,我已经安装了make, automake, gcc, gcc4.0,libtool,g77,gmak,但是还有一些问题没有解决,
checking for working makeinfo... missing
checking whether to enable maintainer-specific portions of Makefiles... no
checking for Cygwin environment... (cached) no
checking for mingw32 environment... (cached) no
.............
checking whether the C compiler (gcc ) is a cross-compiler... no
checking for executable suffix... (cached) no
checking whether -lc should be explicitly linked in... (cached) no
checking whether the C compiler (gcc ) is a cross-compiler... no
.........
checking whether to enable maintainer-specific portions of Makefiles... no
checking host system type... i686-pc-linux-gnu
checking whether to enable memory checking... no
checking whether to enable memory profiling... no
checking for gcc... (cached) gcc
checking whether the C compiler (gcc -g -O2 ) works... yes
checking whether the C compiler (gcc -g -O2 ) is a cross-compiler... no
后面的也有提示creat好多东西,也不知道有没有成功,
第二步make出现的问题更多,多次出现
make[4]: Nothing to be done for `all'.

天啊,我想装OFF2,GTK+2.6,只是其中一个条件啊,而pkgconfig只是GTK+2.6的一步,请大虾帮帮忙,先我装上GTK+v2.6,我已经装了两天了
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-07-29 20:07

704..apt
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
redbee123
帖子: 4
注册时间: 2007-07-25 22:57
送出感谢: 0
接收感谢: 0

#3

帖子 redbee123 » 2007-07-29 21:07

请问楼上704..apt是什么东东,俺是新人啊?不明白就是不明白
redbee123
帖子: 4
注册时间: 2007-07-25 22:57
送出感谢: 0
接收感谢: 0

#4

帖子 redbee123 » 2007-07-29 21:13

是不是说要安装7.04版本的ubuntu 啊?
回复

回到 “老旧版本支持”