apt-get 无法启动,提示需要文件。

为当前最终发行版之前的所有版本提供支持
回复
traveller2
帖子: 16
注册时间: 2005-10-08 20:22
送出感谢: 0
接收感谢: 0

apt-get 无法启动,提示需要文件。

#1

帖子 traveller2 » 2005-11-30 16:21

happy@trubuntu:~$ ls /usr/lib/libstdc*
/usr/lib/libstdc++.so.6.0.5

happy@trubuntu:/boot$ sudo apt-get update
apt-get: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

happy@trubuntu:~$sudo ln -s /usr/lib/libstdc++.so.6.0.5 /usr/lib/libstdc++.so.6

happy@trubuntu:/boot$ ls -l /usr/lib/libstdc*
lrwxrwxrwx 1 root root 27 2005-11-30 16:39 /usr/lib/libstdc++.so.6 -> /usr/lib/libstdc++.so.6.0.5
-rwxr-xr-x 1 root root 804032 2005-11-30 15:27 /usr/lib/libstdc++.so.6.0.5

happy@trubuntu:~$ sudo apt-get update
apt-get: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.4' not found (required by apt-get)
apt-get: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.4' not found (required by /usr/lib/libapt-pkg-libc6.3-6.so.3.10)

I'am sorry i can't write in chinase.
上次由 traveller2 在 2005-11-30 18:18,总共编辑 2 次。
traveller2
帖子: 16
注册时间: 2005-10-08 20:22
送出感谢: 0
接收感谢: 0

#2

帖子 traveller2 » 2005-11-30 18:11

无法启动apt-get,什么也做不了,咋办?
traveller2
帖子: 16
注册时间: 2005-10-08 20:22
送出感谢: 0
接收感谢: 0

#3

帖子 traveller2 » 2005-11-30 18:11

新装其系统。5.10
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2005-12-01 1:14

$ dpkg -l libst*|grep ii
ii libstartup-not 0.8-0ubuntu1 library for program launch feedback (shared
ii libstdc++5 3.3.5-8ubuntu2 The GNU Standard C++ Library v3
ii libstdc++6 4.0-0pre6ubunt The GNU Standard C++ Library v3
没有GLIBCXX。我的正常。
~$ ll /usr/lib/libstdc++.so*
lrwxrwxrwx 1 root root 18 2005-11-22 18:42 /usr/lib/libstdc++.so.5 -> libstdc++.so.5.0.7
-rw-r--r-- 1 root root 737816 2005-02-11 07:25 /usr/lib/libstdc++.so.5.0.7
lrwxrwxrwx 1 root root 18 2005-11-23 16:28 /usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.4
-rw-r--r-- 1 root root 855544 2005-04-02 21:57 /usr/lib/libstdc++.so.6.0.4
hoary的稳定些
● 鸣学
回复

回到 “老旧版本支持”