[问题]Ubuntu启动的时候会自动重命名Windows分区下的文件 怎么办啊!

为当前最终发行版之前的所有版本提供支持
回复
wzlsquall
帖子: 11
注册时间: 2007-07-12 13:39
送出感谢: 0
接收感谢: 0
联系:

[问题]Ubuntu启动的时候会自动重命名Windows分区下的文件 怎么办啊!

#1

帖子 wzlsquall » 2007-08-01 10:47

我安装了Ubuntu 7.04 和Windows XP,启动Ubuntu的时候在检查磁盘时总是会提示一些信息,例如:
xxxxxxx
bad file

auto-rename
000

类似的提示,然后就自动给我的windows下的文件重命名了, 出现这种情况是怎么回事啊,我该怎么办才能让他不会重命名啊?

高手帮忙啊!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-08-01 10:49

cat /etc/mtab
看你如何挂载的。
● 鸣学
wzlsquall
帖子: 11
注册时间: 2007-07-12 13:39
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 wzlsquall » 2007-08-01 10:54

那查看了之后有什么对策啊?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2007-08-01 10:57

你看不懂,就贴出来。等知道的人来解释罗。
● 鸣学
wzlsquall
帖子: 11
注册时间: 2007-07-12 13:39
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 wzlsquall » 2007-08-01 11:30

root@wzlsquall:~# cat /etc/mtab
/dev/sda4 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
procbususb /proc/bus/usb usbfs rw 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
lrm /lib/modules/2.6.20-15-generic/volatile tmpfs rw 0 0
/dev/sda1 /media/sda1 vfat rw,utf8,umask=007,gid=46 0 0
/dev/sda2 /media/sda2 vfat rw,utf8,umask=007,gid=46 0 0
/dev/sda3 /media/sda3 vfat rw,utf8,umask=007,gid=46 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
root@wzlsquall:~#
wzlsquall
帖子: 11
注册时间: 2007-07-12 13:39
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 wzlsquall » 2007-08-01 12:58

高人指点啊
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 skyx » 2007-08-01 13:22

You'd better hava your disk checked in windows, maybe
no security measure is worth anything if an attacker has physical access to the machine
头像
aitilang
帖子: 1026
注册时间: 2007-04-28 21:38
送出感谢: 0
接收感谢: 0

#8

帖子 aitilang » 2007-08-01 13:55

干脆把那几个vfat格式的行从里面删掉,一了百了。。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2007-08-01 14:41

umask=007,gid=46 你在/etc/fstab里面设置的??不要。
● 鸣学
wzlsquall
帖子: 11
注册时间: 2007-07-12 13:39
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 wzlsquall » 2007-08-01 23:23

明天试试,谢谢大家帮忙!
wzlsquall
帖子: 11
注册时间: 2007-07-12 13:39
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 wzlsquall » 2007-08-02 9:21

Problem has been solved !

sudo gedit /etc/fstab

modify
/dev/sda1 /media/sda1 vfat rw,utf8,umask=007,gid=46 0 1
/dev/sda2 /media/sda2 vfat rw,utf8,umask=007,gid=46 0 1
/dev/sda3 /media/sda3 vfat rw,utf8,umask=007,gid=46 0 1

to

/dev/sda1 /media/sda1 vfat rw,utf8,umask=007,gid=46 0 0
/dev/sda2 /media/sda2 vfat rw,utf8,umask=007,gid=46 0 0
/dev/sda3 /media/sda3 vfat rw,utf8,umask=007,gid=46 0 0
回复

回到 “老旧版本支持”