[问题]如何卸载Ubuntu默认安装好的一个包然后编译安装一个更新的版本?

为当前最终发行版之前的所有版本提供支持
回复
xell
帖子: 174
注册时间: 2006-08-26 19:52
送出感谢: 0
接收感谢: 0

[问题]如何卸载Ubuntu默认安装好的一个包然后编译安装一个更新的版本?

#1

帖子 xell » 2007-08-01 17:28

RT,我现在希望自己编译安装librsvg2,但是系统默认安装了,而且我尝试remove的时候发现要remove很多相关的包,我不敢贸然remove掉……

怎么能确定安全的remove一个包(库)呢?
头像
nihui
帖子: 1746
注册时间: 2006-10-21 12:03
来自: Shanghai
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 nihui » 2007-08-01 17:32

如果楼主有足够的自信确定这样子不会导致依赖问题的话,那就强制删除。。

librsvg2 还不算很底层的包,删除的话,apt 可以(kde 下面)


另:其实不删除也可以编译的。。 :?
.

私人空间
附有 Magic Linux 2.1 最新开发日志~


미안하다, 사랑한다


欢迎来 #xfce-cn 中文频道~~
xell
帖子: 174
注册时间: 2006-08-26 19:52
送出感谢: 0
接收感谢: 0

#3

帖子 xell » 2007-08-01 17:51

我也觉得不删除编译肯定可以,但是会不会有冲突呢?
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#4

帖子 jarlyyn » 2007-08-01 17:56

最好是不删除编译。

举个例子

如果楼主要编译最基本的网络协议的库

那么,如果删除的话,所有需要网络功能的软件都会被自动删除,楼主觉得有必要吗?

我的推荐是


用checkinstall做个包,版本比现有的版本高,那样是最安全的了
xell
帖子: 174
注册时间: 2006-08-26 19:52
送出感谢: 0
接收感谢: 0

#5

帖子 xell » 2007-08-01 18:01

不太明白楼上的关于checkinstall做包的问题。能不能说的详细点或者给点资料?
回复

回到 “老旧版本支持”