普通用户不能打开thunderbird...

为当前最终发行版之前的所有版本提供支持
回复
头像
murtrix
帖子: 16
注册时间: 2006-04-09 1:04
送出感谢: 0
接收感谢: 0

普通用户不能打开thunderbird...

#1

帖子 murtrix » 2007-08-01 23:05

小弟用的是7.04,嫌源里的软件版本低,于是自己装了一些,如:
mozilla 1.8a5, seamonkey 1.x, thunderbird 2.0
(都是从官网上下的.tar.gz 文件)
可是,用root进入gnome后,可以正常启动这些程序,
但是,用普通用户进入gnome后,就不能启动,
显示如下:

foxer@matrix:~$ thunderbird
Segmentation fault (core dumped)
foxer@matrix:~$ su
Password:
To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

root@matrix:/home/foxer# thunderbird
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key

(thunderbird-bin:25182): Gtk-WARNING **: cannot open display:
root@matrix:/home/foxer#

各位大哥请指点一二!
techie
帖子: 98
注册时间: 2005-11-24 11:28
送出感谢: 0
接收感谢: 0

#2

帖子 techie » 2007-08-02 8:13

呵呵,我原来也遇到过这种情况,不过后来重启了几次就好了。不清楚是因为重启之间安装了什么包,还是其它的什么原因,莫名奇妙的就好了。
回复

回到 “老旧版本支持”