ubuntu 重装之旅遭遇问题,求助<已解决>

为当前最终发行版之前的所有版本提供支持
回复
头像
piziliu88
帖子: 94
注册时间: 2007-06-02 23:08
送出感谢: 0
接收感谢: 0
联系:

ubuntu 重装之旅遭遇问题,求助<已解决>

#1

帖子 piziliu88 » 2007-08-03 19:28

终于开始完善我的UBUNTU,但是昨天不知道为什么确捅了个大篓子,从未遇见过的问题,不知道有没有高手能帮忙一下,感激不尽。
刚开始从源的配置,字体,分辨率,触摸板,一切正常,但是开始配置播放器时出问题了。我配置MPLAYER。因为源里有这个软件,所以就先在源里下好。然后开始配置编译器和字幕时,因为是在网上找的解决办法,按照上面说的:
sudo apt-get install mplayer-386
sudo apt-get install mplayer-fonts
sudo apt-get install mozilla-mplayer
sudo cp /etc/mplayer/mplayer.conf /etc/mplayer/mplayer.conf_backup
sudo gedit /etc/mplayer/mplayer.conf
其实这些个文件在源里也有,但是本人认为既然有那么再重新下一次也没有关系,以防后面的步骤有什么疏漏,但是配完了就发觉MPLAYER可以用了,但是新立得用不了了,提示是 /var/lib/apt/list/cn.archive.ubuntu.com_ubuntu_dists_edgy-backports_restricted_binary-i386_Packages有问题。
论坛上也有人有类似的问题,他的解决办法是把那些个软件包删了。我就这么连续删了几个软件包,都是在/var/lib/apt/list/下,还删了/var/lib/dpkg/status.开始知道问题严重了,那以后打开新立得的报错变成:
E: 无法打开文件 /var/lib/dpkg/status - open (2 No such file or directory)
E: 无法解析或打开软件包列表或状态文件。
E: _cache->open() failed, please report.
这下想来这两天重装是白装了,得重来了,还是抱着死马当活马医的心态,发给兄弟们看看,不知道有人知道怎么拯救不?如果2天内没有解决方法只好重来了,所以请兄弟们帮帮忙,谢谢了
上次由 piziliu88 在 2007-08-05 12:56,总共编辑 1 次。
linux的运用在于不断的探索和询问
头像
piziliu88
帖子: 94
注册时间: 2007-06-02 23:08
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 piziliu88 » 2007-08-03 19:30

其实如果能进的了新立得的话,那么可以把损坏的软件包,删了,只是一报错,将报错窗口关了后新立得也跟着退出了,这就没法子了
linux的运用在于不断的探索和询问
头像
nihui
帖子: 1746
注册时间: 2006-10-21 12:03
来自: Shanghai
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 nihui » 2007-08-03 19:40

/var/lib/apt/list/cn.archive.ubuntu.com_ubuntu_dists_edgy-backports_restricted_binary-i386_Packages
把 sources.list 中带有 edgy 字样的条目删除。
软件源不能同时用两个版本的。
.

私人空间
附有 Magic Linux 2.1 最新开发日志~


미안하다, 사랑한다


欢迎来 #xfce-cn 中文频道~~
头像
piziliu88
帖子: 94
注册时间: 2007-06-02 23:08
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 piziliu88 » 2007-08-05 12:55

修好了,把edgy类型的源删了,然后 sudo apt-get update ,再从 livecd中把 /var/lib/dpkg/status文件拷到自己本身的那个系统目录下,重新sudo apt-get update,衷心感谢楼上,不胜感激 :)
linux的运用在于不断的探索和询问
头像
quanet
帖子: 5
注册时间: 2011-08-26 14:21
送出感谢: 0
接收感谢: 0

Re: ubuntu 重装之旅遭遇问题,求助<已解决>

#5

帖子 quanet » 2011-09-07 15:11

我也遇到相同的问题,可是在sources.list中找不到edgy类型的源啊,可不可以请楼上说详细点?谢谢
回复

回到 “老旧版本支持”