[求救]安装、安装、安装。。。我要崩溃了

为当前最终发行版之前的所有版本提供支持
回复
头像
levin
帖子: 109
注册时间: 2007-07-26 12:40
来自: 南京
送出感谢: 0
接收感谢: 0
联系:

[求救]安装、安装、安装。。。我要崩溃了

#1

帖子 levin » 2007-08-05 16:13

小弟我今天上网找了个软件来用用
安装时说我一大堆包版本低 什么libc6,libfreetype.....
以前我也遇到过同样的问题,而且apt-get update && apt-get dist-upgrade 系统会告诉你什么都是newest version
(我是5.10升到6.06LTS的)(我的源是cn99)
以前我没管过,算了就算了。但是今天那个软件是放在http://www.debian.org/distrib/packages 上的
这个网站牛的很,什么包都有,我就想手动摆平依赖关系。。。
结果装了6,7个包后,装不下去了,这时我发现。。。。。。。
目前看来除了firefox,其他地方都用不了中文输入了,包括terminal,text editor.......
而且字体也有点变化(说实话,变得好看了),但是我不知道这几个包手动升级后弄乱了包的依赖后会带来怎样的后果,小弟想回到原来的状态也困难重重。。。郁闷中

想请各位大虾帮帮我

到底为什么我的包版本低 是因为源不好,还是系统内核低,还是6.06这个版本的问题
到底怎样才能让我的依赖关系变好

这里附上我的(我已经手动还原了一个包-libc6,其他的似乎不太容易):
pluto@ubuntu:/dev$ sudo apt-get -f install
Password:
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... failed.
The following packages have unmet dependencies.
libfontconfig1: Depends: libc6 (>= 2.3.6-6) but 2.3.6-0ubuntu20.5 is installed
Depends: fontconfig-config (= 2.4.2-1.2) but it is not installable
libfontconfig1-dev: Depends: libfontconfig1 (= 2.3.2-1.1ubuntu12) but 2.4.2-1.2 is installed
libfreetype6: Depends: libc6 (>= 2.6-1) but 2.3.6-0ubuntu20.5 is installed
libfreetype6-dev: Depends: libfreetype6 (= 2.1.10-1ubuntu2.4) but 2.3.5-1+b1 is installed
libgcc1: Depends: libc6 (>= 2.6-1) but 2.3.6-0ubuntu20.5 is installed
libqt3-mt: Depends: libc6 (>= 2.5-5) but 2.3.6-0ubuntu20.5 is installed
Depends: libpng12-0 (>= 1.2.13-4) but 1.2.8rel-5ubuntu0.2 is installed
Depends: libxrandr2 (>= 2:1.2.0) but 1:1.1.0.2-0ubuntu4 is installed
libqt3-mt-dev: Depends: libqt3-mt (= 3:3.3.6-1ubuntu6.3) but 3:3.3.7-5 is installed
libstdc++6: Depends: libc6 (>= 2.6-1) but 2.3.6-0ubuntu20.5 is installed
pdfedit: Depends: libc6 (>= 2.3.6-6) but 2.3.6-0ubuntu20.5 is installed
zlib1g: Depends: libc6 (>= 2.5-5) but 2.3.6-0ubuntu20.5 is installed
zlib1g-dev: Depends: zlib1g (= 1:1.2.3-6ubuntu4) but 1:1.2.3.3.dfsg-5 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

救救我吧
But for Ubuntu, I will die.
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-08-05 16:16

什么软件
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
jimhu
帖子: 1322
注册时间: 2006-01-25 22:29
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 jimhu » 2007-08-05 16:31

源里面的软件更新会比官方的慢。
提示缺少什么的话,就去这个软件的官方网站下载咯。
debain的包和ubuntu好像不是全部通用的。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 skyx » 2007-08-05 16:45

楼主主要是源的问题,另外

xiechy 写了:貌似千万不要跨版升级的说。这是由于ubuntu基于debian,而debian本身是不提供跨版升级支持的(debian-policy)。很多虚拟包,过渡包,元包,都在跨版后有可能出错。



ubuntu跨版升级,没看官方升级说明,跨版升级是很危险的。
no security measure is worth anything if an attacker has physical access to the machine
头像
levin
帖子: 109
注册时间: 2007-07-26 12:40
来自: 南京
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 levin » 2007-08-05 16:49

先谢谢 大家再集思广益啊
But for Ubuntu, I will die.
头像
levin
帖子: 109
注册时间: 2007-07-26 12:40
来自: 南京
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 levin » 2007-08-05 16:50

回2楼的
是一个叫pdfedit的软件
But for Ubuntu, I will die.
头像
levin
帖子: 109
注册时间: 2007-07-26 12:40
来自: 南京
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 levin » 2007-08-05 17:08

大家说我是源的问题,应该是吧
我当初依据论坛里的快速设置指南配置ubuntu
而关于源只加了个cn99 我当时以为都一样 cn99快 我就加了这个 结果现在许多包版本低
我刚才又参考了快速指南 加了一些源 但是因为依赖关系乱的一塌糊涂 不能更新啊
怎么办
大家加油 帮我想想办法
But for Ubuntu, I will die.
leeyee
帖子: 723
注册时间: 2006-04-11 9:01
送出感谢: 0
接收感谢: 0

#8

帖子 leeyee » 2007-08-05 19:34

你的系统环境是6.06,但想要安装的debian软件包可能超前了。找一个低版本的安装看看,或者把系统升到7.04。
I would love to change the world, but they won't give me the source code.
http://hi.baidu.com/wienerlee
头像
levin
帖子: 109
注册时间: 2007-07-26 12:40
来自: 南京
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 levin » 2007-08-05 20:34

leeyee 写了:你的系统环境是6.06,但想要安装的debian软件包可能超前了。找一个低版本的安装看看,或者把系统升到7.04。


我是从5。10升到6。06的 还能继续升到7。04吗? 该怎么升啊 ?
低版本的包不好找啊
现在最大的问题是因为依赖关系乱了apt-get install不能用了
不能更新。。。
But for Ubuntu, I will die.
头像
fortruth
帖子: 1795
注册时间: 2005-11-06 1:51
来自: 七彩云世界
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 fortruth » 2007-08-05 20:50

学得不精,,lx见笑了....
lz还请参考:

ubuntu的安装与离线升级、跨版升级和备份策略
上次由 fortruth 在 2007-08-05 21:02,总共编辑 1 次。
佛出寺,求索真世界 For_Truth:Free_Open_Share
OPEN GPG KEY:03D18D95
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#11

帖子 skyx » 2007-08-05 20:56

楼上最好到官方英文站看下

xiechy 写了:貌似千万不要跨版升级的说。这是由于ubuntu基于debian,而debian本身是不提供跨版升级支持的(debian-policy)。很多虚拟包,过渡包,元包,都在跨版后有可能出错。



ubuntu跨版升级,没看官方升级说明,跨版升级是很危险的。
no security measure is worth anything if an attacker has physical access to the machine
回复

回到 “老旧版本支持”