终端里 这样 显示 什么 软件 都装不了 也不能 卸载了 什么 原因 阿 ?

为当前最终发行版之前的所有版本提供支持
回复
ll2003520
帖子: 7
注册时间: 2007-08-04 23:10
送出感谢: 0
接收感谢: 0

终端里 这样 显示 什么 软件 都装不了 也不能 卸载了 什么 原因 阿 ?

#1

帖子 ll2003520 » 2007-08-06 14:03

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#2

帖子 xhy » 2007-08-06 14:10

you must manually run 'dpkg --configure -a' to correct the problem.
目前负债150多万
ll2003520
帖子: 7
注册时间: 2007-08-04 23:10
送出感谢: 0
接收感谢: 0

#3

帖子 ll2003520 » 2007-08-06 14:14

xhy 写了:you must manually run 'dpkg --configure -a' to correct the problem.
运行 了 阿

wendaoliang@wendaoliang-desktop:~$ dpkg --configure -a
dpkg: 该操作需要超级用户权限
wendaoliang@wendaoliang-desktop:~$ sudo -i dpkg --configure -a
/usr/bin/dpkg: /usr/bin/dpkg: cannot execute binary file
wendaoliang@wendaoliang-desktop:~$

这样 还是 不行 阿
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#4

帖子 xhy » 2007-08-06 14:17

sudo -i dpkg --configure -a // -i 不要

sudo dpkg --configure -a
目前负债150多万
ll2003520
帖子: 7
注册时间: 2007-08-04 23:10
送出感谢: 0
接收感谢: 0

#5

帖子 ll2003520 » 2007-08-06 14:24

可以了 要谢谢楼上 阿 但 为什么 会 这样呢 "sudo -i dpkg --configure -a " 不执行命令吗? 所以 必须 再重 输入一次命令。
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#6

帖子 xhy » 2007-08-06 14:32

sudo的语法规定的 最后一个域是 {-e file [...] | -i | -s | command}

-i 和 命令不能共存
目前负债150多万
ll2003520
帖子: 7
注册时间: 2007-08-04 23:10
送出感谢: 0
接收感谢: 0

#7

帖子 ll2003520 » 2007-08-06 14:37

恩 好的 谢谢
回复

回到 “老旧版本支持”