[讨论]初装ubuntu的ip设置问题

为当前最终发行版之前的所有版本提供支持
回复
Akirasai
帖子: 2
注册时间: 2007-08-08 10:48
送出感谢: 0
接收感谢: 0

[讨论]初装ubuntu的ip设置问题

#1

帖子 Akirasai » 2007-08-08 11:10

初学,见笑了
装好ubuntu 7.04之后在gui系统设置里设定了eth0的静态ip
但是因为局域网里面有个dhcp服务器,所以貌似网卡的ip设置无效,始终是自动获取的那个ip,根本不认静态ip设置

难道这是个bug?
还是一定要在shell中输入才行?

求解
Akirasai
帖子: 2
注册时间: 2007-08-08 10:48
送出感谢: 0
接收感谢: 0

#2

帖子 Akirasai » 2007-08-08 16:27

没人来帮忙么
太受打击了,第一次用ubuntu居然连ip地址都设置不了
ltc100
帖子: 35
注册时间: 2007-07-31 15:00
送出感谢: 0
接收感谢: 0

#3

帖子 ltc100 » 2007-08-08 16:38

把DHCP服务关闭了不就行了?
我也是菜鸟,学习中。
头像
xiaokang
帖子: 331
注册时间: 2006-06-13 14:47
来自: 黄鹤楼
送出感谢: 0
接收感谢: 1 次

#4

帖子 xiaokang » 2007-08-08 16:55

能启动GUI?
在系统--系统管理---网络中进行设置。。

GUI很简单,就不多说了!
xnsxcoolczh
帖子: 9
注册时间: 2007-08-10 10:38
送出感谢: 0
接收感谢: 0

#5

帖子 xnsxcoolczh » 2007-08-11 14:47

我也是在gui中设置就是没有作用 ,是怎么回事呀
头像
boydd
帖子: 255
注册时间: 2007-05-10 19:42
来自: 南京, Deutschland, Karlsruhe
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 boydd » 2007-08-11 23:06

代码: 全选

auto lo
iface lo inet loopback


iface eth0 inet static
address 172.20.20.11
netmask 255.255.0.0
gateway 172.20.23.254


auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

auto eth0
可以是通过修改/etc/network/interfaces来设置ip地址和关闭dhcp,只要吧有auto和dhcp的那行删除就可以了(不过千万在修改前备份此文件!!!!)
然后
ifdown eth0
ifup eth0
就可以了
yclwl
帖子: 37
注册时间: 2007-05-27 10:30
来自: 江苏
送出感谢: 0
接收感谢: 0

#7

帖子 yclwl » 2007-09-09 23:58

其实 自己仔细找下 就能弄好 很简单的
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#8

帖子 stlxv » 2007-09-10 0:08

xnsxcoolczh 写了:我也是在gui中设置就是没有作用 ,是怎么回事呀
肯定没弄对
PHP是最好的语言!不服来战!
complorer@163.com
帖子: 3
注册时间: 2007-08-24 21:50
送出感谢: 0
接收感谢: 0

我的网络也不通!

#9

帖子 complorer@163.com » 2007-09-20 15:24

stlxv 写了:
xnsxcoolczh 写了:我也是在gui中设置就是没有作用 ,是怎么回事呀
肯定没弄对
:oops:
在gui中设置了ip,netmask,gateway(和windows下的一样),网络不通。(一块网卡,windows下网络正常)
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#10

帖子 windwiny » 2007-09-20 16:15

ifconfig eth0 192.168.1.243 netmask 255.255.255.0 up
route add default gw 192.168.1.1

设置ip后,添加网关
头像
chattan
论坛版主
帖子: 3922
注册时间: 2007-07-11 20:59
送出感谢: 0
接收感谢: 0
联系:

Re: [讨论]初装ubuntu的ip设置问题

#11

帖子 chattan » 2007-09-20 17:14

Akirasai 写了:初学,见笑了
装好ubuntu 7.04之后在gui系统设置里设定了eth0的静态ip
但是因为局域网里面有个dhcp服务器,所以貌似网卡的ip设置无效,始终是自动获取的那个ip,根本不认静态ip设置

难道这是个bug?
还是一定要在shell中输入才行?

求解
有问题也是你那里的服务器或者是你的设置问题。

我也是通过局域上网,我也是设的静态IP!一切正常!
lusijin
帖子: 73
注册时间: 2007-02-07 19:54
送出感谢: 0
接收感谢: 0

Re: [讨论]初装ubuntu的ip设置问题

#12

帖子 lusijin » 2009-04-30 15:17

修改interfaces时不能保存,说我没权限

新手请教
回复

回到 “老旧版本支持”