[问题]如何安装软件?不要APT或新立得!

为当前最终发行版之前的所有版本提供支持
回复
头像
bird
帖子: 765
注册时间: 2006-09-04 10:45
送出感谢: 0
接收感谢: 0
联系:

[问题]如何安装软件?不要APT或新立得!

#1

帖子 bird » 2007-08-09 9:10

新装的ubuntu 6.06,但是发现自己从网上下载下来的软件不太好安装,特别是一些源代码需要编译的软件(一般都是一个tar.gz的压缩包),网上查了好多资料,感觉没有讲的很清楚的,一步一步讲怎么做?每一步是什么意思?为什么要那么做……等等;以至于下了好多软件,都不能安装,比如opera什么的,郁闷阿……

各位大虾帮帮忙把,详细的说一说,小弟不胜感激!

(不需要APT或者新立得的方法,这些已经很熟悉了)
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-08-09 9:12

viewtopic.php?t=4427&highlight=

其实,还是建议aptitude
● 鸣学
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#3

帖子 bones7456 » 2007-08-09 9:18

LZ需要的是编译的方法吧。
一般就是
./configure
make
sudo make install
3步。具体要看具体的包了,不能一概而论。
关注我的blog: ε==3
头像
bird
帖子: 765
注册时间: 2006-09-04 10:45
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 bird » 2007-08-09 9:35

不是不想用apt,编译这个也是很需要的,apt很方便,但是有些软件如果源里没有的话,那不就郁闷了?

2楼、3楼,可不可以说的更明白一点阿……
leeyee
帖子: 723
注册时间: 2006-04-11 9:01
送出感谢: 0
接收感谢: 0

#5

帖子 leeyee » 2007-08-09 10:09

源里没有的软件如果要安装,那一定在下载它的地方或者它的压缩包里有附带的安装说明。常见的安装方法就是几种:
1,deb包(rpm包)。用apt-get或者dpkg安装,如果出错基本上是依赖问题,解决后再继续安装;
2,源码编译。首先请务必看安装说明(README或INSTALL文件)就是常见的三步。./configure是为了检查系统中库、编译工具是否符合要求,make是进行编译,make install是安装;
3,二进制安装脚本。如.bin文件,一般大一点的商业软件是这种安装方式,基本不会出现依赖问题。比如Quake,MATLAB之类;
4,可执行文件。不需要安装,解压缩就可以运行,只要把它们放到想要的地方就可以了。
I would love to change the world, but they won't give me the source code.
http://hi.baidu.com/wienerlee
头像
vvoody
帖子: 749
注册时间: 2007-01-21 20:10
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 vvoody » 2007-08-09 10:35

Opera不开源,给你的不是源码,执行那个sh文件后只是把文件复制到prefix里去。
回复

回到 “老旧版本支持”