我的机器安装过程即出现的问题!!!

为当前最终发行版之前的所有版本提供支持
回复
stonethree
帖子: 32
注册时间: 2005-11-04 9:47
来自: 武汉
送出感谢: 0
接收感谢: 0
联系:

我的机器安装过程即出现的问题!!!

#1

帖子 stonethree » 2005-12-04 14:50

机器配置:
dell latitude l400
cpu: p3700
ram: 128m
hda: 10g
无cdrom、floppy.
有个硬盘转接卡

安装过程

将本本上的硬盘拆下来, 用转接卡接到台式机上,设成从盘
然后用在xp/2000下的方式安装:希望只装server,所以boot的时候加了
参数server;可没有用,gnome照装不误:
无奈,重新来过;等装完基本系统后;把硬盘拆下来,装回本本,启动后他会装packges,我就狂按esc,他就不装了
重新起动后,进入系统,先把ip搞了一下,然后ping网成功,
开始安装中文输入法scim,装好后没什么反应,怀疑是不是没有xwindow,
看到大家说fvwm省空间,且可以diy,就装fvwm,装好后,startx
完了,出现提示:
时间: 2005-12-03 周六, 下午8:07 标题: [问题]装了server版,想装fvwm,运行startx,出现错误!帮帮我呀!

--------------------------------------------------------------------------------

信息:xauth: creating new authority file /root/.serverauth.6261


X Window System Version 6.8.2 (Ubuntu 6.8.2-77 20051010174523 root@vernadsky.buildd)
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.10 i686 [ELF]
Current Operating System: Linux ubuntu 2.6.12-10-686 #1 Fri Nov 18 12:09:04 UTC 2005 i686
Build Date: 10 October 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.12-10-686 (buildd@terranova) (gcc version 3.4.5 20050809 (prerelease) (Ubuntu 3.4.4-6ubuntu8)) #1 Fri Nov 18 12:09:04 UTC 2005
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 3 19:52:00 2005
(==) Using config file: "/etc/X11/xorg.conf"
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o": No symbols found
(EE) Failed to load module "synaptics" (module does not exist, 0)
Skipping "/usr/X11R6/lib/modules/libfb.a:fbmmx.o": No symbols found
(EE) No Input driver matching `synaptics'
Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.Z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.Z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.Z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0

waiting for X server to shut down

xorg.conf文件内容
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Rage Mobility P/M (AGP)"
Driver "ati"
BusID "PCI:1:0:0"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Rage Mobility P/M (AGP)"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#2

帖子 catinsnow » 2005-12-04 15:56

应该是因为xserver-xorg开头的驱动包没有装.
不知道你是怎么装xserver的.试试

代码: 全选

sudo apt-get install xserver-xorg
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2005-12-04 16:02

有x。应该是驱动不对。"GLcore"没有。glx可能又没安装。
● 鸣学
stonethree
帖子: 32
注册时间: 2005-11-04 9:47
来自: 武汉
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 stonethree » 2005-12-04 16:16

我是按照帮助文档里的《小内存系统安装》
只是把icewm换成了fvwm;
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2005-12-04 16:20

我的看看,对比一下。因为你的不确切知道安装了什么。dpkg -l|grep ' x..'
ii x-window-syste 6.8.2-10.1 X Window System core components
ii xbase-clients 6.8.2-10.1 miscellaneous X clients
ii xfce4-icon-the 4.2.1-1 Xfce Standard icon theme
ii xfonts-100dpi 6.8.2-10.1 100 dpi fonts for X
ii xfonts-75dpi 6.8.2-10.1 75 dpi fonts for X
ii xfonts-base 6.8.2-10.1 standard fonts for X
ii xfonts-scalabl 6.8.2-10.1 scalable fonts for X
ii xfs 6.8.2-10.1 X font server
ii xfsprogs 2.6.20-1 Utilities for managing the XFS filesystem
ii xlibmesa-dri 6.8.2-10.1 Mesa 3D graphics library modules [X.Org]
ii xlibmesa-gl 6.8.2-10.1 Mesa 3D graphics library [X.Org]
ii xlibmesa-glu 6.8.2-10.1 Mesa OpenGL utility library [X.Org]
ii xlibs 6.8.2-10.1 X Window System client libraries metapackage
ii xlibs-data 6.8.2-10.1 X Window System client data
ii xloadimage 4.1-14 Graphics file viewer under X11
ii xml-core 0.09 XML infrastructure and XML catalog file supp
ii xmms 1.2.10-2ubuntu Versatile X audio player that looks like Win
ii xorg-common 6.8.2-10.1 X Window System (X.Org) infrastructure
ii xserver-common 6.8.2-10.1 files and utilities common to all X servers
ii xserver-xorg 6.8.2-10.1 the X.Org X server
ii xsltproc 1.1.12-3ubuntu XSLT command line processor
rc xterm 6.8.2-10.1 X terminal emulator
ii xutils 6.8.2-10.1 X Window System utility programs
● 鸣学
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#6

帖子 catinsnow » 2005-12-04 16:52

eexpress 写了:有x。应该是驱动不对。"GLcore"没有。glx可能又没安装。
GLcore应该是没有问题的.

代码: 全选

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o": No symbols found 
这是正常的.

我是指可能xserver-xorg-input-synaptics,xserver-xorg-input-mouse之类的驱动模块包没有装好.而装xserver-xorg包应该可以把一些这样的包装上的.
我dapper里xserver-xorg并不依赖xserver-xorg-input-synaptics,或许还要单独装.

代码: 全选

sudo apt-get install xserver-xorg-input-synaptics
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
freeflying
论坛版主
帖子: 521
注册时间: 2005-03-26 9:38
送出感谢: 0
接收感谢: 0

#7

帖子 freeflying » 2005-12-04 17:42

楼上的我已经回过你了,你的synaptics模块没有正确加载,注释掉
图片
回复

回到 “老旧版本支持”