有没有人实验过删掉5.10的gcc4.0换上gcc3.4??

为当前最终发行版之前的所有版本提供支持
回复
芳芳郁金香
帖子: 179
注册时间: 2005-10-06 18:49
送出感谢: 0
接收感谢: 0

有没有人实验过删掉5.10的gcc4.0换上gcc3.4??

#1

帖子 芳芳郁金香 » 2005-12-04 15:21

如题

被gcc4强烈郁闷 :x :x
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#2

帖子 catinsnow » 2005-12-04 15:48

可以同时用的啊,为什么要删掉呢?
要用gcc-3.4也可以运行:

代码: 全选

ln -s /usr/bin/gcc-3.4 /usr/bin/gcc
上次由 catinsnow 在 2005-12-04 16:24,总共编辑 1 次。
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2005-12-04 16:04

不需要删除的。我都是ln假装各种版本。
● 鸣学
头像
freeflying
论坛版主
帖子: 521
注册时间: 2005-03-26 9:38
送出感谢: 0
接收感谢: 0

#4

帖子 freeflying » 2005-12-04 17:25

为什么要链接,configure时可以指定gcc的。
./configure --help 看看就知道了
现在的系统基本上是给予4.0.1的了,大部分软件都可以用4.0.1来编译的。
图片
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2005-12-04 22:21

有些软件是指定版本的。必须ln个假的。
● 鸣学
头像
yang119345
帖子: 570
注册时间: 2005-06-19 14:22
来自: 上海
送出感谢: 0
接收感谢: 1 次
联系:

#6

帖子 yang119345 » 2005-12-04 23:14

make的时候都可以设置gcc版本的~

多个gcc并存是很常见的呀
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#7

帖子 Element » 2005-12-04 23:18

我好像两个都装了啊,上次不知道装什么的时候需要gcc-3.4,就装了个。
没想到在lin下还有这样的要求,高版本还办不了低版本的事情。
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
freeflying
论坛版主
帖子: 521
注册时间: 2005-03-26 9:38
送出感谢: 0
接收感谢: 0

#8

帖子 freeflying » 2005-12-05 10:43

不要链接,configure时指定
图片
回复

回到 “老旧版本支持”