当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : (软件包有不能满足的依赖关系)这个错误,请问该如何修复
帖子发表于 : 2007-08-09 19:27 

注册: 2007-08-07 20:23
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
好不容易装好,更新好源
执行完这两条命令:
sudo apt-get update
sudo apt-get dist-upgrade
第一条命令速度还可以,但第二条更新软件,一共下载了大概有900多个,从昨晚一直到今天白天一天,刚回家看,全部弄好,不过正准备更新可用更新(即屏幕右上角日期左边那个),点击后就出错了,出错的原因找出来了。如下:

引用:
下列的软件包有不能满足的依赖关系:
belocs-locales-bin: 依赖: libc6 (>= 2.5-0ubuntu1) 但是 2.3.6-0ubuntu20 已经安 装了
lib32gcc1: 依赖: libc6-i386 (>= 2.3.6-7) 但是 2.3.6-0ubuntu20 已经安装了
lib32z1: 依赖: libc6-i386 (>= 2.5-0ubuntu1) 但是 2.3.6-0ubuntu20 已经安装了
python-support: 依赖: python (>= 2.4.3-10) 但是 2.4.2-0ubuntu3 已经安装了
E: 不能满足依赖关系。不妨试一下 -f 选项。


请问该怎么修复?如果可以的话,能否告知为什么会这样?
还有就是,sudo apt-get dist-upgrade这条命令是不是和用鼠标点屏幕右上角那个更新可用更新是不是一样的效果?两者哪个是装好系统后必须要做的?

望高手答复,小弟先谢了!
小生是个新手,请回复稍详细点,谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-09 22:02 

注册: 2007-08-07 20:23
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
怎么没人回复啊?
哦,对了,忘了说我的系统版本了,我的是AMD64位6.06 lts 版本的


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-08-10 0:00 
头像

注册: 2007-07-24 22:23
帖子: 241
送出感谢: 0 次
接收感谢: 0 次
不妨试一下 -f 选项 :D


_________________
Linux 2.6.25-ARCH #1 SMP PREEMPT Mon Jul 14 15:25:51 UTC 2008 i686 GenuineIntel GNU/Linux


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-08-10 14:20 

注册: 2007-08-07 20:23
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上的提醒,那个我当时就试了,还是一样,还是回显:
代码:
belocs-locales-bin: 依赖: libc6 (>= 2.5-0ubuntu1) 但是 2.3.6-0ubuntu20 已经安 装了
lib32gcc1: 依赖: libc6-i386 (>= 2.3.6-7) 但是 2.3.6-0ubuntu20 已经安装了
lib32z1: 依赖: libc6-i386 (>= 2.5-0ubuntu1) 但是 2.3.6-0ubuntu20 已经安装了
python-support: 依赖: python (>= 2.4.3-10) 但是 2.4.2-0ubuntu3 已经安装了

现在主要问题就是这四个文件已经损坏了,本来准备全删了,但一看好多软件全部依赖这几个,要删得删掉很多软件(我是这么理解,或者就是其它一些软件不能用了,新立得显示出来个软件列表),而我也不知道哪些能删,哪些是不能删,所以不敢乱动,想问下,看论坛里有没有哪位兄弟姐妹,能否告诉我一下,这四个包是不是系统必须的,能否删掉,最好是能修复,该怎么修复,谢谢!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: (软件包有不能满足的依赖关系)这个错误,请问该如何修复
帖子发表于 : 2012-09-07 21:01 

注册: 2012-09-07 20:59
帖子: 1
系统: ubuntu
送出感谢: 0 次
接收感谢: 0 次
:em21
同问啊,55555555


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译