(有不能满足依赖关系的软件包)该如何修复?

为当前最终发行版之前的所有版本提供支持
回复
xroot
帖子: 5
注册时间: 2007-08-07 20:23
送出感谢: 0
接收感谢: 0
联系:

(有不能满足依赖关系的软件包)该如何修复?

#1

帖子 xroot » 2007-08-09 22:44

好不容易装好,更新好源
执行完这两条命令:

代码: 全选

sudo apt-get update
sudo apt-get dist-upgrade
第一条命令速度还可以,但第二条更新软件,一共下载了大概有900多个,从昨晚一直到今天白天一天,刚回家看,全部弄好,不过正准备更新可用更新(即屏幕右上角日期左边那个),点击后就出错了,出错的原因找出来了。如下:

代码: 全选

下列的软件包有不能满足的依赖关系:
belocs-locales-bin: 依赖: libc6 (>= 2.5-0ubuntu1) 但是 2.3.6-0ubuntu20 已经安 装了
lib32gcc1: 依赖: libc6-i386 (>= 2.3.6-7) 但是 2.3.6-0ubuntu20 已经安装了
lib32z1: 依赖: libc6-i386 (>= 2.5-0ubuntu1) 但是 2.3.6-0ubuntu20 已经安装了
python-support: 依赖: python (>= 2.4.3-10) 但是 2.4.2-0ubuntu3 已经安装了
E: 不能满足依赖关系。不妨试一下 -f 选项。

请问该怎么修复?如果可以的话,能否告知为什么会这样?
还有就是,sudo apt-get dist-upgrade这条命令是不是和用鼠标点屏幕右上角那个更新可用更新是不是一样的效果?两者哪个是装好系统后必须要做的?

望高手答复,小弟先谢了!
小生是个新手,请回复稍详细点,谢谢!

我的系统版本是AMD 64 6.06 LTS。
回复

回到 “老旧版本支持”