apt-get 故障

为当前最终发行版之前的所有版本提供支持
回复
vision
帖子: 88
注册时间: 2006-04-14 1:12
来自: 上海
送出感谢: 0
接收感谢: 0

apt-get 故障

#1

帖子 vision » 2007-08-14 14:04

sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在筹划升级... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 17 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
您希望继续执行吗?[Y/n]y
正在设置 ttf-opensymbol (2.2.0-1ubuntu4) ...

Updating fontconfig cache...
/usr/share/fonts/X11: failed to write cache
/usr/share/fonts/X11/100dpi: failed to write cache
/usr/share/fonts/X11/75dpi: failed to write cache
/usr/share/fonts/X11/Type1: failed to write cache
/usr/share/fonts/X11/encodings: failed to write cache
/usr/share/fonts/X11/encodings/large: failed to write cache
/usr/share/fonts/X11/misc: failed to write cache
/usr/share/fonts/X11/util: failed to write cache
/usr/share/fonts/truetype: failed to write cache
/usr/share/fonts/truetype/arphic: failed to write cache
/usr/share/fonts/truetype/baekmuk: failed to write cache
/usr/share/fonts/truetype/freefont: failed to write cache
/usr/share/fonts/truetype/kochi: failed to write cache
/usr/share/fonts/truetype/thai: failed to write cache
/usr/share/fonts/truetype/ttf-arabeyes: failed to write cache
/usr/share/fonts/truetype/ttf-bengali-fonts: failed to write cache
/usr/share/fonts/truetype/ttf-bitstream-vera: failed to write cache
/usr/share/fonts/truetype/ttf-dejavu: failed to write cache
/usr/share/fonts/truetype/ttf-devanagari-fonts: failed to write cache
/usr/share/fonts/truetype/ttf-gentium: failed to write cache
/usr/share/fonts/truetype/ttf-gujarati-fonts: failed to write cache
/usr/share/fonts/truetype/ttf-kannada-fonts: failed to write cache
/usr/share/fonts/truetype/ttf-lao: failed to write cache
/usr/share/fonts/truetype/ttf-malayalam-fonts: failed to write cache
/usr/share/fonts/truetype/ttf-mgopen: failed to write cache
/usr/share/fonts/truetype/ttf-oriya-fonts: failed to write cache
/usr/share/fonts/truetype/ttf-punjabi-fonts: failed to write cache
/usr/share/fonts/truetype/ttf-tamil-fonts: failed to write cache
/usr/share/fonts/truetype/ttf-telugu-fonts: failed to write cache
/usr/share/fonts/type1: failed to write cache
/usr/share/fonts/type1/gsfonts: failed to write cache
/usr/share/X11/fonts: failed to write cache
/usr/share/X11/fonts/100dpi: failed to write cache
/usr/share/X11/fonts/75dpi: failed to write cache
/usr/share/X11/fonts/Type1: failed to write cache
/usr/share/X11/fonts/encodings: failed to write cache
/usr/share/X11/fonts/encodings/large: failed to write cache
/usr/share/X11/fonts/misc: failed to write cache
/usr/share/X11/fonts/util: failed to write cache
/usr/local/share/fonts: failed to write cache
/var/lib/defoma/fontconfig.d: failed to write cache
/var/lib/defoma/fontconfig.d/A: failed to write cache
/var/lib/defoma/fontconfig.d/B: failed to write cache
/var/lib/defoma/fontconfig.d/C: failed to write cache
/var/lib/defoma/fontconfig.d/D: failed to write cache
/var/lib/defoma/fontconfig.d/E: failed to write cache
/var/lib/defoma/fontconfig.d/F: failed to write cache
/var/lib/defoma/fontconfig.d/G: failed to write cache
/var/lib/defoma/fontconfig.d/H: failed to write cache
/var/lib/defoma/fontconfig.d/J: failed to write cache
/var/lib/defoma/fontconfig.d/K: failed to write cache
/var/lib/defoma/fontconfig.d/L: failed to write cache
/var/lib/defoma/fontconfig.d/M: failed to write cache
/var/lib/defoma/fontconfig.d/N: failed to write cache
/var/lib/defoma/fontconfig.d/O: failed to write cache
/var/lib/defoma/fontconfig.d/P: failed to write cache
/var/lib/defoma/fontconfig.d/R: failed to write cache
/var/lib/defoma/fontconfig.d/S: failed to write cache
/var/lib/defoma/fontconfig.d/T: failed to write cache
/var/lib/defoma/fontconfig.d/U: failed to write cache
/var/lib/defoma/fontconfig.d/V: failed to write cache
/var/lib/defoma/fontconfig.d/a: failed to write cache
/var/lib/defoma/fontconfig.d/j: failed to write cache
/var/lib/defoma/fontconfig.d/m: failed to write cache
/var/lib/defoma/fontconfig.d/u: failed to write cache
dpkg:处理 ttf-opensymbol (--configure)时出错:
子进程·post-installation script·返回了错误号·65
dpkg:依赖关系问题使得 openoffice.org-core 的配置工作不能继续:
openoffice.org-core 依赖于 ttf-opensymbol;然而:
软件包 ttf-opensymbol 还没有被配置。
dpkg:处理 openoffice.org-core (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 python-uno 的配置工作不能继续:
python-uno 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
dpkg:处理 python-uno (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-writer 的配置工作不能继续:
openoffice.org-writer 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
openoffice.org-writer 依赖于 python-uno (>= 2.2.0);然而:
软件包 python-uno 还没有被配置。
dpkg:处理 openoffice.org-writer (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-calc 的配置工作不能继续:
openoffice.org-calc 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
dpkg:处理 openoffice.org-calc (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-draw 的配置工作不能继续:
openoffice.org-draw 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
dpkg:处理 openoffice.org-draw (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-impress 的配置工作不能继续:
openoffice.org-impress 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
openoffice.org-impress 依赖于 openoffice.org-draw (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-draw 还没有被配置。
dpkg:处理 openoffice.org-impress (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-math 的配置工作不能继续:
openoffice.org-math 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
dpkg:处理 openoffice.org-math (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-base 的配置工作不能继续:
openoffice.org-base 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
dpkg:处理 openoffice.org-base (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org 的配置工作不能继续:
openoffice.org 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
openoffice.org 依赖于 openoffice.org-writer;然而:
软件包 openoffice.org-writer 还没有被配置。
openoffice.org 依赖于 openoffice.org-calc;然而:
软件包 openoffice.org-calc 还没有被配置。
openoffice.org 依赖于 openoffice.org-impress;然而:
软件包 openoffice.org-impress 还没有被配置。
openoffice.org 依赖于 openoffice.org-draw;然而:
软件包 openoffice.org-draw 还没有被配置。
openoffice.org 依赖于 openoffice.org-math;然而:
软件包 openoffice.org-math 还没有被配置。
openoffice.org 依赖于 openoffice.org-base;然而:
软件包 openoffice.org-base 还没有被配置。
dpkg:处理 openoffice.org (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-evolution 的配置工作不能继续:
openoffice.org-evolution 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
openoffice.org-evolution 依赖于 openoffice.org-base;然而:
软件包 openoffice.org-base 还没有被配置。
dpkg:处理 openoffice.org-evolution (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-gtk 的配置工作不能继续:
openoffice.org-gtk 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
dpkg:处理 openoffice.org-gtk (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-gnome 的配置工作不能继续:
openoffice.org-gnome 依赖于 openoffice.org-core (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-core 还没有被配置。
openoffice.org-gnome 依赖于 openoffice.org-gtk;然而:
软件包 openoffice.org-gtk 还没有被配置。
dpkg:处理 openoffice.org-gnome (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 linux-libc-dev (2.6.20-16.29) ...
正在设置 libc6-dev (2.5-0ubuntu14) ...
正在设置 dpkg-dev (1.13.24ubuntu6) ...
dpkg:依赖关系问题使得 openoffice.org-common 的配置工作不能继续:
openoffice.org-common 依赖于 openoffice.org-core (>> 2.2.0) | openoffice.org-core-experimental (>> 2.2.0);然而:
软件包 openoffice.org-core 还没有被配置。
未曾安装软件包“openoffice.org-core-experimental”。
dpkg:处理 openoffice.org-common (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-java-common 的配置工作不能继续:
openoffice.org-java-common 依赖于 openoffice.org-common;然而:
软件包 openoffice.org-common 还没有被配置。
dpkg:处理 openoffice.org-java-common (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-filter-mobiledev 的配置工作不能继续:
openoffice.org-filter-mobiledev 依赖于 openoffice.org-java-common (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-java-common 还没有被配置。
dpkg:处理 openoffice.org-filter-mobiledev (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-style-human 的配置工作不能继续:
openoffice.org-style-human 依赖于 openoffice.org-common (= 2.2.0-1ubuntu4);然而:
软件包 openoffice.org-common 还没有被配置。
dpkg:处理 openoffice.org-style-human (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 libstdc++6-4.1-dev (4.1.2-0ubuntu4) ...
正在设置 g++-4.1 (4.1.2-0ubuntu4) ...
正在设置 g++ (4.1.2-1ubuntu1) ...

正在设置 build-essential (11.3) ...
在处理时有错误发生:
ttf-opensymbol
openoffice.org-core
python-uno
openoffice.org-writer
openoffice.org-calc
openoffice.org-draw
openoffice.org-impress
openoffice.org-math
openoffice.org-base
openoffice.org
openoffice.org-evolution
openoffice.org-gtk
openoffice.org-gnome
openoffice.org-common
openoffice.org-java-common
openoffice.org-filter-mobiledev
openoffice.org-style-human
E: Sub-process /usr/bin/dpkg returned an error code (1)


每次apt-get后就出现的错误

好像是新装软件后更新fontconfig cache

这个要怎么解决?
图片
the flying flower
that
changes the colour of my day
头像
jqrrwaje
帖子: 22
注册时间: 2007-07-23 13:41
来自: 湖南省
送出感谢: 0
接收感谢: 0

#2

帖子 jqrrwaje » 2007-08-14 20:46

apt-get update
apt-get dist-upgrade
vision
帖子: 88
注册时间: 2006-04-14 1:12
来自: 上海
送出感谢: 0
接收感谢: 0

#3

帖子 vision » 2007-08-15 3:23

发上来之前就试过

另外fc-cache也弄过

问题依旧

刚重装,又来了
图片
the flying flower
that
changes the colour of my day
Ken488
帖子: 24
注册时间: 2006-09-04 19:09
送出感谢: 0
接收感谢: 0

#4

帖子 Ken488 » 2007-08-16 2:51

好像是时间问题,我也有这个问题,再好的解决方法就是安装系统前把主板时间调后来安装系统,安装完系统重启时把时间调回现在的时间!这个方法一定可以! :P
头像
jqrrwaje
帖子: 22
注册时间: 2007-07-23 13:41
来自: 湖南省
送出感谢: 0
接收感谢: 0

#5

帖子 jqrrwaje » 2007-08-16 21:49

重装apt
vision
帖子: 88
注册时间: 2006-04-14 1:12
来自: 上海
送出感谢: 0
接收感谢: 0

#6

帖子 vision » 2007-08-18 22:55

Ken488 写了:好像是时间问题,我也有这个问题,再好的解决方法就是安装系统前把主板时间调后来安装系统,安装完系统重启时把时间调回现在的时间!这个方法一定可以! :P
恩。搞定!谢谢这位兄弟!!!
图片
the flying flower
that
changes the colour of my day
tjuhzjemail
帖子: 1
注册时间: 2007-09-10 12:46
送出感谢: 0
接收感谢: 0

你好

#7

帖子 tjuhzjemail » 2007-09-10 22:44

vision


难道必须重装才能搞定??
回复

回到 “老旧版本支持”