[问题]Ubuntu下安装JDK的问题,请大家帮忙看看

为当前最终发行版之前的所有版本提供支持
回复
release2006.study
帖子: 2
注册时间: 2007-08-14 16:20
送出感谢: 0
接收感谢: 0

[问题]Ubuntu下安装JDK的问题,请大家帮忙看看

#1

帖子 release2006.study » 2007-08-14 16:27

这几天我安装了Ubuntu7.0.4,然后想在该操作系统下安装JDK。于是我从SUN主页上下载了jdk-6u2-linux-i586-rpm.bin 这个文件。
但我在root权限下用命令:bash jdk-6u2-linux-i586-rpm.bin 进行安装的时候,却出现了下面的错误提示:
inflating: jdk-6u2-linux-i586.rpm
inflating: sun-javadb-common-10.2.2-0.1.i386.rpm
inflating: sun-javadb-core-10.2.2-0.1.i386.rpm
inflating: sun-javadb-client-10.2.2-0.1.i386.rpm
inflating: sun-javadb-demo-10.2.2-0.1.i386.rpm
inflating: sun-javadb-docs-10.2.2-0.1.i386.rpm
inflating: sun-javadb-javadoc-10.2.2-0.1.i386.rpm
error: 依赖性检测失败:
/bin/basename 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/cat 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/cp 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/gawk 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/grep 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/ln 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/ls 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/mkdir 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/mv 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/pwd 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/rm 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/sed 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/sort 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/touch 被 jdk-1.6.0_02-fcs.i586 所需要
/usr/bin/cut 被 jdk-1.6.0_02-fcs.i586 所需要
/usr/bin/dirname 被 jdk-1.6.0_02-fcs.i586 所需要
/usr/bin/expr 被 jdk-1.6.0_02-fcs.i586 所需要
/usr/bin/find 被 jdk-1.6.0_02-fcs.i586 所需要
/usr/bin/tail 被 jdk-1.6.0_02-fcs.i586 所需要
/usr/bin/tr 被 jdk-1.6.0_02-fcs.i586 所需要
/usr/bin/wc 被 jdk-1.6.0_02-fcs.i586 所需要
/bin/sh 被 jdk-1.6.0_02-fcs.i586 所需要
Installing JavaDB
error: 依赖性检测失败:
/bin/sh 被 sun-javadb-core-10.2.2-0.1.i386 所需要

我是Linux菜鸟,希望各位帮我看看为什么会出现这样的错误,该如何解决。谢谢!!!!
头像
ofewiofewo
帖子: 547
注册时间: 2007-06-02 14:56
送出感谢: 0
接收感谢: 0

#2

帖子 ofewiofewo » 2007-08-14 16:29

apt-get install sun-java6-jdk
release2006.study
帖子: 2
注册时间: 2007-08-14 16:20
送出感谢: 0
接收感谢: 0

#3

帖子 release2006.study » 2007-08-14 16:37

谢谢ofewiofewo的解答~~按照你的方法已经顺利的安装了JDK了。
可否请问一下这两种安装方式有什么区别?我原先的安装方法犯了什么错误呢?
谢谢。
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#4

帖子 xhy » 2007-08-14 16:41

jdk-6u1-linux-amd64.bin

你应该下载类似的bin文件 不是rpm.bin
目前负债150多万
头像
patrickhe
帖子: 681
注册时间: 2005-07-21 19:13
来自: Peking, China
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 patrickhe » 2007-08-14 16:49

Ubuntu 下,尽量用 apt 安装。如果源内的 package 不能满足要求的话,再去尝试其他安装方式。
我想,大多数用电脑的目的不是为了安装软件,而是使用软件,apt 就是为简化 Linux 下软件安装步骤而设计的,所以既然使用了 Ubuntu 这样的 Debian-like 的系统,就欢欢喜喜地利用好这个便利吧。
回复

回到 “老旧版本支持”