运行acroread提示找不到文件

为当前最终发行版之前的所有版本提供支持
回复
头像
bearscafe
帖子: 694
注册时间: 2007-05-05 23:11
送出感谢: 2 次
接收感谢: 0

运行acroread提示找不到文件

#1

帖子 bearscafe » 2007-08-15 19:56

昨天重装了系统,安装了AcroReader后,在终端执行acroread,系统提示:
exec: 937: /usr/local/Adobe/Acrobat7.0/Reader/intellinux/bin/acroread: not found
但是,我看了一下, /usr/local/Adobe/Acrobat7.0/Reader/intellinux/bin/acroread这个文件确实是存在的:
-rwxr-xr-x 1 root root 20307580 2006-05-23 06:08 acroread
这是怎么回事呢?谢谢!
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 ct » 2007-08-15 20:49

代码: 全选

ctqucl@feisty:~$ acroread 
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
expr: 写入时发生错误
并不比你更正常 :lol:
头像
bearscafe
帖子: 694
注册时间: 2007-05-05 23:11
送出感谢: 2 次
接收感谢: 0

#3

帖子 bearscafe » 2007-08-16 4:55

二楼的问题可以在网上找到解决方案,摘抄如下:
一直以来看PDF都是用acroread的,没有编码的问题,中文显示也非常舒服,运行非常正常。但是就在前两天忽然之间就发现acroread用不了了,在终端下运行acroread,重复出现如下提示,CPU占用100%,要kill掉才行,重新安装也是这样。
引用
expr:写入时发生错误

后来在网上google了一下才发现,原来这是acroread的一个bug,并不是所有用户都会触发,是跟libgtk的版本有点关系。acroread对libgtk的版本的校验有问题,似乎出现死循环。
只需要修改acroread的可执行文件就可以解决。
sudo vim /usr/local/Adobe/Acrobat7.0/bin/acroread

找到下面这一行
echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'

修改成下面这样就行了,就加了一个*号。
echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00*.\([0-9]*\)\|\(.*\)/\1\2\3/g'

如果你用的是scim,最好在脚本里面也加上这么一句,用fcitx的就不用加了。
GTK_IM_MODULE=xim
tomguy
帖子: 702
注册时间: 2005-09-27 10:32
送出感谢: 0
接收感谢: 0

#4

帖子 tomguy » 2007-08-16 13:11

在那个目录直接运行?
回复

回到 “老旧版本支持”