当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ./configure出什么问题了??????
帖子发表于 : 2007-08-16 15:04 

注册: 2007-07-26 23:49
帖子: 63
地址: 中国广州
送出感谢: 0 次
接收感谢: 0 次
为什么会这样????当我输入 ./configure时候就这样,如下,请看:
root@ubuntu-desktop:~/Downloads/eva# ./configure
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking target system type... i686-pc-linux-gnulibc1
checking for a BSD-compatible install... /usr/bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables


See `config.log' for more details.
root@ubuntu-desktop:~/Downloads/eva# make
make: *** 没有指明目标并且找不到 makefile。 停止。 :?: :?: :?: :?: :?: :?: :?: :?: :?: :?: :?: :?:



有那位高人帮我一下,还有个问题:是不是当我们使用./configure时候,如果后面没有加上路径的话,也就是没有这样:
./configure --prefix=path,他会把安装后的东西放在那里?是不是放在/usr/local下面阿???

两跟问题:请赐教!!!!!!!!!!!!


_________________
我是个刚刚接触ubuntu的人,很多东西都还是一团雾水,希望在以后的日子里能与大家建立一种互帮互助的气氛,谢谢大家的支持


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-16 15:15 

注册: 2005-12-02 22:08
帖子: 125
地址: 毛里求虱
送出感谢: 0 次
接收感谢: 0 次
别急,你仔细搜一下论坛,搜‘eva’就好了,这类似编译问题已经被问过N次了。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-08-16 16:09 
头像

注册: 2007-04-28 21:38
帖子: 1026
送出感谢: 0 次
接收感谢: 0 次
用apt-build不久可以将所有编译时要用的包都装上了 吗?


_________________
thinkpad x61 2G DDR no cdrom
--------------------------------------------
ABS学习中
sed学习中
awk学习中
perl学习中
新手描述不清,老手猜测不到,胡乱指挥一通,后果难以预料


页首
 用户资料  
 
4 楼 
 文章标题 : 无法安装编译环境阿
帖子发表于 : 2007-08-16 16:12 

注册: 2007-07-26 23:49
帖子: 63
地址: 中国广州
送出感谢: 0 次
接收感谢: 0 次
root@ubuntu-desktop:~/Downloads/eva# apt-get install libiconv.so.2
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
E: 无法找到软件包 libiconv.so.2
root@ubuntu-desktop:~/Downloads/eva# apt-get install gcc libc6-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
gcc 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.4-1ubuntu12.3) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包
root@ubuntu-desktop:~/Downloads/eva# apt-get install libc6-dev


无法安装编译环境阿
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.4-1ubuntu12.3) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包


如何解决上述问题?????xi谢谢


_________________
我是个刚刚接触ubuntu的人,很多东西都还是一团雾水,希望在以后的日子里能与大家建立一种互帮互助的气氛,谢谢大家的支持


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译