当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如何解决软件包的依赖问题???
帖子发表于 : 2007-08-16 16:08 

注册: 2007-07-26 23:49
帖子: 63
地址: 中国广州
送出感谢: 0 次
接收感谢: 0 次
root@ubuntu-desktop:~/Downloads/eva# apt-get install libiconv.so.2
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
E: 无法找到软件包 libiconv.so.2
root@ubuntu-desktop:~/Downloads/eva# apt-get install gcc libc6-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
gcc 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.4-1ubuntu12.3) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包
root@ubuntu-desktop:~/Downloads/eva# apt-get install libc6-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.4-1ubuntu12.3) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包


如何解决上述问题?????xi谢谢


_________________
我是个刚刚接触ubuntu的人,很多东西都还是一团雾水,希望在以后的日子里能与大家建立一种互帮互助的气氛,谢谢大家的支持


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-16 16:51 
头像

注册: 2006-10-21 12:03
帖子: 1746
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo apt-get update

代码:
sudo apt-get -f install


_________________
.

私人空间
附有 Magic Linux 2.1 最新开发日志~
引用:


미안하다, 사랑한다




欢迎来 #xfce-cn 中文频道~~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译