挂载windows分区后中文显示不了

为当前最终发行版之前的所有版本提供支持
回复
头像
BurnSprit
帖子: 184
注册时间: 2007-08-10 21:13
送出感谢: 0
接收感谢: 0

挂载windows分区后中文显示不了

#1

帖子 BurnSprit » 2007-08-16 17:39

我按照教程挂载好了windows分区,进去好可以顺利操作,但是里面的中文文件名显示都是???,有没有办法解决呢
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#2

帖子 leeaman » 2007-08-16 19:21

/etc/fstab

代码: 全选

  GNU nano 2.0.6              文件: /etc/fstab                                  

# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=9a014549-7ebb-44ee-8f88-c67c3f955a41 / reiserfs notail 0 1
# Entry for /dev/sda6 :
UUID=2f9601aa-c49d-43bc-a875-e08ea5e8d4d6 /home reiserfs defaults 0 2
# Entry for /dev/sdb1 :
UUID=2860F56960F53E5E /media/sdb1 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
# Entry for /dev/sdb5 :
UUID=56144007143FE89F /media/sdb5 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
# Entry for /dev/sdb6 :
UUID=98804D6C804D51C4 /media/sdb6 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
# Entry for /dev/sdb7 :
UUID=B47C06047C05C1DA /media/sdb7 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
locale=zh_CN.UTF-8是不是这个原因
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
BurnSprit
帖子: 184
注册时间: 2007-08-10 21:13
送出感谢: 0
接收感谢: 0

#3

帖子 BurnSprit » 2007-08-16 22:54

不好意思啊,新手啊,上面那段内容还看不明白啊,是不是说我的字体格式设置不对
头像
BurnSprit
帖子: 184
注册时间: 2007-08-10 21:13
送出感谢: 0
接收感谢: 0

#4

帖子 BurnSprit » 2007-08-17 14:56

哪位再给点提示呀,上面那段代码是不是要用编辑器来看的啊
头像
warlocklau
帖子: 18
注册时间: 2007-08-10 16:18
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 warlocklau » 2007-08-17 15:08

1:查看你的win分区是sd?
2:sudo gedit /etc/fstab
/media/sdb7 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
修改下即可
嘛叫个性签名?
LINUX乐园,QQ群:18515236 ^_^
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 ct » 2007-08-17 15:08

sudo gedit /etc/fstab
头像
BurnSprit
帖子: 184
注册时间: 2007-08-10 21:13
送出感谢: 0
接收感谢: 0

#7

帖子 BurnSprit » 2007-08-17 17:42

我的的window分区是fat的,是hda硬盘
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 hualang0929 » 2007-08-17 17:47

挂载参数加上utf8,类似下面

代码: 全选

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,utf8     0       0
抬头望星空一片晴,我独行,夜已渐寒……
头像
BurnSprit
帖子: 184
注册时间: 2007-08-10 21:13
送出感谢: 0
接收感谢: 0

#9

帖子 BurnSprit » 2007-08-17 20:13

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda7 / ext3 defaults,errors=remount-ro 0 1
/dev/hda8 /home ext3 defaults 0 2
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hda5 /media/D vfat defaults,umask=0000 0 0
/dev/hda9 /media/E vfat defaults,umask=0000 0 0

我是看官方说明这样子的啊,加了那个utf8就挂不了了
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 hualang0929 » 2007-08-17 20:32

那就不清楚了,
手动挂载试试咯
抬头望星空一片晴,我独行,夜已渐寒……
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#11

帖子 BigSnake.NET » 2007-08-17 20:36

代码: 全选

UUID=445C-A61B /windows vfat defaults,utf8,umask=007,gid=46 0 0
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
BurnSprit
帖子: 184
注册时间: 2007-08-10 21:13
送出感谢: 0
接收感谢: 0

#12

帖子 BurnSprit » 2007-08-21 23:06

好久没上来了,谢谢上面这么多位的帮忙啊,问题已经解决了
我后来发现wiki里面也有说明的,把代码改成下面的就行了

/dev/hda9 /media/E vfat iocharset=utf8,umask=0000 0 0
回复

回到 “老旧版本支持”